Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: FFOW Performance?

07 Dec 2010   #1
Buck11

Window 7 Home Premium (64bit)
 
 
FFOW Performance?

Hi, I just got Windows 7 home premium and installed FFOW and the lag online is just unplayable no matter what settings I try in the game or with the latest CCC. I had this game playing great on XP 32bit, but now can barely play it. I tried the troubleshooter and tried complatibility modes xp sp2, and vista sp2, and as admin, and I tried what other reported to work... task manager and setting priority to low, but it gives me an error and changes nothing.
I've installed other games just fine and they look better and play good, except FFOW... and the worst part of all this searching and posting and trial and error testing is that I can see the windows logo on the FFOW box and it says, "GAMES FOR WINDOWS" !!!!! LOL

Anyway, I'm at a loss and hoping someone knows what to do, or something else I can try. Thanks.

This is my set-up:

Asus M3A
Amd Athalon X2 Dual Core 6000+ (3.0Ghz)
ATI Radeon HD4850 512mb
2X1 GB Ballistix Tracers pc8500
2X1 GB KVR pc6400
Seagate 500GB Sata
LD DVD Lightscribe Burner
OCZ 850w GameXstream
LG 20.1 Flatron Wide LCD


My System SpecsSystem Spec
.
08 Dec 2010   #2
OldMX

Microsoft Windows 10 Professional / Windows 7 Professional
 
 

Make sure you install the latest driver release for your sound card and the latest release of OpenAL from creative, doing this prevents many issues with the game.
My System SpecsSystem Spec
08 Dec 2010   #3
Buck11

Window 7 Home Premium (64bit)
 
 

Hi, thank you for responding. I made sure they were up to date and tried the game but no difference. Still stutters and lags like crazy. I uninstalled and reinstalled FFOW and the patches last night, and now the shortcut doesn't even work. I had to go right to the directory and click the icon there and set it in compatibility mode for XP SP3, then it would start, but only from that icon in the directory.
I was wondering if it has something to do with the Ageia PhysX... maybe it's running an updated version in win7 and not running in compatibilty mode like the game is set to XP SP3...? If that makes sense, I dunno lol.
My System SpecsSystem Spec
.

Reply

 FFOW Performance?




Thread Tools




Similar help and support threads
Thread Forum
Intel 520 SSD, low performance, high performance, then low again...?
I just now installed an Intel 520 240GB SSD. Measuring the performance, got strange results. First it did not at all perform close to my expectations and Intels promises:...
Hardware & Devices
TDU 2 performance is below par
So as the days go by Crossfire is beginning to annoy me more and more; I have the latest CAP Profiles installed and with 2 instances of GPU-Z open, the second card isn't be loaded much if at all. I'm seeing frames in the 40's and it's not making any sense to me at all. I should make mention that...
Gaming
SSD Performance
Hi all, I am a bit of a noob and I am looking for some help with understanding whether or not I have my system configured for optimal performance of my SSD drive. The performance I am currently getting seems quite low. Below are what I understand to be the relevant components involved: ...
Performance & Maintenance
Performance Has Changed To Performance Moniter
I am going through sql server 2005 implemetation and maintenance book. On chapter 15 it is going through useing performance moniter. which was about long before windows 7. Now ive got up to specifying my counters but i cannot find options to: 1. Set the inteval to one second. 2....
Performance & Maintenance
low performance
hello i want to declare that i very unsitisfied with the performance of my laptop with win 7 x64: 1.most of the time i see that my CPU usage is high 2.on new games on highest settings the game runs slow and i have tried the new wolfenstein and on highest settings its slow while my friend with the...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App