Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Game seems to run but dosent show up

07 Dec 2010   #1

Windows 7 Home premium 32bit
Game seems to run but dosent show up

Ok ive loaded Dungeon Seige 2 and It ran fine the first day I got the laptop. I recently tried to play the game and when I insert the disk the game run screen comes up but when I run the application the screen flashes quick then windows comes back up and the program is running in the task manager but I cant see the game so i ended the task and tried running the game in a lower resolution and the same thing happened except when i started the program windows went to the lower resolution like the game should have and the program was running in task manager. When I ended the program windows went back to its previous resolution. So the game seems like its running but in the background somewhere i cant see it. Plus I sometimes hear Verizon commercial real low out of the speakers but cant seem to find where thats coming from either.

I dont have my specs on the computer at the moment but I wanted to get the ball rolling since I think its just a setting issue and Im not familiar with 7 yet. Well I hope ive given adequate information untill I can get home to the laptop in question.

My System SpecsSystem Spec
07 Dec 2010   #2

Windows 7 Ultimate 32-Bit

Have you tried running the game with compatibility functions turned on? I tend to run my games with "Administrator" checked in the "Properties" box. 9 times out of 10 the game will work for me just fine with that option alone, even if the game will run without it checked anyway.
My System SpecsSystem Spec
08 Dec 2010   #3

Windows 7 Home premium 32bit

Ive tried that and it seems to work for a split second but just dosent come up. Im thinking I have a virus on the laptop cause when I try to go onto the seven forums it redirects me to some goofy website.
My System SpecsSystem Spec

08 Dec 2010   #4

Windows 7 Ultimate 32-Bit

Then you've got some virus. What type of virus is it? What website does it redirect you to?
My System SpecsSystem Spec

 Game seems to run but dosent show up

Thread Tools

Similar help and support threads
Thread Forum
Show me your favorite game fails!
Here I would like to post all our favorite video game fails/bloopers/glitches or whatever else have you. you can post any game from Tetris to Titanfall. Just whatever you find funny. If you don't think what I have is funny than show me what you think funny is. We all need some entertainment. I...
Enabled EIST dosent show in the my Computer properties Win 7 ?
hi folks i have enabled my EIST (Enhanced Intel Speedup Technology) via BIOS but on windows 7 properties it wont show it always show the actuall reading of the processor which 3.0ghz and if i chk my cpu-z reading it shows that its working fine according to EIST so how can i fix this problem, so i...
PC Custom Builds and Overclocking
my pc runs but dosent start anything
my pc starts but nothing starts not even the wallpaper nor the toolbar i can move the mouse and click crtl Lshift and del to start task manager but when i try to use explorer it says cant find , but i can start any other exe from there my antivirus dosent find any virus and occasionally my screen...
System Security
Next human vs. machine battleground: game show Jeopardy!
Could be interesting. Read more and see a video: Next human vs. machine battleground: game show Jeopardy! - SmartPlanet
WMC dosent show avi files
When i add library folder to video where my AVI files are it pulls up the avi files sub folder but shows zero contents in the folder when there is a avi file to be played in it. The files are playable in WMP thru sharks application but can not play in WMC I could plays avi files in vista media...
Media Center
QEMU dosent like Windows 7
Just for future reference, build 7000 of Windows 7 dosent work with QEMU, I set up a machine with the ISO in the virtual disk drive and set it to boot from said ISO but it didnt want to run. I downloaded the latest version of VirtualBox and that worked fine, by the way :)

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App