Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Warcraft III unable to initialize DirectX

05 Jan 2011   #1

Dual Booting Windows 7 64-Bit Ultimate Edition and Fedora 16.
Warcraft III unable to initialize DirectX

I am having this trouble with launching Warcraft III. Whenever i launch the game it show an error that it is unable to initialize DirectX.

I have read solutions in "DotA forums".
Things i have done.

1. Reinstalled DirectX with the setup included in "NFS Hot Pursuit"(and many other games)

2. Reinstalled ATI graphic drivers.(Ver 10.12)

3. Restarted the computer several times.

4. Done updating DirectX with dxwebsetup.exe.

Things that could help.

1. When running dxdiag i do not get the test option in *ANY* of the tabs.

2. This problem started when i restarted my computer after connecting a new display.(I first connected it when it was already started, then i restarted my computer)

3. Reinstalled my Graphic driver.

4. In the forums i read it shows that the problem is related with Direct3D.

5. I havent installed the driver that came with the monitor.

Seeking fast reply.
Game to play.


My System SpecsSystem Spec
05 Jan 2011   #2

Windows 7 x64 (Ultimate)

Have you tried reinstalling the Warcraft game and installing DirectX when it prompts you to do so?
My System SpecsSystem Spec

 Warcraft III unable to initialize DirectX

Thread Tools

Similar help and support threads
Thread Forum
DirectX problem in Warcraft 3 TFT
Hello to everyone! This is my problem: an old game, Warcraft 3 TFT, is not running in my current PC. When I try to run it, it always shows this message: "Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer installed and that you display drivers are current....
Unable to initialize error 0x20000017 1-click
I use 1-click which is from and I get the above message at Windows startup. Any ideas. Have re-installed application.
Unable to initialize the external drive in Windows 7
Hi, I have an WD Elements 1023 external hard drive which I want to connect to my laptop which runs a 64 bit Windows 7 Home Premium. When I connect the device, it shows up in the device manager and the driver is installed properly. However, it doesnt show up as a drive and in the Disk...
Hardware & Devices
Unable to initialize external HDD in Disk Management due to I/O error
Hi All, I've recently ran into an almost identical problem that was described (but not resolved) in this thread. In my case, the drive worked perfectly with my system and only recently stopped appearing in My Computer. Also, my drive is still visible and accessible on Windows XP but is not...
Hardware & Devices
Unable to initialize external HDD in Disk Management due to I/O error
Hi all, I am hoping someone would be able to help me out on this problem. I'm running Windows 7 Ultimate 64 bit. Problem: Windows detects my external HDD but doesn't show up in My Computer. Drive is detected in Disk Management, indicated as "not initialized". When I try to initialize the drive,...
Hardware & Devices
unable to initialize Disk - because of an I/O error
Hi, EDIT: USB to IDE sucks badly! If you have a choice get an external HDD enclosure better! I am trying to connect a 250 GB IDE HDD to my laptop by using an "USB to IDE" adapter the disk is recognized by seven, but when i go to "Disk management" and try to initialize it, i get this error...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App