Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Medal of Honor Allied Assault... mouse issues

22 Jan 2011   #1

Windows 7 x64 (Ultimate)
MoH Allied Assault... G9 issues [Solved]

So, after doing away with all the CoD games, I undusted my MoHAA and installed it, I also installed patch 1.1

Installation went well, didn't even need to set it to Comp. Mode, the only thing is that I can not play it at 1680 x 1050, have to settle for 1084 x 768... oh well.

My main concern is that somehow, the game does not want to play well with my Logitech G9 mouse... I am having an extremely hard time centering the mouse on the enemy or any target.

I can move the mouse fairly quick but when I try to aim the crossfires to an enemy ai, it takes me at least 3 to 5 secs, sometimes more and well, by that time... I am already dropped on the ground dead.

Anybody has any suggestions? I seriously don't want to see if I have an old ps2 mouse more so when the original CoD is as old as this game was and I didn't have this problem.

My System SpecsSystem Spec
23 Jan 2011   #2

Windows 7 Home Premium x64

Is the game simply not responding to your clicks, or does it freeze/slow down or something?
Quake 3 engine is ancient, you know, I had a very hard time getting MOHAA to load a level at all; but using a simple PS2 mouse is actually just what you need to determine what's the problem.
My System SpecsSystem Spec
23 Jan 2011   #3

Windows 7 Ultimate x64 Service Pack 1

Odd. MOHAA runs fine with my USB mouse.

I'd recommend using a PS/2 mouse as that should overcome the issue. Actually, something similar did happen to me...except the issue was with Windows itself and just about every game or application I had.

If your mouse has any sensitivity options, try tweaking them a little (I think MOH has some settings for mouse via the options menu.)
My System SpecsSystem Spec

23 Jan 2011   #4

Windows 7 x64 (Ultimate)

Ingame Options, even with the mouse at full Speed Sensitivity, the mouse moves very slow but enough to get to pin point the options or objectives I need, I can move the mouse across the screen fine. The problem lies when you want to move the crosshairs to line up with the enemy ai (center the mouse so to speak), this takes forever.

I guess moving the mouse fast is not the issue, moving the mouse slow is... centering the crosshairs slow to line up the sights to your enemy is when I start panicking

Wouldn't you know it, I did a spring cleaning a while ago and I dump all my old hardware, I have to go ask a friend for an old ps2 now. Murphy... such a bitch
My System SpecsSystem Spec
23 Jan 2011   #5

Windows 7 x64 (Ultimate)

Well, this is a total drag and annoying to say the least. I have read many sites and nobody seems to be having this problem. I have even gone to compatible XP w/SP 2 mode and it helped a bit but still, I am having to Quick Save every time I kill an enemy, then, I am having to die a few times to find out where the enemy will show up and kind of guess where he will show up next and hope that my bullets will get there before he kills me.

Oh well, I will continue my endeavor and I hope that I can find some answers.
My System SpecsSystem Spec
25 Jan 2011   #6

Windows 7 x64 (Ultimate)

Just to add that the problem was finally solved by installing "Game Booster". I still can't believe that did the trick, really.

It disabled something that was working on the background that was interfering with the game but I don't know what exactly it was since it disabled a bunch of stuff.

anyways, thumbs up for Game Booster and older games.
My System SpecsSystem Spec

 Medal of Honor Allied Assault... mouse issues

Thread Tools

Similar help and support threads
Thread Forum
Medal of Honor: Allied Assault crashes to the desktop
I'm on a FPS binge lately, yet Allied Assault will not work at all. Battlefield 1942, Return to Castle Wolfenstein, MoH Airborne, and CoD1 and its United Offensive expansion pack all work perfectly. Allied Assault on the other hand simply crashes the moment I click on it. The screen will go...
Medal of Honor Pacific Assault has no video, but sound playing
I'm trying to play Metal of Honor Pacific Assault on an i5 2500k machine with 16 MB of memory and a ATI HD 6870 video card. When I launch the game I have no video, I can hear the sound of the game starting "EA Games, challenge everything" and then the demo starts, but no video. I tried...
Medal of Honor: Allied Assault expansions can't adjust options
I recently got the Medal of Honor 10th anniversary package, and all of the games work fine, minus the 2 expansions for Allied Assault (Spearhead and Breakthrough). The games themselves run well enough, however I can't adjust any of the options. This is really a deal breaker for me, because I just...
Medal of Honor and ATI Crossfire Issues. Thoughts?
First off, I'll start by saying I just got a new computer about 3 days ago. Previous to this I was playing MOH on my old Asus Crossfire board, a single core 2.0ghz AMD and 3gb of DDR1 RAM and a single PCIe slot ATI Radeon HD3870 X2 card. Crossfire mode WORKED. I got a little sick of the lag so I...
medal of honor allied assault on X64
Here is my issue: I installed MOHAA (medal of honor allied assault) on a few computers with windows 7. Each of them did the same thing. It installed to both program files. In the x86 program files it has the most of the install, however this install is missing 4 folders which go into the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:14.
Twitter Facebook Google+