Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BC2....

20 Jun 2011   #1
simmo

Windows 7 Professional 64 bit
 
 
BC2....

I have issues with BC2 since I reinstalled the game. Pb has been updated and now kicks ppl for "key packet loss" which in itself is a pain in the butt.

Problem is game does'nt appear to save properly..I am unlocking the motion sensor then I'm not,I'm Lv 1 then I'm Lv 31 (correct). Doesn't save password or auto login either.

If EA can't/don't do anything to fix the crap netcode and the random shut downs on ppl's connections I'm not sure why anyone would want to buy BC3 given EA aren't about to fix either code or servers so these issues will be ongoing.

Nothing I can do about my ISP who also suck bigtime tho I hope to be on ADSL soon and I hope a fixed line connection resolves the Pb issue re packet loss.

I sorta remember changing permissions so this game can write as I think it's read only but I'm not sure on this. Anyone know if this is needed? At least I think this was the game I did the permissions change on.


My System SpecsSystem Spec
.
20 Jun 2011   #2
NotYourHero

Windows 7 ultimate x64
 
 

This sounds like a problem with your pc to ea servers. I have been playing BC2 on w7 for like a year now and it runs perfectly. No issues unless EA servers are down/messed up.

As far as netcode goes, this has nothing to do with them and is an issue with the server you are on. EA does not control game servers, users do. No one plays on EA servers anyway. Search =2ez=, they are a good server.
My System SpecsSystem Spec
20 Jun 2011   #3
simmo

Windows 7 Professional 64 bit
 
 

Quote   Quote: Originally Posted by NotYourHero View Post
This sounds like a problem with your pc to ea servers. I have been playing BC2 on w7 for like a year now and it runs perfectly. No issues unless EA servers are down/messed up.

As far as netcode goes, this has nothing to do with them and is an issue with the server you are on. EA does not control game servers, users do. No one plays on EA servers anyway. Search =2ez=, they are a good server.
No doubt a lot of the issues within au are caused by my ISP and there shoddy network. However due to where I live I don't have a lot of choice in ISP's..it's Telstra or nothing.

EA's servers are rubbish tho..according to a poster on another forum he has checked using some traffic monitoring software and he has found the issues are mainly on EA's end.

And =2ez= is located where? The US? That would cause more problems due to latency. That's mostly why I stopped playing WoW cause bloody Blizzard refuse to have the game hosted in Au despite there claims to the contrary.
My System SpecsSystem Spec
.

Reply

 BC2....




Thread Tools



Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App