Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: getting an error : "d3d9.dll is missing"

23 Sep 2011   #1

Windows 7 Ultimate
getting an error : "d3d9.dll is missing"

Hello Friends,

I've been getting an error : "d3d9.dll is missing" while trying to run/play CivCity Rome (Civilisation City Rome). Following are the screenshots of the error, dxdiag result, resolution that i tried.

This is the error message while trying to run the CivCityRome.exe file. I also tried = Right Click > Select "Take Ownership" from Context Menu > Run as Administrator
from Context Menu. Still getting same error.

getting an error : "d3d9.dll is missing"-1.jpg

So i tried to identify the version of DirectX update installed on computer since its been a longtime. Run > dxdiag > enter. Here is the result of the search. I'm using DirectX 11 version & not sure if i have to downgrade it???

getting an error : "d3d9.dll is missing"-2.jpg
Note: This also has my comps specification.

Here is the GPU details:

getting an error : "d3d9.dll is missing"-3.jpg

I also downloaded d3d9.dll from a website & here 1 can see that existing file on my pc is latest while the update is an old update.

getting an error : "d3d9.dll is missing"-4.jpg

So, i need help with identifying the steps to resolve this error.

My System SpecsSystem Spec
23 Sep 2011   #2

7 ultimate x64

My System SpecsSystem Spec
23 Sep 2011   #3

Windows 7 Ultimate

Quote   Quote: Originally Posted by Schroff87 View Post

Thank you Buddy...will try it!
My System SpecsSystem Spec

05 Oct 2011   #4

Windows 7 Home Premium (64 bit)

Even though you have Windows 7 and DX11 by default you need to still install DX9 updates weird huh :)
My System SpecsSystem Spec
09 Oct 2011   #5

Windows 7 Ultimate

Quote   Quote: Originally Posted by hybridfan View Post
Even though you have Windows 7 and DX11 by default you need to still install DX9 updates weird huh :)
Well the updates didn't resolve this issue...still getting the same error....
My System SpecsSystem Spec
10 Oct 2011   #6
Microsoft MVP

Win 7 Ultimate x64

For starters try running a legit version of the game and not a pirated copy.

getting an error : "d3d9.dll is missing"-1.jpg

Till then we can't help you.

My System SpecsSystem Spec

 getting an error : "d3d9.dll is missing"

Thread Tools

Similar help and support threads
Thread Forum
"Desktop As Shortcut" Command Is Missing from the "Send To" Menu
Can anyone help me with this ? i got a picture ... i cant sendto desktop as shortcut the icon is missing .. help !!:cry:
"Local Area Connection" missing in "Change adapter Settings".. Plz hlp
I have to set up a Broadband connection. But Local Area connection icon is missing. Someone told "drivers" could be missing... I installed few. But the problem is as it was.. please guide me in this regards.. Thank you Screen shots Attached
Network & Sharing
"Bootmgr is missing" error upon startup, caused by human error
Today I got my new laptop and decided to dual boot Ubuntu and Windows 7 on it. After several hours of partitioning and researching, I ran into many issues. Eventually I decided to boot Ubuntu from a USB drive, open up Gparted, and delete any and all Linux partitions while expanding the size of the...
General Discussion
"Select Proper Boot Device" now "NTLDR is missing"
Computer Specs: CPU: I5-2400 MB: Asus Pz868 Ram: Corsair 8GB Vengeance LP Using on board VIdeo For now Maxtor HD Sata WD Raptor Sata HP Lightscribe DVD-r Drive Sata Problem I was having once I completed my new build with old system parts was as listed in title. It started out as select...
BSOD Help and Support
Win7 pro startup error "Boot MGR missing"/"Operating System Not Found
I just upgraded from Vista Home Premium to Win7 professional x64 hoping to fix the above mentioned problem. After a complete re-install Im getting the same errors. Im not sure of the proper terminology here, but during startup the computer does a scan of all hardware and "Volume 0" has a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:37.
Twitter Facebook Google+