Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires II The Conquerors-High Resolution+Music Fix on Win7 64

12 Oct 2011   #1
Games Goblin

Windows 7 Ultimate x64 Version 6.1 (Build 7600)
Age of Empires II The Conquerors-High Resolution+Music Fix on Win7 64

Hi all

I just got a huge itch to play the Age of Empires series again. I played Age of Mythology last week and worked without a hitch on Windows 7. But when trying to install my all time favorite Age of Empires 2 yesterday, ran into a lot of problems - after hours of googling, I have managed to get the game up and running without the dreaded colour bug and that too at my monitor's resolution of 1680x1050 (vanilla AoE 2 and AoE 2x are limited to 1280x1024) and I managed to get the game to play background music again (more on this below).

So I am compiling a guide so that anyone who wants to install this classic can spare themselves the agony of spending hours to find a solution.

The following guide has been compiled using my Age of Empires Collector's edition which I bought some 9 years ago. I can't guarantee this guide will work 100% for other editions/compilations of the game - but I see no reason why it won't work

A. Installing Age of Empires II - The Age of Kings

When I tried to install AoE 2, it would keep getting stuck at 50% when copying the file ARIALNB.TTF - so I had to use the following steps to get it to work

1. Insert your Age of Empires II disc. DO NOT run the setup through autoplay. Close autoplay, go to My Computer, right click the AoE 2 CD and Open it.

2. Now right click AOESETUP.EXE and click properties and go to the Compatibility tab

3. In compatibility mode, Select Run this program in compatibility mode for: and in the Drop down menu, select Windows 98 / Windows ME

In Settings, select the following options:
Disable visual themes
Disable desktop composition

In Privilege level, select Run this program as administrator

Click apply and then click OK

4. Now, run AOESETUP.EXE as administrator and the setup should complete without a hitch

B. Installing Age of Empires II - The Conquerors Expansion

The conquerors setup went smoothly for me - did not need to set it to compatibility mode. If you run into problems, I suggest you use the above method.

C. Updating the game and Installing the resolution patch

note: the resolution patch will only work for The Conquerors Expansion and not for the vanilla Age of Kings

1. You can get the 1.0c patch from Microsoft Games. Install it.

2. Now get the resolution patch made by boekabart of -HERE - download the AoE2WideSetup.msi installer

3. Get a No-CD exe for the conquerors expansion -the widescreen patch only works for No-CD exe, spent around an hour trying to get the widescreen patch to work only to find in the readme that it wont work with the original executable because its encrypted or something

4. The readme for the widescreen patch says that it only works when it's installed to the game folder of Age of Empires 2 so when installing the patch, keep that in mind. My installation path for the patch was: J:\Games\Microsoft Games\Age of Empires II\AoE2Wide\

5. After installing the patch, you should get a shortcut on your desktop named AoE2Wide. Run it. After it finishes running you should get a .bat file on your desktop named "AoC1.0c 1680x1050.bat" or something.

6. Right click on the .bat file and go to the compatibility tab and select Run this program in compatibility mode for: and in the Drop down menu, select Windows XP (Service Pack 2) and click OK.

7. Now run the .bat file as administrator and keep your fingers crossed!! In game menu, make sure to select 1280x1024 as resolution. If all goes well, the game should be running at your desktop/monitor resolution and the colours bug should vanish. Enjoy!

D. About the Music Bug and Fixing it

This has plagued AoE 2 for a long time now. The Age of Kings and The Conquerors CDs are mixed mode CDs i.e. one part holds the game data and the other part holds the game's BGM in Red Book Audio CD format. Now, old computers (1999-2000's) had no problems with this as they had an audio connector for the CD drive (more info here) and AoE would play the audio track off the CD once you start the game. But since now we use SATA drives, the game wont play BGM anymore.

This always puzzled me as when I got the game I had a Win 98 Pentium 2 PC with a Philips CD drive which had an audio connector and the BGM would play correctly- but when I got my Pentium 4 machine with a Samsung DVD drive with no audio connector, AoE 2 would not play music anymore and it takes a lot out of the game as the music plays a big part in setting the mood of the game. I only recently figured out that the audio cable was responsible for this.

I used to get around this by starting a game in AoE, alt+tab back to windows and then playing the Game CD in Windows Media Player and then alt+tab back into the game.

When using the above widescreen patch, my system hangs for a bit when alt tabbing back to windows (I guess it's because the patch suspends explorer.exe in order to prevent the colour bug). So after more searching on google and experimenting, I found another method here developed by TheMegaX2 and FrozenWolf150

1. Use Windows Media Player to rip the soundtracks from the game CD's. I did this with both the AOK and AOC soundtracks. WMP will usually create .wma files.
2. Rename them to something recognizable, like AOK Track.wma, since the default name for both is 01 Track 1.wma.
3. Use a free audio converter, to convert them to .mp3 format. (I used the one found here)
4. Copy them to the Taunt folder.
5. Assign them numbers like you would for custom taunt files. I named them 50 AOK Track.mp3, and 51 AOC Track.mp3.
6. When you start the game, now you can choose between the AOK and AOC soundtracks, based which you prefer. Just press enter and type 50 for Age of kings BGM, and 51 for The Conquerors BGM and press enter again.

The difference is that the game won't automatically loop the track once it finishes, so you'll have to restart it manually. Also, it's possible to have BOTH tracks playing at once and overlapping, so be careful not to do this.
E. Misc Problems

I remember that the game used a medieval looking font in it's menus and buttons but now it displays a standard font - no idea how to fix this even after searching for long in Google. While it would be nice to see it fixed, it's hardly a dealbreaker.


Time spent installing Age of Empires and fiddling with it to get it to work - a few hours

The feeling of playing a classic and being 10 years old again - Priceless!

My System SpecsSystem Spec
30 Oct 2011   #2

Windows 7 Professional 32bit

... I love you, so long I have wandered through the dark halls of the internet searching for a solution for both these problems but to no avail. Cheers.
My System SpecsSystem Spec
02 Jan 2012   #3

Windows 7 Ultimate x64
No-CD Link

Regarding the above, use the link from boekabart to be your no-cd exe file. It's the below:

Otherwise the widescreen patch will not work.
My System SpecsSystem Spec

02 Jan 2012   #4

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

after reading this I am going to dig out my old AoE discs and do this!! I can't wait!!

My System SpecsSystem Spec
03 Jan 2012   #5

Windows 7 Ultimate SP1 x64

i recently installed it on my laptop and all seems well, but i do need to do the widescreen patch

also any tips on running it without the CD? i can't get the disc to image correctly at all and i have no cd drive in my laptop, so plugging in the external one is a bit of a pain, rather do without if possible!
My System SpecsSystem Spec
04 Jan 2012   #6


Aoe2 is kinda dated for me, but just out of curiosity, does the no-cd work for multiplayer? As I recall only the SP campaign worked back when I used the no-cd patch.
My System SpecsSystem Spec
05 Jan 2012   #7

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

as far as i know multi-player is dead. it used to run through the old ,sn gaming zone which is now gone. unless you know of any other way to play?

My System SpecsSystem Spec
06 Jan 2012   #8


Nah, just for LAN. I never go online in the wild for these things. One of my buddies owns a cybercafe, I get plenty of friendly reliable action there. Would've been nice if this worked back in the day though.
My System SpecsSystem Spec
16 Jan 2012   #9

windows 7 64 bit

I had the same problem as everyone else did. Would not run on Windows 7 64 bit. I tried the changing the directx - didn't work. Reset the compatibility mode - didn't work. This is what I did to get it to work:

Did the crack updates for AOE 2 and/or AOE 2 Conquers: Just did a google search for AOE 2 crack. The crack disable the CD check that is causing the problem.

Then to fix the color I did the following:
  1. Open notepad and copy/paste the part from the quote box
    • If you have Age of Empires II:
      quotetaskkill /F /IM Explorer.exe
      Start explorer.exe
    • If you have Age of Empires II with expansion:
      quotetaskkill /F /IM Explorer.exe
      Start explorer.exe

  2. Save as Windows7 fix.bat and put it in the same folder where you installed Age of Empires.
  3. Make a shortcut to the bat to access the game and if necessary change the icon so it looks like the actual shortcut

I tried everything else put it did not work. Now AOE 2 works in Windows 7 64 bit.

I piece these fixes from numerous sites and repair attempts. Found these to work and everything is running now.
My System SpecsSystem Spec
24 Feb 2012   #10

win 7 pro 32

Thanks mate.

It worked like a charm
My System SpecsSystem Spec

 Age of Empires II The Conquerors-High Resolution+Music Fix on Win7 64

Thread Tools

Similar help and support threads
Thread Forum
Graphics issue with Age of Empires II: The Conquerors
I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main...
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
Age of Empires 2: The Conquerors freezing.
Hi, I'm using win 7 x64 ultimate. dx updated. most win updates installed (omitted malicious software tool & etc.) Versions: Age of Kings: 2.0b (failed with 2.0a too), The Conquerors: 1.0e (fails with 1.0c too) AoE: Forgotten Empires installed, runs ok. AoE: Age of Kings runs ok. Tried killing...
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
age of empires II conquerors
salut , am si eu o problema si de fapt nu doar eu cam toata lumea pe care o cunosc si joaca age of empires II conquerors , la win 7 nu merge bine in joc se vede foarte nasol culoarea , am vazut aici la voi ca spuneti ca nu are nici e problema, dar nu e asa , nu e compatibil jocu sau daca voi chiar...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App