Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: NO games working on Win7 Ultimate 64-Bit

10 Aug 2009   #11
Armenix

Windows 7 Ultimate 64-bit
 
 

Ok, so before i do the driver sweep thing, I just wanted to mention 2 things and see what you think first.

I now notice that in my Device Manager screen, under "other devices", theres a "?". Then, branching off from it is a "Multimedia Audio Controller" with an "!". I'm guessing that this is just my computer recognizing the uninstalled card. I wasn't sure if that could attribute to me still getting errors, probably not though.

As far as deleting the driver software, i'm pretty sure i did that, because on the next restart, it tried to install new hardware, but failed. The Device Manager shows 2 "High Definition Audio Device" (which it always has since win7 fresh install), neither of which i have selected as my sound (i currently have no sound). Should I uninstall or "disable" those as well first? I wasn't sure if that would mess anything up since they were probably Mobo functions. I was thinking they might also re-install themselves anyway. Why would there be 2 HDA devices listed anyway?

Any comments on those before i proceed? Thanks a bunch guys! Sorry if i'm being picky, this helps me learn as well =P, and I really appreciate your guys help!


My System SpecsSystem Spec
.
12 Aug 2009   #12
smarteyeball

 
 

Sorry for the delay mate - I do apologise and hope you haven't been holding on

If you still have a ? or ! after the drivers have been installed, then yes that could be contributing to the problem. If the ? and ! only appear while the drivers are uninstalled, then as you summized, that is just Windows detecting the "unknown" hardware. ie the X-fi card

At least one of the High Definition Audio devices would be your 2600XT. It's safe to disable it. The other one could be the digital output of the X-Fi.

Another possibility would be your on-board sound device is not disabled in the BIOS, however you would have had issues in XP as well if the on-board wasn't disabled.
My System SpecsSystem Spec
12 Aug 2009   #13
Armenix

Windows 7 Ultimate 64-bit
 
 
Resolved!!!!!!!!

Hey, no problem smarteyeball, everyone's got things to do =)

You will be very pleased though....I FOUND THE SOLUTION!!!

It's a bit bittersweet, however...and i'm pretty annoyed that I went through all this hassle to find that it was my Agnitum Outpost Firewall Pro 6.9 64-bit Edition that was causing all these issues...something I would have never expected, as i never have issues with AOP. I had gotten the newer version of it, and i really should have checked something like that first, but I honestly would have never guessed that a firewall would be causing BSOD! I shut it off, and violla, EVERYTHING WORKS!! =)

It seems like I'm far from the only one with this issue with AOP 6.9 and BSOD's, so i'd advise anyone looking to get 6.9 to stay away for now and stick with 6.7.

This fixed all the game issues on my laptop, and i'm sure it will on my desktop...of course, this still leaves another question that i wont be able to resolve until i can get home on Friday. I still have to see if the SB drivers will still cause some errors, as I cant imagine it would error log something like that for no reason.

I hate making such a newbie mistake though, thanks for sticking through me with this though, I really appreciate it!
My System SpecsSystem Spec
.

12 Aug 2009   #14
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Man those secondary firewalls and add on programs cause so many problems like this I have lost count. Makes it very difficult for the person trying to help as they have no idea if these types of programs are installed or not. Glad you got it sorted out.
My System SpecsSystem Spec
12 Aug 2009   #15
Armenix

Windows 7 Ultimate 64-bit
 
 

Yea, thanks chev =)

Yea, i should have mentioned it before, I have just never had issues with it before...nor had i ever heard of a firewall causing BSOD's. But none the less, should have mentioned it. Thanks again for all of your efforts!
My System SpecsSystem Spec
12 Aug 2009   #16
smarteyeball

 
 

Quote   Quote: Originally Posted by Armenix View Post
Hey, no problem smarteyeball, everyone's got things to do =)

You will be very pleased though....I FOUND THE SOLUTION!!!



This fixed all the game issues on my laptop, and i'm sure it will on my desktop...of course, this still leaves another question that i wont be able to resolve until i can get home on Friday. I still have to see if the SB drivers will still cause some errors, as I cant imagine it would error log something like that for no reason.

I hate making such a newbie mistake though, thanks for sticking through me with this though, I really appreciate it!
One down, one to go

As Chev65 pointed out, not knowing all the different apps someone has installed makes remote troubleshooting just that little bit more difficult. Sometimes it's hard enough when you do know what's installed on your own machine

As for being a newbie mistake - Don't worry about it Sometimes the simplest things are the easiest to overlook. I must confess that AV/Firewall software didn't even cross my mind

Fingers crossed it solves the desktop problems as well. Post back with the results when you get back to the machine. Hopefully it's not a separate issue....

Good luck.
My System SpecsSystem Spec
05 Dec 2010   #17
Georgi

Windows 7 Ultimate x64
 
 

Please can some bodey help me.I wan't to play games on Windows 7 Ultimate x64.My computer doesen't wan't to run them.My skype is gogovg.Please finde me in the skype to solve the problem. smarteyeball Please try to finde me in the skype.
My System SpecsSystem Spec
Reply

 NO games working on Win7 Ultimate 64-Bit




Thread Tools




Similar help and support threads
Thread Forum
BSOD while playing various games in Steam, Win7 Ultimate x64
Problem is persisting after reinstalling Windows, can't really pinpoint it to any certain program, since the problem seemed to start right after installing ''the essential'' drivers and stuff from MSI disket that came with the motherboard. I hope the files attached help, I'm sorry for not being...
BSOD Help and Support
Win7 Ultimate: Win7 Ultimate repair from DVD
I caught malware omiga-search which I still couldn't remove neither with malwarebytes not ccleaner nor manually. While trying to remove it manually I deleted some important win 7 files and now my desktop doesn't load and the windows-key doesn't work. So I tried the startup-repair but it doesn't...
Performance & Maintenance
USB Floppy Drive not working in Win7 Ultimate x64
Hi guys. I'm new to the forum but I've read through this thread ( https://www.sevenforums.com/drivers/2042-usb-floppy-drive-driver-error.html ) and posted there as well but no response as yet, but it's an old thread so hence why I'm making this one. I've a problem with getting hold of a...
Hardware & Devices
Audio not working on win7 ultimate x64?
So I have had windows 7 for a while and I was using my computer when it got and I must have overloaded it and it gave me a blue screen. My audio doesn't work and when I got to the playback devices its empty I have the boxes checked off to show all the devices but it shows absolutely nothing. I...
Sound & Audio
Most programs stopped working on my Win7 Ultimate x64
I have Win 7 Ultimate x64 installed on my pc. I had no trouble at all in the past. In the last few days though, I had programs like Paragon Partition Manager 11 Demo which stopped working where before I had no problems with. Each time I try to start it, it gives me error; " a part of paragon...
BSOD Help and Support
Chinese words are gibberish in my Win7 Ultimate games.
I have recently upgraded from my XP to Win7 Ultimate 32 bits. And I realised that when I play chinese games, I had to delete all my previous saves before it would load properly and even then, the text becomes gibberish in-game. With some of my other games, the programme itself won't run. I have...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App