NO games working on Win7 Ultimate 64-Bit

Page 1 of 2 12 LastLast

  1. Posts : 9
    Windows 7 Ultimate 64-bit
       #1

    NO games working on Win7 Ultimate 64-Bit


    Hi there sevenforums!

    Ok, so I have an unusual issue. I have 1 computer and 1 laptop with Windows 7 Ultimate 64-bit Edition Build 7600 on both of them, and both have all updated (and proper) drivers. I have tried installing these games in attempts to see what sorts of games will work and what wont: Left 4 Dead, Heroes of Might and Magic V, and Warcraft III.

    My laptop:
    AMD Sempron Processor
    Nvidia GeForce M8200
    3GB RAM

    Desktop:
    Intel E2200 Dual Core
    ATI Radeon HD 2600XT
    2GB RAM

    On my laptop, I am able to successfully install all of the games, but Warcraft III will not play, not even with the latest 1.24a patch (BSOD). Heroes V initially gave me trouble and gave me a BSOD, but once i reinstalled it, it worked just fine. Left 4 Dead gave me no issues.

    On my desktop, however, NOTHING will play. All of my programs run just fine, not a single hitch, but all of my games give me a BSOD, or just turn my screen black and restart my computer. Unlike my laptop, I have my Windows 7 on a separate partition (20GB), and i install everything on another partition. I don't know if this is a factor, but as far as i know, it shouldn't matter. I have tried running them all on different compatibility modes, and have run them as a system administrator, and they all yield the same result

    Although Warcraft III should work since people can play it on Vista 64-bit, i'm not even that peeved about that, i could live with that. I just want to know why NOTHING works on my desktop computer...any suggestions? I'm about ready to pull out my hair on this one.
    Last edited by Armenix; 08 Aug 2009 at 01:35. Reason: included build #
      My Computer


  2. Posts : 12,364
    8 Pro x64
       #2

    Without knowing what the BSOD errors are, it's hard to pinpoint a culprit.

    The usual suspects:

    Are all video and sound drivers are up to date?

    Chipset drivers installed?

    Are there any yellow triangle exclamation marks appearing in device manager?
      My Computer


  3. Posts : 9
    Windows 7 Ultimate 64-bit
    Thread Starter
       #3

    Thank you for the reply smarteyeball!!

    For the most part, i'm primarily getting black screens that seem like it's loading the game, then it reboots my computer automatically after 4-5 seconds. I don't seem to get BSOD's anymore.

    I am not seeing any yellow exclamation marks by any of my devices in the "device manager" screen, so I don't think it's that. What I can do is link/tell you what drivers I have installed for the devices on my computer and see if its just not properly recognizing any conflicting drivers, or maybe i'm missing some necessary ones, but all appears right to me.



    Intel E2200 Dual Core - None

    ATI Radeon HD 2600XT - Drivers & Tools | GAME.AMD.COM (Driver Ver. 8.632.0.0)

    GIGABYTE GA-P31-S3G Motherboard - GIGABYTE - Support&Download - Motherboard - Driver - GA-P31-S3G (rev. 1.0) (Chipset Driver Ver 8.3.1.1009)

    Sound Blaster X-Fi Xtreme Audio -
    Creative Worldwide Support > X-Fi Xtreme Audio (Driver Ver. 1.04.0090)



    Thats about it...I'm still unsure of what to do. Im still troubleshooting with no luck, any further advice would be appreciated. THANK YOU

    Edit: I seemed to have found an article where someone is facing similar issues, just not the same OS (XP 64-bit), maybe there's something in there that could help lead me to answer?

    http://www.tomshardware.com/forum/26...omputer-freeze
    Last edited by Armenix; 09 Aug 2009 at 02:31. Reason: Edited Chipset Driver, Article Found
      My Computer


  4. Posts : 12,364
    8 Pro x64
       #4

    It all looks in order driver wise. No exclamation marks in Device indicates nothing untoward there either.

    Did you have any trouble with the same components in another OS? ie XP or Vista - or is this a fresh build just for Seven? If it's a new build, it sounds like a power supply problem.

    Have you run the WEI system rating? (It shouldn't matter, but if there is a video problem, it may possibly crash when running the Video card assesement)

    On the off chance it's still technically BSOD'ing - to stop an automatic restart:

    Right click on "Computer" in the start menu>properties and then select "advanced system settings"

    In the start up and recovery field, select settings and untick 'Automatically restart'
    NO games working on Win7 Ultimate 64-Bit-auto.png


    Since you've already had some BSOD, head to:

    C:\Windows\minidump

    and zip and upload a few of the most recent .dmp crash dumps (use the paperclip attachment to upload the zipped file)

    Lastly, check in the Event Viewer logs:

    Start Orb>type "event" and got to Custom views>administrative events to see if the app crash has a common faulting module

    NO games working on Win7 Ultimate 64-Bit-event-viewer.png
      My Computer


  5. Posts : 9
    Windows 7 Ultimate 64-bit
    Thread Starter
       #5

    Thanks again for another reply, smarteyeball!

    I've had this computer for about a year now, and i previously ran Win XP Pro SP3 32-bit edition flawlessly. I had never actually gotten a BSOD until windows 7, and I haven't changed anything hardware-wise.

    As far as not receiving enough power, my current power supply is an Antec Earthwatts EA430 (430W)...do you think that could be an issue? Found here: Newegg.com - Antec earthwatts EA430 430W Continuous Power ATX12V v2.0 80 PLUS Certified Active PFC Power Supply - Power Supplies

    On the WEI, i score a 5.4, which is low-balled by my RAM/CPU. My GPU ranks up to 5.7 for desktop and 6.3 for gaming.

    I have attached those errors as requested, and i checked that administrative events thing, and there was only 1 application error logged, and this is what it said:

    Faulting application name: rundll32.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc637
    Faulting module name: P17RunE.dll, version: 1.0.1.1, time stamp: 0x46199985
    Exception code: 0xc0000005
    Fault offset: 0x00002393
    Faulting process id: 0x808
    Faulting application start time: 0x01ca1899f7a8882b
    Faulting application path: C:\Windows\SysWOW64\rundll32.exe
    Faulting module path: C:\Windows\SysWOW64\P17RunE.dll
    Report Id: 4c03fd57-84a7-11de-be50-001d7dadc7be

    Do you think it could be something else?

    Thanks for your help, smarteyeball!

    Edit: I plan on doing a lot more testing/troubleshooting within the next day or so, so maybe that will help pinpoint some errors, I have just been busy with work the past few days, so I'm sorry if there's not a whole lot to work with. I'll be sure to get some more info for you soon!

    I was also thinking of just doing a fresh install of win7 and seeing if that fixes the issues, let me know what you think.
    NO games working on Win7 Ultimate 64-Bit Attached Files
      My Computer


  6. Posts : 4,364
    Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build
       #6

    First off:

    Did you upgrade from XP to W7? When your games are installed to a separate partition (which is what I always do) are you manually installing them (which is what I do) or did you do a custom 7 install that has moved the Program Files tree to another partition using something like vLite?
      My Computer


  7. Posts : 12,364
    8 Pro x64
       #7

    Unfortunatelty the crash dumps don't pinpoint any driver (MS haven't released the proper Seven Symbols to do a proper check)

    However that faulting module "P17RunE.dll" is part of the Creative drivers - so I'd say it's a very strong possibility it's your sound drivers.

    As a test, uninstall your sound drivers and then run the games without sound - if they don't crash, there's your culprit.

    These drivers could be worth a shot:
    RapidShare: 1-CLICK Web hosting - Easy Filehosting

    From:
    SB P17X Series Support Pack 2.0 (07/31/2009) - AudigySE/Value/LS_Live24bit_X-Fi XtremeAudio_SB5.1VX - Sound Blaster - Creative Labs


    (*Note they are unofficial drivers by Daniel_k, but he's done good things with SB drivers in the past )
      My Computer


  8. Posts : 9
    Windows 7 Ultimate 64-bit
    Thread Starter
       #8

    Johngalt, thanks for some further assistance!

    My current installation is a fresh install: I formatted the drive, installed Win7, then partitioned my HD to have a 20g partition, then the rest would be a separate one. Then I reinstalled win7 on that new 20g partition, and formatted the old win7 partition, so its all completely clean, not an upgrade.

    As far as how I install programs, what i do is that in the setup process, i usually hit "custom" (if its necc), and i change the install directory to my non win7 partition. So, basically, if Win7 is part "C", then i change the directory to the other partition, "F". I don't physically move any folders after an install to the F partition from the C partition.

    I think i'm doing it right, as my regular, non-graphic programs work just fine, just my games have an issue.

    Smarteyeball:

    No dice with the uninstallation of the sound drivers...i removed all the installed programs associated with SB, and then i went to the device manager and uninstalled the drivers from there. Do you think i should completely remove the card?

    I'm now getting those BSOD's again, but i think that can be credited to the unchecking of "restart automatically" thing, because when i check it back, i dont get the BSOD, just a restart. It's hard to say if the removal of the sound drivers had any affect on it...i'm assuming not though.

    Am i pretty SOL now? :-/ Thanks for your great help so far!
      My Computer


  9. Posts : 4,364
    Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build
       #9

    OK, just checking. For the future, you do not have to go through the dual installation with W7 - the installer has a built in partition manager. When you go to install and it presents you with a list of your drives, you just delete the existing partition on the drive that you want to install and then create a new one for 20 GB - and install W7 into that (no pre-format required, as the installer handles all of that).

    now, on to your issue - get Guru3D - Driver Sweeper and install it and read the instructions starting at Phyxion.net | Driver Sweeper | Products | Products to get an idea how to use it - then use it and see if there are any latent files left over from your driver uninstall.

    Also, you should run several virus scans, just in case - see Slow Internet and Vistax32 after a while... - Vista Forums (the link leads to our sister site, Vistax64).
      My Computer


  10. Posts : 12,364
    8 Pro x64
       #10

    It's hard to say if the removal of the sound drivers had any affect on it...i'm assuming not though.
    Unfortunately, after a restart Seven will automatically re-install it's bundled drivers, which could be adding to the issue.

    When using device manager to un-install the drivers, make sure to tick the "Delete the driver software for this device" (see attached pic) - this should stop Seven from automatically installing it's own backup drivers from the WinSXS folder and allow you to install your own.

    Uninstall software through CP

    Uninstall and permanently delete through device manager

    Re-boot into safe mode and run Driver Sweeper (Run as admin)

    Boot normally and hopefully you won't have any sound device installed, or remaining files. Then try a different driver set.



    Armenix said:
    Do you think i should completely remove the card?
    As a last resort, yes.

    Do the same uninstall/driver sweeper routine and then remove the card.

    The problem with troubleshooting, is that it can be a pita
    Attached Thumbnails Attached Thumbnails NO games working on Win7 Ultimate 64-Bit-permanently-delete-driver.png  
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:05.
Find Us