Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problems with Command and Conquer 3

15 Aug 2009   #1

Windows 7 64-bit RC7100
Problems with Command and Conquer 3

Hi all.
I have installed Command and Conquer 3 Tiberium Wars, and have been trying to get it to run.
When I try to launch it I get the following Direct X error, and the game closes:
Please make sure you have Direct X 9.0 or higher installed. Also verify that your video card meets the minimum requirements, and that you do not have hardware acceleration disabled in the Display control panel.
I'm running Windows 7 64-bit, RC7100 and have a Radeon 4890 (see sys specs for further details).

I'm pretty sure that the graphics card "meets the minimum requirements".
Running Dxdiag shows I have DirectX 11, and I also install DX 9.
My current display driver doesn't allow me to change settings to enable hardware acceleration via the control panel, but in ATI's Catalyst Control Center I couldn't find anything relevant that wasn't already checked. Also downloaded the latest video drivers for my card.

On a possibly unrelated note I've been having problems with Guild Wars and Red Alert 3, when I try to run either of them in full-screen mode the screen goes totally black (sounds are normal), and then gradually turns bright white in patches. Alt-tabbing or force-quitting results in serious monitor flickering for a minute or so once the desktop appears. Guild Wars is now played windowed, although following today's tinkering RA3 seems to work fine again in full-screen).

Any help much appreciated.

Attached Images
Problems with Command and Conquer 3-dx-error.jpg 
My System SpecsSystem Spec
16 Aug 2009   #2

Windows 7

I have installed C&C3 without problems BUT I had so many problems installing Age Empires 3. I was getting similiar message to you for that game.

I completely uninstalled game after four goes. Including in registry and all folders deleted. Reinstalled in completely new place. C drive/games. Before even attempting to load installed latest patch! Turned off Norton's Internet Security which I feel is causing a lot of issues on my computer and voila the game played.
Good luck.
My System SpecsSystem Spec
01 Sep 2009   #3

Win7 7100 / WinXP SP2

I keep getting a weird Disc Error for the Movies.big file when trying to install C&C3
My System SpecsSystem Spec

03 Sep 2009   #4


I also had many problems installing Age Empires 3...
My System SpecsSystem Spec
04 Nov 2009   #5

windows 7

i get the same exact error did you ever figure it out? I have a laptop with the integrated 3200.
My System SpecsSystem Spec
05 Nov 2009   #6

Win7 7100 / WinXP SP2

It FINALLY installed when I put the installer on WinXP SP3 mode and turned off any drive emulation software
My System SpecsSystem Spec
09 Nov 2009   #7

Windows 7 Premium

I just downloaded C&C3's 1.09 Patch and updated to Directx 11. Then Ran the Shortcut "As Administrator" Works perfectly fine now.
My System SpecsSystem Spec
25 Jul 2010   #8

windows 7

Quote   Quote: Originally Posted by AeonGamer View Post
It FINALLY installed when I put the installer on WinXP SP3 mode and turned off any drive emulation software

Could you explain how to do this? Please and thank you
My System SpecsSystem Spec

 Problems with Command and Conquer 3

Thread Tools

Similar help and support threads
Thread Forum
Command and Conquer Generals 2
Hey there anybody knows what is with all the hate on the new c and c game being f2p? It looks pretty good but the dislike and hatred on it is overwhelming.
Need help with command & conquer games!!!!!
I have the old Command & Conquer games: Red Alert 2 and Yuri's Revenge and they will not run properly on windows 7!!! Please help! the sound works fine and the game works, like i can click on the buttons but the video doesnt work. The video freezes on the current image unless i change something on...
Command and Conquer: Zero hour.
A friend and I are looking at having a game of Command and Conquer later on today, one issue is I am unable to get the game working. I have the first decade edition of Command and Conquer and all the thread I have read are all talking about using a .InI file and are rather old threads. I have...
Command and conquer The First Decade
So I am on my dads computer, i don't know all the specs but i know for a fact its strong enough to play any of the games. So it seems that NONE of his Westwood/EA Games work (Command and conquer in specific) I tried to get C&C Generals: Zero hour to work. I got an error that looked like this ...
Command and Conquer The first decade
Ive got windows 7 Home 64bit OS. And the generals and zero hour from the first decade pack don't seem to work... I tried some compatibility mode aswell, but it won't work. Anyone know how i can get this to work Thanks

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:41.
Twitter Facebook Google+