Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Any Luck With Combat Arms?

16 Jan 2009   #1

Windows 7/Ubuntu
Any Luck With Combat Arms?

Ok so i have been fooling around with Combat Arms for a Day or two (on Build 7000) and i can kinda get it to work. First i have to click on it once, its loads, then nothing happens. Click on it again and it loads but then a error message is displayed telling me i dont have Directx. Even though Everyone Knows that Windows 7 comes WIth Directx 11, and i ran DxDiag to prove it. However i just cant seeem to get it to work. So has anyone else had any luck with it?

My System SpecsSystem Spec
17 Jan 2009   #2
Guy with a Colt

Windows 7 Ultimate 64bit

I got it to work, follow as follows

Right click the desktop icon, Click properties
Click Compatibility Tab
check the box for Run this program in compatibility mode for:
Select Vista from the down drop box
check the box for Run this program as an administrator.

Try the game now.

if you still get a directx error write it down and type it in here
My System SpecsSystem Spec
17 Jan 2009   #3

Windows 7/Ubuntu

I follow the instructions above, however had to click the icon twice, Once it loaded but then did nothing, second time it loaded, screen went black for 2-3 secs then went back to the desktop with this error message.

Unable to reset the renderer. In order to play Combat arms, you'll need at leasty Directx 9.0c, with a video card that supports TnL

My Graphics Card Specs
Nvidia GeForce 6200 512MB

I do have the latest graphics Drivers directly from the Nvidia Site.
My System SpecsSystem Spec

17 Jan 2009   #4
Guy with a Colt

Windows 7 Ultimate 64bit

hmm try DriectX Nov 2008 Redist

Download the Redist package, save it anywhere eg: desktop
once downloaded, double click exe file and confirm any uac popup messages.
click yes to accept agreement
at the next screen click browse, point it to anywhere on the drive, eg C:\

to create a new folder click ok and after the \ left click and type
eg: DirectX
once you are satisfied with the location "note where it is" click OK
it should pop up with a window The Folder 'C:\DirectX' does not exist. Do you want to create it?
Click Yes
A window with a progress bar should pop up and then it will dissapear
go to the path you have told it to extract to via Computer
in the folder should be a exe file called Setup.exe, run that file.

Don't worry, It wont stuff DX11, It will only fix the DirectX 9.0c side

I hope this helps your problem.

a handy hint, update your system specs in your usercp
info in there like graphics card will help ppl helping you

I used this DirectX on win 7, hence no problems my end
My System SpecsSystem Spec
17 Jan 2009   #5

Windows 7/Ubuntu

Thank you for the directions, however i have encountered another problem.
I downloaded the file you provided
Created a Folder in C:\ Named DirectX
I extracted the file to C:\DirectX
The installation went fine until the end when i got this error:
An Internal system error occurred.
Please refer to DXError.log and DirectX.log in your windows folder to
Determine problem.
My System SpecsSystem Spec
17 Jan 2009   #6

Windows 7 Beta x32 / Windows XP Media Center x32

Almost the same problem. I don't have the DX problem that Kidfork has, but when I run the game, the launcher pops up, and right after Hackshield finishes updating the game disappears off the task bar. Opening Task Manager, Engine.exe (the game) is still running, but it's consuming 100% of one of my cpus (dual-core). If I run Combat Arms again, it works perfectly, but now I have two Engine.exe processes running and both my CPUs maxed out. The first process isn't using much memory, only about 30mb, while the second is running properly at about 190mb. Can't figure out why the first instance won't work, and the second time I run it it always does.

Also, after I play CA, I can't terminate Engine.exe, and it becomes impossible to shut down or anything short of holding down the power button.
My System SpecsSystem Spec
18 Jan 2009   #7

Windows 7/Ubuntu

At this point in time i think its good to say that COmbat Arms does NOT work in WIndows 7. I mean its still in beta so ill wait it off. Or Probaly install A Linux Partition and see if i can get it to work there.
My System SpecsSystem Spec
18 Jan 2009   #8

Windows 7 Ultimate Vista Ultimate x64

Here you go try this installer for DX web installer

My System SpecsSystem Spec
20 Jan 2009   #9

Windows 7

I cant even run the installer for Combat arms Europe, it says; "Failed to extract loader" and if i run it as vista, or XP, it seems to work, but it says its crashed, but the installer seems to keep running, but doesn't do anything. D;
My System SpecsSystem Spec
26 Jan 2009   #10

Windows 7 Ultimate

i have a weird problem..... when i run it, it gets up to hacksheild. then it crashes and i get blue screen of death. this happens with alot of my programs and idk why i get blue screen so much.....
My System SpecsSystem Spec

 Any Luck With Combat Arms?

Thread Tools

Similar help and support threads
Thread Forum
Combat Arms Not Wanting to Work
I have recently tried to get back into playing Combat Arms, however, it does not want to seem to run under Windows 7 at all. It ran fine under Windows XP. I have added the program to my Comodo Firewall trusted programs, but it doesn't seem to be a firewall issue. I have tried running it under...
Can I play Combat Arms on my laptop?
Hello, Recently I checked on this System Requirements lab site, that checks my system specs to see if I am compatible to play some games. Well I checked for Combat Arms and it said that my video card needed upgrading. I think it was a NVidia brand one. I want to know if I can still play it okay...
Combat Arms??
I have been trying Combat Arms... but no luck :shock: my PC is: Core2Duo 2.2Ghz 1GB Ram DDR2557 Nvidia 7200GS And i been playing this game in Vista and XP... but in 7, when i run it, nothings happens... but in the Task Manager, "Engine.exe" is running and i cant terminate that process....
Combat arms Problem
Hi, so, I realize that there are a lot of these posts, but not one of them corresponds to my problem. So, i start Combat arms, and log in, choose a server, go to a game... and in a few secs, the game closes, with no error messages or anything =P so whats going on?
Combat Arms problem
I having problems playing combat arms,I first load the game then chose a server an a channel when im loading to the channel the game paralyze but the music is still playing,i press esc and when it came to the destop a pop-up was there but i couldnt read it because it closes when i close combat arms...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:54.
Twitter Facebook Google+