Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Trying to play a game - Flash.ocx is missing - Game wont launch

21 May 2012   #1

Windows 7 Ultimate 64 bit
Trying to play a game - Flash.ocx is missing - Game wont launch

The title pretty much sums everything up.
I downloaded a game called R.O.D.E Online, its a free mmorpg
I installed the game, everything went well.
When I tried to launch the game nothing happens, after clicking on the launcher a few times I get an error message that says this:

Program compatibility assistant
This program requires a missing windows component:
"This program requires flash.ocx, which is no longer included in this version of Windows."

I have browsed to the installation folder and directly clicked on the launcher file, the game launches but when I try to play it says I need to download the newest patches. Well the file that gives me the error is the launcher which downloads the patches.

I have searched for answers for this error for about 2 hours.. It seems others have had this error for other programs but it wasn't essential to fix for the program to run. I have been unable to find a solution so any help is much much appreciated.

Thank You!

My System SpecsSystem Spec
24 May 2012   #2

Windows 7 Professional 64bit

Have you tried running it in compatibility mode?
My System SpecsSystem Spec
24 May 2012   #3

Windows 7 Ultimate 32bit

Do you have the latest version of Adobe Flash Player?
My System SpecsSystem Spec


 Trying to play a game - Flash.ocx is missing - Game wont launch

Thread Tools

Similar help and support threads
Thread Forum
game won't launch from within games explorer
Hello. I've just installed a game (Gardenscapes) on my son's PC, and after I'd installed it I copied the .exe file and pasted it in the games explorer folder. For some reason, however, it will not launch when the icon is clicked upon, and the message 'Unable to init application. Please reinstall...
BSoD each time I launch a game
Heya, So I have a MSI GT70 with two graphic cards : an intel HD Graphics 4000 used for the desktop and anything that doesn't involve too much GPU usage and an Nvidia Geforce GTX 675M used for gaming. I made sure the Nvidia GPU was used when gaming, so the problem can't be swapping. But, each...
BSOD Help and Support
BSOD Happenes a lot, especially when trying to launch a game.
As the title says I often recive a BSOD when trying to play videogames. Usually after installing it I launch it knowing it will blue screen. I get the error isql is not less or equal? Something along those lines. Anyway usually after the crash I go back to steam and just verify the integrity. But...
BSOD Help and Support
Windows 7 Pro Wont Play Game
my game is firefighter command raging inferno it is mad for xp but it downloads onto my system fine but wont play
How can I change my game icons that I click to play the game?
My icons were crap when I installed the game and want to change them, but it says the picture has to be an icon. How do I do this?
Launch game as high priority
Would it improve performance on a game to launch it as a high priority process? Specifically, Garry's Mod. Is this possible? The problem is, I can't just minimize it and reset the process priority as doing so seems to make it crash.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App