Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Oblivion - UAC messages and Visual Glitches (2 separate issues)

06 Jul 2012   #1

Windows 7 Professional x64 SP1
Oblivion - UAC messages and Visual Glitches (2 separate issues)

Hello again!

Thanks to guidance from online communities, including this forum, I now have Oblivion installed and working with all of my mods (there really aren't that many mods in my list at this time). HOWEVER, I am still experiencing a few issues that I am unable to figure out on my own, and I was hoping this forum could help.

This issue is entirely due to my inability to understand UAC. I can't seem to get the UAC prompt to go away upon startup of this game, no matter which icon (of the several possible shortcuts or the .exe in the game folder) I click on to start the game, or if I use the built-in launcher of OBMM.

I'd prefer not to disable UAC entirely (which is the only way I have succeeded in eliminating the UAC prompts thus far). Oddly, I have set nothing in the OBMM properties to dissuade UAC, and it launches without interruption. I have this installed in the same folder as the Oblivion.exe (C:\Games\Oblivion).

I have gone to the .exe in the game folder, and right click to set various conditions in Properties, as suggested by various online sources. This is what I have set, thus far:
-Compatibility Tab-Disable visual themes/Disable desktop composition/Run this program as an administrator/Changed settings for all users

-Security Tab-Full Control/Modify/Read&execute/Read/Write ; All Users Listed

Also, on the Shortcut Icons:
-Shortcut Tabs-Advanced Button-Run as administrator (This always resets itself to unchecked)

It's very hard to describe what I am seeing. I get one set of glitches when I enable V.Sync, and another when I disable it or run it in windowed mode. It's kind of like the 'tearing' described in the TweakGuides that was recommended in the above pinned troubleshooting topic, kinda.

If I enable V.Sync, (which was my former setting on my old XP system) I get very rare random flashes of electric-blue OR grey where a texture ought to envelop the mesh of a certain object/wall, AND I get random grey/goldenrod flashes like diagonal creases reminiscent of 'tearing', especially when I am standing still near flickering light. Also, tho not a glitch, I do notice less than smooth running of the Map movie in the main menu.

If I disable V.Sync or run the game in windowed mode (a full screen window), the issues listed above seem to be eliminated; however, a new sort of 'tearing' manifests in the game menus (not the UI). This looks more like the 'tearing' described in the TweakGuides document, as it is horizontally aligned, and seemingly shifted. Also, for comparison, the Map movie at the main menu runs smooth and evenly.

If I can't eliminate the visual glitch, I will play it with V.Sync off, as that seems to leave the world experience of the game alone; tho, of course, I'd like to figure out how to be 'artifact' free.

I include the following so you can know what I have considered/tried thus far...
I looked at the troubleshooting topic pinned above and I think I have done due diligence? This is numbered according to the pinned troubleshooting topic. Please correct/redirect me if I have missed something... Or if there is a way to verify an unknown/uncertain variable...

1. Update drivers: When I go to device manager, and right click to update driver, they all say they are up to date.
2. Correct drivers?: How do I know/how can I tell for sure?
3. Patch Game: GOTY comes fully patched to 1.2.0416
4. Windows Update: says," Windows is Up to Date"
5. Update DirectX Files: I installed 9.0c when I installed the game. How can I tell if I need to update?
6. DirectX 10/11: I believe I have these, but since Oblivion is meant to use DirectX9, this should be a non issue.
7. Game Settings: I adjusted them to desired adequate levels. I did not touch my .ini file (makes me nervous). I also referenced for guidance, by reading the guide for Oblivion, as well as the gamer's graphics and display settings guide.
8. Video Card Control Panel: I did not alter anything; nothing is competing.
9. Display Settings: A-ok
10. Antivirus: avast! is a non-issue. No change if on/off/gamers mode.
11. Game Managers: n/a
12. secuROM: I think that's also n/a
13. Overclocking: n/a (I am not intentionally doing this, and doubt it is an issue)
14. Permissions: I think these are not an issue with regards to my visual glitches. I am still reading about and trying to understand these and UAC for my other issue with the game.
15: Game Mods: Same issues pre-modded and post-modded; not the cause.
16. Compatibility Mode: No difference either way.
17. Known issues: I can't find my exact issue, but I find similar, with no resolutions.
18. Game forums: I've been visiting those too (for years).
19. Tech Support: Not tried, I don't expect it'll help (Win7 not officially supported).
20. Search: I have. Maybe I am choosing poor key words? I have read much relative and helpful info, but I have yet to find my particular issue/answer.
a- Overclocking: Not something I have ever knowingly attempted.
b- Overheating: I doubt it. Lotsa fans. New rig. Overqualified hardware.
c- Case Cooling: again, I doubt it. Lotsa fans with washable filters.
d- Power Supply: again, I doubt it. Overqualified and brand new.
# Game Compatibility List: Oblivion did not make the initial list, but was mentioned later in the topic (several times, including my particular edition), and many gamers on other forums have Oblivion working fine on Windows7x64.

My System SpecsSystem Spec
06 Jul 2012   #2

Windows 7 Professional x64 SP1

On Issue#1
Well Sheesh! It may be that have misunderstood UAC presentation entirely. I thought that if it was marked to run as administrator, that the UAC prompts would cease upon startup of that particular program. Have I been mistaken all this time?

I found a tutorial on this site that seems to suggest that there is a way to disable/eliminate the UAC prompts for certain programs by creating an elevated shortcut thru task scheduler... however, in this case, it does not work; as it crashes the game before it can load. Ah well...

On Issue #2
I was apparently mistaken in my earlier notion that V.Sync toggled which glitch I was experiencing. In fact, it merely seems to toggle the likelyhood of experiencing these glitches. I have since experienced all sets of glitches with either V.Sync setting.

If there are any other ideas/links, I'd appreciate input, as I am all out of direction on the two subjects.

Truth be told, these issues are annoying, but do not actually prevent me from gaming. If I have to settle with UAC prompts prior to every game (or turning UAC off), and glitchy menus and walls and the occasional blue rock or fixture..... Well, it's better than not gaming.

Cheers And Happy Gaming! ~Nom
My System SpecsSystem Spec
06 Jul 2012   #3

Windows10 Pro - 64Bit vs.10547

- check your CCC (- via right-click on desktop)

- what is listed under Information/Software..?
- it should show which version AMD/Ati gfx driver you have installed..
My System SpecsSystem Spec

07 Jul 2012   #4

Windows 7 Professional x64 SP1


Thank You for responding. I truly appreciate your willingness to guide me. It seems that since I was here last, I may have resolved the video glitch issue...
To answer your question, I have the driver offered at the XFX site that my install disk directed me to during installation. According to CCC, the Driver Packaging Version is 8.98-120611a-141402c-ATI.

I did not initially install CCC (because I never used it on my last system), however, after reading TweakGuides ATI advice, I decided to reinstall my driver and to include CCC this time. The last time I installed my driver, the internet was not behaving typically; perhaps due the coincidence of those recent intense storms? Something may have gone amiss since things seem to be working as expected this time. I did almost exactly what I did the first time. I did not make any changes in CCC (in part because the ATI guide was too dated to correlate with this version of CCC); yet somehow, my game seems to have manifested a harmonious relationship with my video card on this second install.

I am so happy to have my game working again! I've been learning to make this custom computer work since February; I am so thankful to this site for the many tutorials and for the forums for being there when the tutorials weren't clear enough for me. Thanks again for your patience and participation. I wish the Gurus of Seven Forums much Joy and Mirth. ~Nom

P.S. I am likely to disable UAC because the intitial pop-up irks me. I have yet to find a way to disable that for this one application. If there is any further advice on that matter, I'd really appreciate the direction/guidance/advice.
My System SpecsSystem Spec
09 Jul 2012   #5

Windows10 Pro - 64Bit vs.10547

I don't get problems with UAC - are you set up as the Administrator account..?
My System SpecsSystem Spec
10 Jul 2012   #6

Windows 7 Professional x64 SP1

Thanks for your reply. Yes, I am set up as the Administrator account. In fact, it is the only account on the machine. Any other settings I ought to check or ideas I can try? ~Nom
My System SpecsSystem Spec
10 Jul 2012   #7

Windows 10 Pro

Quote   Quote: Originally Posted by NomDeKeyz View Post
Thanks for your reply. Yes, I am set up as the Administrator account. In fact, it is the only account on the machine. Any other settings I ought to check or ideas I can try? ~Nom
Check your permissions. See step 14 in my guide: Tips on Troubleshooting Game Issues.

Sometime windows gets stupid and goes heywire with folder permissions. Anyway check the folder permissions where the game is installed.

Let us know.
My System SpecsSystem Spec
11 Jul 2012   #8

Windows 7 Professional x64 SP1

Sygnus21, thanks muchly for your response!

The files/game is installed in C:/Games/Oblivion.

I did not create an 'Everyone' category as directed in the tutorial, as I only want to free up the game for myself on this one computer. I have four 'names'/accounts listed under the security tab (but I recall only making one, so I assume Windows made the others by default/for system requirement): Authenticated Users, SYSTEM, Administrators(me), and Users(me). I eventually gave permissions to all four names/accounts on the list, to the .exe, the launcher, the Oblivion folder, and then to the Games folder.

I gave permissions to the .exe and launcher (previously), then (after your response) to the Oblivion folder, and the Games folder; I was about to for the C: directory, but was advised by the system that giving permission to the 'root directory' may have unforeseen repercussions; so I canceled out. While poking into the security tab of the C: folder, I saw that I already have full permission for the SYSTEM and the Admin account. I am using the Admin account...(Or so I thought).

I tested to see if the game would skip the UAC prompt after altering permissions to each item/.exe/folder change; after having all listed accounts/users marked with full permission on the launcher, the .exe, the Oblivion folder and the Games folder; I am still receiving UAC prompts.

Do I truly need to make an 'Everyone' listing to get the desired UAC interaction? Or is there something else I am missing? Like a proper way to log in as an administrator, perhaps? [I checked my User Accounts Page, and I am listed there by my name, and the word Administrator underneath... I assume that means I AM in fact using/logged-in as the Administrator...]

Insights Welcome...

P.S. I have the OblivionModManager(OBMM) installed to C:/Games/Oblivion ; the same location as the .exe and the launcher... OBMM will initiate without triggering a UAC prompt. It has the same permissions as I have given to the .exe, the launcher, and the two folders they are contained in (under C:/). Might this mean that it isn't a permissions issue after all?

P.P.S. I apparently also have a guest account that was created by default. It has never been logged into.
My System SpecsSystem Spec
11 Jul 2012   #9

Windows 10 Pro

The guest account isn't the issue. Like I said, check the permissions for the game's base folder and make sure your "Log In" name is there. "Administrator" is going to be/should be there by default, but if your user name isn't there add it then see what happens. Again, read step 14 of my guide.

And DON'T mess with permissions in the root directory unless you know what it is you're doing. Best advice... leave them alone. In fact, if the game is installed in "C" drive I might be inclined to leave the game folder alone, but it wouldn't hurt to just add your Log In name in that folder if it isn't there.

Other than that, don't mess with the root directory permissions!

Also remove the "Run as Administrator" from everything you did in the game, try adding your log in name like I said and go from there. If things go haywire, remove the game entirely and start over.

BTW is this the Steam version of the game?

Good luck.
My System SpecsSystem Spec
12 Jul 2012   #10

Windows 7 Professional x64 SP1


Ok, I checked the game's base folder permissions, I made sure my Log In name was listed by following your guide (not just as User; I was confused by the names listed because my computer name and login name are the same, but when I compared the name-structure in your tutorial, I figured out what was missing). BTW, Your guide was very easy to follow; Thanks for that.

I DID NOT mess with permissions in the root directory, I PROMISE! I also undid changes made to the Games folder by unchecking what was previously unchecked. I did not add my Log In name to my Games folder. (I might have tried that next, but it proved uneccesary).

I removed 'Run as Administrator' from everything, as you suggested. And still it behaved the same...

(And no, this is not the Steam version of the game; I have a disk set.)

THANKYOU SOOOOOO MUCH!!! I really didn't want to disable UAC altogether. Thanks to you, I now have UAC running the way I prefer. Woo Hoo!!!

Thank You BugMeister and Sygnus21; I wish you both and every Seven Guru much Health and Happiness, always.
My System SpecsSystem Spec

 Oblivion - UAC messages and Visual Glitches (2 separate issues)

Thread Tools

Similar help and support threads
Thread Forum
MSI GTX 460 BSOD on startup / visual glitches on every driver
Hello all, I've been experiencing some driver fails with many official NVIDIA drivers. As last I was happy with my 331.93 driver until yesterday. Recently my LCD SyncMaster920NW monitor has been dead (inverter/capacitor). And I started to use old SyncMaster793 CRT monitor which supports maximum...
BSOD Help and Support
BSOD, graphical glitches, explorer.exe issues
Greetings, Since a while back my computer has been BSOD:ing mostly while playing games utilizing 3D models, and while using Firefox or Chrome. Sometimes it just starts with some graphical glitches and then explorer.exe might die, but it always ends in a BSOD. Thanks in Advance Usch
BSOD Help and Support
Oblivion Keyboard Issues
Oblivion loads on my Windows 7 system, but when I try to use the keyboard it gives me special characters (#,$,!, etc.) or numbers when I am pushing letter keys when I try to enter a character name. Also the standard W,S,A,D keys don't move the character. I tried going into options and setting the...
Performance Issues with Oblivion.
So I bought the Deluxe edition on steam about two weeks ago and I've been getting abysmal fps drops. It' start at at around 100 and drop almost immediately to the 10-20 range, and it usually stay there. If tried with mods, without mods, uninstalling and reinstalling and still the issue remains. I...
Oblivion crashes after oblivion fully loads
Hello everyone. I have been playing this game for a week now and it was running perfectly. Now, when I load up the game, I get to the oblivion logo and when it fully loads, it crashes and I get to my desktop where there is the lovely "oblivion has stopped working" box. I had this problem before,...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:39.
Twitter Facebook Google+