Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: GTA4+EFLC&GrotesqueTactics 2 :runtime error r6030 crt not initialized

18 Aug 2012   #1

Windows 7 Pro 64-bit with SP1
GTA4+EFLC&GrotesqueTactics 2 :runtime error r6030 crt not initialized


since today I experience this annoying error message when I start either GTA4+EFLC or Grotesque Tactics 2 (all steam versions):

Microsoft Visual C++ Runtime Library
Runtime Error!

- CRT not initialized

I have no clue what this means.
Already uninstalled and reinstalled all the vcredists (2005/2008/2010 x86+x64 with SP1).Rebooted my system several times.

Uninstall (all vc versions)
reboot 1
reboot 2
install (2005 & 2008 & 2010 x86/x64 versions)
reboot 3
reboot 4
nothing changed.

I also tried the "repair" option of VCR 2008/2010 and rebooted, but this did not help either.

Everything else seems to work fine.
I have run a lot of games today, to test any other game for VCR errors, nothing else is effected by this error.

Since several days there were no changes to my system.
No system related updates or any driver or config changes at all.

Any ideas or suggestions?

Thanks in advance.

EDIT: I remembe I had one R6030 once, wich also let me not run GTA4. But I do not remember what I did last time. Maybe it is just a simple Registry fix, but the explainations regarding the R6030 error are fror programmers and not for a person like me, who just installs VCR version in order to play a game (and the game requires the VCRs).

My System SpecsSystem Spec
18 Aug 2012   #2

Windows 7 Pro 64-bit with SP1

I performed several new tests and came to the conclusion it is hooked up to the Virtu Software.
The Virtu software controlls the switching between my integrated CPU video card and the dedicated (see my specs).

Up till two days agao there was no problem.
Same VC redists installed and software layout did not change.
Even any system related configs were not touched.

I already de-installed video drivers for integrated and dedicated video cards and also Virtu.
Than I reinstalled everything, configured the dedicated application, just to get bumped to square one.... R6030. :-(

Open for suggestions, except for "don't use Virtu anymore", because it worked all the time.

Hardware was also already checked.
I had several stresstests and bechmarks run.
The problem is connected to games using a certain version of VC redists (GTA4+EFLC&GrotesqueTactics 2, also Civ 5 now!).
When I do not run the games via Virtu, just the integrated CPU video card they start and I could play... if the integrated card would not be so bad for games. 2D is OK, but 3D is not possible without slideshow.
My System SpecsSystem Spec
23 Aug 2012   #3

Windows 7 Pro 64-bit with SP1

I made a complete new installation of my system, guess what... R6030 for the mentioned games again!

So my guess is, this is related to the Virtu Software in combionation with latest Windows 7 updates/hotfixes.

I can not determine which one of the latest it was, but this must be the reason.

It is no coincidence, when installing a fresh system with the drivers and setup of when everything ran fine, is now making trouble again, after updating the system.
I updated the system immidiately after the first drivers were installed.

After the initial updates I installed VC redistributions 2005/2008/2010 as x86 and x64 version.
Than I installed Virtu latest version (nvidia and intel drivers already working).
After the last reboot I finally installed Steam.
Verified the cache of GTA 4, everything OK, lets go... R6030!
Turning of Virtu, game starts and I am on mainscreen.

Deinstalled Virtu, reboot, went into BIOS and deactivated iGPU.
With the dedicated (Nvidia GTX460) all mentioned games are starting and running without problems.

Waste of time
My System SpecsSystem Spec

27 Aug 2012   #4

Windows 7 Pro 64-bit with SP1

Update: The support of LucidLoggix just confirmed with an e-mail reply, that they know about the problem and working on it.

Though it seems it is related to the latest patchday updates. :-(
My System SpecsSystem Spec

 GTA4+EFLC&GrotesqueTactics 2 :runtime error r6030 crt not initialized

Thread Tools

Similar help and support threads
Thread Forum
Microsoft Visual C++ Runtime Library - Runtime Error!
Hi everyone. I have a runtime error every time I try to load my SnapPea program, which I use to connect my android phone to my PC, to add photos. music, etc. It was working fine 2 days ago and I don't know why this is happening. I would really appreciate any help and I have attached the error...
BSOD Help and Support
Microsoft Visual C++ Runtime Library Runtime Error" error message
What do I need in order to fix this problem? This pop-up message appears when I patched my game
General Discussion
BSOD while playing games - GTA4 EFLC.exe crashes during gameplay
Hi all Am currently loving playing GTA4: Episodes from Liberty City. The game runs and loads well (offline/single player), but crashes frequently during gameplay at seemingly random times. Included with my system information file is a report of one of the crashes. I've had no...
BSOD Help and Support
Runtime error this application has requested the Runtime to terminate
Hello, I hope someone can help. I have been using Cucusoft YouTube Mate for a long time and suddenly today I get this message: runtime error "this application has requested the Runtime to terminate it in an unusual way" I'm not very computer smart and I don't understand why this has...
General Discussion
GTA4 PC : EFLC Step by step account linking process
Good Evening Everyone This account linking nonsense for GTA 4 EFLC Social-Club and Windows Live has really thrown us for quite a loop. If someone could please give us a step by step lesson on this topic it would be greatly appreciated.
GTA4 error
i am using Windows 7 Ultimate i just bought DVD of GTA4 so first i installed it but it didn't work then 1 of my friend says uninstall it and then try to reinstall i did so it was installing after few minuets a error appeared (cylic redundancy check ) u can see the image please help me i am crazy 4...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App