Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Multiple games don't launch on Windows 7 Ult. x64

22 Aug 2012   #1

Windows 7 Ultimate x64
Multiple games don't launch on Windows 7 Ult. x64

First of all, I apologize if I'm not asking for help in the right forum or format, for some reason I couldn't access the ''How to ask for help'' page.

The issue is, that multiple games, such as Total War Shogun, Darksiders 2, Assasins Creed Revelations, Sleeping dogs, simply refuse to launch. I click on their respective icons, and absolutely nothing happens. For some of them the mouse turns into a circle for a couple of seconds, and that's it.

Other games, like League of Legends, The Witcher 2, Civ 5, and Dota 2 don't have this issue. It's just a major bummer because I spent a lot of money on these games hoping that they would work on this newly acquired pc.

I have the following specs:

> Mainboard : ASRock Z77M

> Chipset : Intel Ivy Bridge

> Processor : Intel Core i5 3450 @ 3100 MHz

> Physical Memory : 8192 MB (2 x 4096 DDR3-SDRAM )

> Video Card : NVIDIA GeForce GTX 550 Ti

> Hard Disk : Hitachi HDS721010CLA330 ATA Device (1000GB)

> CD-Rom Drive : DTSOFT Virtual CdRom Device

> Monitor Type : BenQ BenQ G950A - 19 inches

> Network Card : Atheros Communications AR9285 Wireless Network Adapter (PCIe)

> Network Card : Realtek Semiconductor RTL8168/8111 PCIe Gigabit Ethernet Adapter

> Operating System : Windows 7 Ultimate Professional Media Center 6.01.7600 (64-bit)

> DirectX : Version 11.00

> Windows Performance Index : 1.0 on 7.9

I had initially installed windows x84 on it, and as I upgraded to x64, nothing changed.

I have updated all of my drivers (I'm not exactly sure if I updated my sound card, since I can't really find it) using Driver Reviver, as well as the respective sites of the major components (such as my motherboard and my graphics card), but again, no changes.

I have turned off UAC.

I have attempted to run all of them as the administrator and with different compatibility settings (ranging from all the xp service packs to the vista service packs)

I have reinstalled the games multiple times.

My computer runs The Witcher just fine on high settings, I don't think my computer is too weak to run the games.

I will post whatever else you guys need from me, frankly, I have absolutely no idea what could be causing this, or how to fix it.

Thanks in advance.

Edit* I noticed that other people had this issue as well (in other threads) however, nobody had a specific solution, perhaps someone has found one now?

My System SpecsSystem Spec
22 Aug 2012   #2

Windows 7 Ultimate 32-Bit

Maybe Windows Update will have your drivers listed? I'm assuming you've tried that?

Also, when you say "upgrade", is that a clean install of 64-Bit Windows?
My System SpecsSystem Spec
22 Aug 2012   #3

Windows 7 Ultimate x64

I have tried that, and all of them have been installed. And yes, it was a clean install.
My System SpecsSystem Spec

22 Aug 2012   #4

Windows 7 x64 (Ultimate)

Ok, a few things... maybe nothing though.

You said you went from 32bit to 64 bit as an upgrade and then you mentioned a clean install? what does that mean exatcly?

In the past people used to say that upgrading from 32 to 64 was not a very good idea, the why escapes me but it made a lot of sense. Ever since then, when upgrading from XP 32 or even Vista 64 to Win 7, I purchased the full Win 7 64 OS, deleted the old OS, format the drive completely and performed a clean install of the new OS on a clean HD... no problems so far, then again, I only play shooters so I don't know whether I have been lucky that none of them have given me any problems.

Not 100% sure on this but I have also read that updating your drivers via Windows Update is not a good idea... at least for me it hasn't been as I always end up with corrupt or failed installs. I usually download the newest driver, uninstall the old one, restart and run as admin the new driver install. If you have an Nvidia card, make sure you also uninstall the PhysX driver before restarting.

You don't say whether you have patched the game to the latest update after installation?

Under Device Manager/Sound you should be able to see what kind of drivers you have... for the most part Realtek HD audio. Also, your Motherboard Specs should tell you what brand of audio you have so you can go to their site and download the latest drivers.

How do I install old games? Well (your miles may vary)... I don't use the Auto Start Setup, I usually open the folder and Right click on the setup.exe and use Run with admin rights.

If that fails, then instead of Admin rights I choose the Troubleshoot Comp and that usually solves the issue.

Sorry for the bible and rant... good luck
My System SpecsSystem Spec
22 Aug 2012   #5

Windows 7 Ultimate x64

Thanks for the reply,

I guess I would have to say I downgraded then, from x84 to x64. And yes, my hard drive was completely formatted. I updated all of the drivers using drivers from their respective websites/ driver reviver, I just checked the windows update to see if I was missing anything, and I wasn't.

Since I had a fresh install, I downloaded only the latest driver updates I could get for my graphics card and motherboard, there shouldn't be any conflicts with older updates.

All the games are patched to the latest updates, so that can't be it. Furthermore, the games I'm trying to play are all relatively new, from 2011 and 2012 only. I also just downloaded the latest Realtek HD driver, and that hasn't affected the issue in any way.

Thanks in advance
My System SpecsSystem Spec
22 Aug 2012   #6

Windows 7 x64 (Ultimate)

Ok, you HAVE NOT downgraded, you are just confusing x86 (same as saying 32 bit) with 64 bit.

Ok, all I can think of then is that you skip a part in your installment, sometimes the games ask you to install some form of DirectX and people skip this part thinking that their DirectX is newer so they don't want to have an old one and they couldn't be more wrong... the game needs to install a part of Directx needed to run the game.

Also, some other times, a driver might get corrupted after the game installation so I need to re install the newest driver recently downloaded even if I just finished doing so 5 minutes ago.

Did you try installing the games like I mentioned? remember, this may be tedious and sometimes even annoying but, it is you after all the one who can't play the game... we are just trying to help :)
My System SpecsSystem Spec
22 Aug 2012   #7

Windows 7 Ultimate x64

Oh no, I'm very grateful for what you're doing, please don't think I'm bothered by any of this at all.

I have installed every directx executable that came with the games, both during the installation and then afterwards I looked for them in their cd's and directories. I also installed .net framework, flash player, and C++ I think it's called.

I did try installing Total War Shogun and Assasins Creed using the setup executables, but to no avail. (This installation worked fine, but the issue wasn't solved).

I deleted the old drivers and then reinstalled them using the update I had already downloaded, nothing changed.

Anything else I might try?

I have absolutely not the slightest idea of what could be causing this.
My System SpecsSystem Spec
22 Aug 2012   #8

windows 7 x64 pro sp1

Windows Performance Index : 1.0 on 7.9 is that right? you only score a 1?

might want to run that assessment again and repost your score.
sounds like you have some issues there
My System SpecsSystem Spec
22 Aug 2012   #9

Windows 7 Ultimate x64

How do I run it again? I can run Civ 5 and the Witcher 2 on High settings, I think that might be an understatement.
My System SpecsSystem Spec
22 Aug 2012   #10

Windows 10 Pro

Quote   Quote: Originally Posted by AstaLaVista View Post
In the past people used to say that upgrading from 32 to 64 was not a very good idea,
Don't know where that came from but there's absolutely nothing wrong with upgrading from a 32-bit OS to a 64-bit OS.

Two things to consider though, and the first one I list has gotten considerably better to the point it may no longer apply.

1 - Make sure your hardware and software is 64-bit capable. In today's computing almost all hardware and software is 64-bit capable. The only thing you have to worry about is older hardware and software you my be holding onto.

2 - When upgrading to a 64-bit OS you need to do a clean (fresh) install. In fact, Windows won't let you do an "upgrade" from a 32-bit to 64-bit.

Here's a snipit from Microsoft's FAQ on upgrading from 32-64 bit - 32-bit and 64-bit Windows: frequently asked questions

If you want to move from a 32-bit version of Windows to a 64-bit version of Windows 7 or vice versa, you'll need to back up your files and choose the Custom option during Windows 7 installation. Then, you'll need to restore your files and reinstall your programs. For more information about performing a custom installation, see Installing and reinstalling Windows 7*.
Note that custom install means replacing your existing OS with the one you're installing.

I would recommend doing a clean install when moving between versions (32/64) - Clean Install Windows 7

Quote   Quote: Originally Posted by EriksK View Post
Thanks for the reply,

I guess I would have to say I downgraded then, from x84 to x64.
There is no such thing as x84, you mean X86, which is actually the 32-bit version of Windows. Don't ask why it was called x86 as I don't have to answer at the moment.

Anyway you actually "upgraded", not downgraded, when you moved from x86(32-bit) to the 64-bit OS.
My System SpecsSystem Spec

 Multiple games don't launch on Windows 7 Ult. x64

Thread Tools

Similar help and support threads
Thread Forum
nvd3dum.dll - Can't play any Games! All games stop working on launch
APPCRASH: nvd3dum.dll is the file causing all my games to crash completely I've tried the following: Re-isntall Nvidia Drivers Re-install the games Re-install C++ & Microsoft.NET Framework 4.0 Re-install Steam files (via Deleting every folder other than 'steamapps' and the Steam exe itself...
Games won't launch on my new Windows 7 32-bit partition on an iMac.
Hey guys, I'll preface this by saying I have an iMac Snow Leopard with a high end graphics card, but for gaming purposes I partitioned a Windows Vista to play a few video games. If you don't know what this is it means it runs just like Vista but on a iMac screen. This worked well (for gaming)...
Some games will not launch on win 7 64 bit
Just finshed building this computer, have all the updates direct X drivers etc. I'm trying to launch Eve Online, the splash screen pops up for about 30 seconds. Then it just disappears, no error messages or anything. I've tried installing and reinstalling, and running it in every compatibility mode...
How do I launch multiple files from Explore?
In Windows XP I could select multiple files (and types) in Windows Explore and ENTER would launch all of them. For example, I could select an XLS file and a VSD file, press ENTER, the spreadsheet would open in Excel and the drawing in Visio. How do I make this great functionality work in...
General Discussion
Games Won't Launch
Hi. Im having problem getting about 20% of my games to launch in Win7. They work just fine on my XP dual boot. What happens is that the games show up in the taskmanager as running but nothin ever shows up on the desktop. There is no increase in CPU or GPU usage and no "loading" sounds from the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App