Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Older game cinematic troubles on my windows 7

09 Nov 2012   #1

Windows 7 64 bit
Older game cinematic troubles on my windows 7

I've been having this problem with multiple games so I think I may be missing some software or something.
Whenever I play an older game (warcraft 3, neverwinter nights, etc.) My screen will turn black during any cinematic. I will hear the sound of the movie, but see nothing. The games themselves will play well and no problems wil occur in the video unless a pre rendered cut-scene is being played. Whenever a cutscene happens, the image will freeze until the scene is over.
This only occurs in older games, I've played new games like civilization 5 and Dishonored with no video issues whatsoever.

Running games in windows xp compatability does not work, nor does adjusting the video settings on the game itself. Am I missing some software or anything of the sort?

My System SpecsSystem Spec
12 Nov 2012   #2

Windows 7 x64 (Ultimate)

By adjusting the video settings... do you mean you adjust the game to your native video resolution? Perhaps you have the video at 1920 x 1080 and the game is incapable of it?

Check the game max requirements and try to set both resolutions to that... exampe: 1024 x 768 on both the monitor and game.

perhaps there is driver corruption and it wouldn't be a bad idea to update your drivers and/or go back to old drivers... even though you say ingame you have no problems viewing the game.
My System SpecsSystem Spec
15 Nov 2012   #3

Windows 8 64-bit (6.2, Build 9200) (9200.win8_rtm.120725-1247)

I know in NWN in the ini file, change safevideo=0 to safevideo=1, if it is already on 1, turn it to 0.

As for Warcraft 3, I had linked my game to my account and it fixed the video issue. Have you tried Alt+Tab out and back into game, and I know the system resolution trick works as well.

The system resolution trick is to right click on desktop, and choose change system resolution, leave that open and run your game, it takes a bit of trying a few times before you get used to it, sometimes you have to try it a few times, Alt+Tabbing opening the resolution screen and Alt+Tabbing back into games sometimes works as well.
My System SpecsSystem Spec


 Older game cinematic troubles on my windows 7

Thread Tools

Similar help and support threads
Thread Forum
Older pc game on win 7
Game installs fine will not load up and start.Read somewhere there is a work around. Came is MEDAL OF HONOR ALLIED ASSAULT,thanks for any input.
I can't uninstall an older game.
I installed Everquest and and was having problems. I wanted to reinstall. It does not show up in Control Panel>Programs>Uninstall. The game was in my user account folder. I manually deleted every file. Windows Search doesn't come up with any files. The game still runs perfectly. I learn...
Older DirectX heavy game has studdering problems.
I have a top of the line system and am running Win7Ux64 after a fresh format and an update to all windows files and hardware drivers. An older game that I used to play on XP was a game called Space Empires V. It was released in 2006. I've been having mouse lag issues when opening windows in the...
Can I run an older game with xp mode?
Can I run an older game with xp mode in virtual PC mode? I installed and game states "can't start hardware accelerated Direct3d 6" I tried using both integration and disabling integration I did install direct3d battlezone II Any thoughts? I am running windows 7 Professional 64bit host os
Older game (Soldier Of Fortune Platinum) EAX issue
Hi all,Just installed Windows 7 7600 build v. and installed a 9 years old game (Soldier of fortune) wich support EAX.Under vista was working perfectly with eax enabled within game,and sound drivers SBX-FI Series Support Pack 2.0,and latest Alchemmy version.Now when i choose to enable EAX within...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:24.
Twitter Facebook Google+