Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unresponsive Cursor in gaming

28 Sep 2009   #1

Windows 7 RC1 7100
Unresponsive Cursor in gaming

Does anyone have a solution for a problem I am having? I have loaded 6 games and 2 of them work fine but the other 4 do not. They all install fine but when the Load screen comes on the cursor is frozen to one spot and will not move. I have all the latest drivers installed. Any Ideas???
Windows 7 - 7100
ATI Catalyst 9.9

Maker ASUS
Model P6T
Rev 1.01G
BIOS Rev 0603
Part C928J7V-01454-60-MIB720-A01

Video Card
Maker ATI
Model HD4870X2
Part 102B5090201 000001

Sound Card
Maker SoundBlaster
Model XFI-Gamer

Power Supply
Maker Thermaltake
Model PSH 750V
Rev B
Part W0116RU

Boot HDD
Maker Samsung
Model HD103UJ
Part 48731A16AA1GYH
Capacity 1 TB

Storage HDD
Maker Seagate
Model Barracuda 7200.11
Part 9JU138-336
Capacity 1.5 TB

My System SpecsSystem Spec
29 Sep 2009   #2

Windows 7 Ultimate x64 SP1

What are the games that will not work? Are they online games that look for the net to play? If they are they might be trying to access the firewall and windows is stopping them from going any farther. To see if that is the case Alt-Tab out when the mouse freezes and see if there is a window open asking you for firewall access.
My System SpecsSystem Spec
30 Sep 2009   #3

Windows 7 RC1 7100
Single player local games

I installed the new Wolfenstein game and it workd fine. The ones that do not work are Drakensang which is a single player RPG, and Majesty 2 a single player RTS game.
My System SpecsSystem Spec

30 Sep 2009   #4

Windows 8 64bit Professional

Quote   Quote: Originally Posted by donwieber View Post
I installed the new Wolfenstein game and it workd fine. The ones that do not work are Drakensang which is a single player RPG, and Majesty 2 a single player RTS game.
Have you tried running them as an "Administrator", do it by right clicking the icon, and selecting "Run As Administrator".

I have to do that with Ventrilo, or else I can't use my Push-To-Talk button when playing fullscreen games.

Another tip would be to run the game in compatibility mode of Windows XP SP2/3 or Vista. I do that with some of my games, such as EVE Online or else it tells me I have insufficient rights to execute it or it errors me.
My System SpecsSystem Spec

 Unresponsive Cursor in gaming

Thread Tools

Similar help and support threads
Thread Forum
Laptop Mouse Cursor Won't Move, MousePAD cursor does
1. Optical USB mouse won't move the cursor. 2. Mouse buttons function properly 3. Bought a new similar mouse, same problem, ruling out damaged mouse likelihood. 4. Have tried multiple USB slots. Have tried rebooting. Have tried uninstalling the driver and rebooting. 5. Saw somewhere to...
Hardware & Devices
Mouse cursor stopped working -poss related to AMD gaming driver?
Please can someone help me! I was in the middle of writing an essay and all of a sudden my mouse pointer has stopped working. I cannot do anything! I think it may be something to do with the AMD gaming driver software update? I have no idea why that's on my laptop in the first place but it's got...
Hardware & Devices
Apply classic arrow cursor to background and busy cursor?
Maybe this sounds weird, but I like the classic cursors and I want the cursor to stay the same whether it's showing a background or busy activity. I tried to capture the cursor and edit it with AWicons, but when I set it, the entire cursor just dissapears when I launch an app for example. But...
Help please! Just finished watching a fantastic movie (avi) and the system became unresponsive. Tried turning off at computer (Windows7) shut down as per, re started and the system went directly to the media centre and was unresponsive. Turned off again, same same.. shut down, turned off and...
BSOD Help and Support
I need help! everything gets unresponsive! :0
Dear Members, I need help right now, my computer has windows 7 it was running smoothly. Until yesterday I turned it on and many things when opened, like, windows backup, windows update, Windows Office, iTunes and other system programs. I thought it was some kind of virus, but luckily I could run...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:11.
Twitter Facebook Google+