Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires 2: AoC expansion

25 Jan 2009   #11


Okay, I think I installed the nvidia drivers off the Acer website first, then found out about the automatic update drivers. I then installed those, could that've led to a conflict? If so, how do you think I should solve it? I tried doing a system recovery, but the windows update installed drivers remained existent.

Alt tabbing didn't work either
Thanks for helping me out though!

My System SpecsSystem Spec
07 Feb 2009   #12

Windows 7

I have the same problem, and i canŽt resolve it. IŽm usinŽradeon 2600 Pci-e.
that alt+tab worked in vista, but not under w7.
My System SpecsSystem Spec
17 Feb 2009   #13

Windows 7, Vista, Mandriva 2008

I'm running that game in Windows Vista on my other fine. According to Microsoft anything that runs in Vista should be running in Win 7 least thats is what they say...the reality may of course be different but hope not...
My System SpecsSystem Spec

28 Feb 2009   #14

Windows 7

ok, maybe, the problem is the beta version. it could be, that the normal release with the drivers will fix that problem. i have this corruption in vista too, but after alt+tab the graphics are excellent - but nit in w7. weŽll see after releasing.
there is one thing i know: w7 beta is still better than vista pro premium ultimate etc.
My System SpecsSystem Spec
10 May 2009   #15

Windows 7 RC 1 Build 7100

Same problem ... the colors are just ****y as hell...
I hope Microsoft will fix this in the final version, because this game is eternal !
My System SpecsSystem Spec
19 May 2009   #16

Windows 7

Ok Anarchitect you're in luck.

I've had the exact same problem, and it has been very annoying.

I've actually fixed it. Rather than go through detailed instructions, word for word, these images should do you justice.

From the first pic, right click on your desktop and click 'screen resolution' then 'Advanced Settings'.

Click the GeForce tab then the 'Start NVIDIA Control Panel' button

Next, make sure after you follow instructions in red in the pic, make sure you mimic all those settings. In the next pic I've scrolled down so you can see the rest of the settings.

These next two pictures I've taken of the 'Global Settings' screen, so you can mimic those settings as well.

Make sure you click apply in the bottom right hand corner and tell me how it goes.

This game is timeless and will go on for a long time.

Let me know if this works for you.

Attached Thumbnails
Age of Empires 2: AoC expansion-aoe2fix.jpg   Age of Empires 2: AoC expansion-aoe2fix2.jpg  
Attached Images
Age of Empires 2: AoC expansion-_aoe2fix.jpg Age of Empires 2: AoC expansion-a_oe2fix.jpg Age of Empires 2: AoC expansion-aoe2fixov.jpg Age of Empires 2: AoC expansion-aoe2fixov2.jpg 
My System SpecsSystem Spec
19 May 2009   #17

Windows 7

Also, I've just realized that this won't fix it UNLESS you keep the screen resolution window open (right click desktop > Screen Resolution).

My System SpecsSystem Spec
22 May 2009   #18


Thank you so much! It works like a charm!
When I had the resolution window open, I started the game. It worked fine, and after about 10 seconds it flashed back to the crappy stuff.
However, thanks to Raddest's methods, everything is working a-okay. I haven't played a whole game yet, but that should be alright. Thank you so much! Especially for taking the time to take screens etc., very much appreciated. If I can help you...

Billy Mays approves of your methods!
My System SpecsSystem Spec
25 May 2009   #19


So I played AoC the other day, finally, and what'll you know? After approx 5 minutes the screen goes weird again. If I go back to windows and then back to the game again, it fixes itself, and after five minutes it comes back again. Any ideas?
My System SpecsSystem Spec
28 May 2009   #20

Windows 7

Nope, but my fix isn't working properly now anymore either.

Thinking of formatting back to XP just because of this game hah.
My System SpecsSystem Spec

 Age of Empires 2: AoC expansion

Thread Tools

Similar help and support threads
Thread Forum
USB 3.0 expansion UAS drive in desktop?
Hello. I was wondering if there is anyway to access the contents of a Seagate 3.0 expansion UAS drive, when it's plugged directly into a SATA port on A desktop PC?
Hardware & Devices
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Partition expansion
I decided to delete the hidden Asus restore partition from my cloned hard drive. The drive had 2 partitions, the hidden one, then the C: drive (with system and data). This was before I found out that the Windows 7 Disk Management tool will not allow you to expand a partition to the left. So...
Installation & Setup
DA:O Expansion
For all you other Dragon Age origins fans out here: Dragon Age Origins - Awakening Looks like its scheduled for is scheduled for release in March. :D

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:27.
Twitter Facebook Google+