Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires 2: AoC expansion

28 May 2009   #21

Windows 7 Professional x64 RTM

Try opening up the Screen Resolution window by right-clicking on the desktop and selecting 'Screen Resolution', then run AoE.
You might have to enable some compatibility settings for it.
I have the following settings enabled:
  • Run this program in compatibility mode for: Windows XP Service Pack 2
  • Disable visual themes
  • Disable desktop composition
  • Disable display scaling on high DPI settings
  • Run as administrator
Without those settings, as well as without opening up the Screen Resolution window, AoC's colors are screwed up for me.
I'm using the latest DirectX 9.0c and modified 185.68 Forceware drivers for my Quadro FX 570M (

My System SpecsSystem Spec
28 May 2009   #22

Windows 7

Hi ambientmf,

Yea I've tried all of those, it seemed very random at best.

The way I'm getting around this now is, once you're in game and the colours are screwed, push F10, go to options, then change the resolution to 800x600, then change it back to 1280x768. For now this seems to be working.

Also, you need to have the resolution screen from windows open too. hah.
My System SpecsSystem Spec
03 Jun 2009   #23

Windows 7

When I try to play the AoE with other players, somebody always loses connection. Sometimes it's another player, sometimes I fall. But the problem is when I try to play under Windows 7.
1-With some players and me under vista everything runs OK.
2-With some players without me, they can play OK.
3-With some players and me under Windows 7 we can never play.

Note> the other players always play under windows xp

The problem begins when the game starts (when the game starts on the map)
My System SpecsSystem Spec

10 Jun 2009   #24

Windows 7 x64 (Build 7600)

I searched in whole Internet for a solution and I found one

Go into task manager select the processes tab and end explorer.exe then alt-tab back into age of empires
Note: this will make your task bar disapear and any open folders
To restart explorer open the task manager agian in the aplications tab hit new task and type explorer in the box
The colours change because of the Aero theme's poor handling of colours

You can also make a batch file with the following lines and place it in the same location as your age of empires 2 executable

taskkill /F /IM Explorer.exe
Start explorer.exe
My System SpecsSystem Spec
11 Jun 2009   #25


People posting fixes here are true heroes!
As internetpeoples we can be proud of ourselves.
My System SpecsSystem Spec
11 Jun 2009   #26

Windows 7 x64 (Build 7600)

That's what we are for
My System SpecsSystem Spec
13 Jul 2009   #27

Win7 x64 RTM

I too had this problem, and found no acceptable solution until this morning....

Go to
and click on "faça o download aqui" to download a mod. Unzip to your Age directory and launch AoC.exe.

This will run Age of Empires 2 The Conquerers in a window!
My System SpecsSystem Spec
14 Jul 2009   #28

Windows 7 Ultimate

When you configured that windowed mode patch, are you able to play the game in full widescreen?

Here's the original source for that patch, btw: AoC VEG MOD 2.0beta (new: windowed mode, configs) - Age of Kings Heaven Forum
My System SpecsSystem Spec
16 Jul 2009   #29

Win7 x64 RTM

Quote   Quote: Originally Posted by JButts View Post
When you configured that windowed mode patch, are you able to play the game in full widescreen?

Here's the original source for that patch, btw: AoC VEG MOD 2.0beta (new: windowed mode, configs) - Age of Kings Heaven Forum

No. This mod does not add any new resolutions to the game. AOE2 only supports 3 resolutions: 800x600, 1024x768, and 1280x1024. When I use it on my 1280 monitor, it actually goes to full screen on the 1280 setting.... but only when the game actually starts. The main menu, lobby and intros are all in 800x600.
My System SpecsSystem Spec
06 Aug 2009   #30


Hi. I have installed win7 on my pc. I was very happy it worked very good......

However, I wanted to play aoc. When I started the game the gras and the trees were not green like they used to be.

Can anyone help me please? I have tried everything from above and nothing worked. Please reply fast I am totally desperate.
My System SpecsSystem Spec

 Age of Empires 2: AoC expansion

Thread Tools

Similar help and support threads
Thread Forum
USB 3.0 expansion UAS drive in desktop?
Hello. I was wondering if there is anyway to access the contents of a Seagate 3.0 expansion UAS drive, when it's plugged directly into a SATA port on A desktop PC?
Hardware & Devices
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Partition expansion
I decided to delete the hidden Asus restore partition from my cloned hard drive. The drive had 2 partitions, the hidden one, then the C: drive (with system and data). This was before I found out that the Windows 7 Disk Management tool will not allow you to expand a partition to the left. So...
Installation & Setup
DA:O Expansion
For all you other Dragon Age origins fans out here: Dragon Age Origins - Awakening Looks like its scheduled for is scheduled for release in March. :D

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:59.
Twitter Facebook Google+