Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires 2: AoC expansion

17 Dec 2009   #51
savage1987

Windows 7
 
 

So pretty much, the outcome of this thread is that Windows 7 is a HUGE failure when it comes to playing older games (especially 64bit Windows 7!) and that AoE2 cannot be made to run comfortably - without ending Explorer.exe every time you run the game or other such band-aid fixes.. am I right?

I have wasted the past 2 hours trying to get this game to work. It's fine, if I don't mind opening the display settings window EVERY TIME I want to play it, and alt-tabbing out EVERY FIVE MINUTES when the colours go haywire again.

I don't think that counts as working properly.

I also don't think closing explorer.exe every time count as working properly either.

If there is nothing to be done about this, there is nothing to be done, which is a shame, because AoE2 is pretty much the only reason my Dad wanted his own computer, and it doesn't bloody work.

/end rant


Sam.


My System SpecsSystem Spec
.
18 Dec 2009   #52
jayb86

Windows 7 Ultimate
 
 
"savage1987"

Unfortunately the only way to stop the colours going nuts is ending the explorer.exe once you start the game. Although this is rather frustrating to think you are unable to play thie game in the way in which it was intended if you love Age of Empires 2 as much as we all day, it soon just becomes part of the game. As Microsoft no longer deal with this game there will be no offical fixes/patches provided for this game in the foreseeable future. Yes its annoying however if it means i have to end the explorer anytime i want to play AOE2 ? I will more than happily use up 5 secs to end a process to enable me to play, in my opinion one of the best PC games ever made.

Kind regards,
Jamie
My System SpecsSystem Spec
19 Dec 2009   #53
savage1987

Windows 7
 
 

Not willing to put up with it, neither is my dad. I will have to find him some new games to play. So much for Windows 7 being a gamer friendly platform... haha. Oh well, good excuse to upgrade to some more pretty games
My System SpecsSystem Spec
.

19 Dec 2009   #54
lollipop

Windows 7
 
 

Quote   Quote: Originally Posted by kyzawarrior View Post

Anyway i got another problem now , we're on hamachi with friend that have a notebook with winxp 32 and when he host the game i can see it but i can't connect , and when i create the game he can't see mee ...

( tryied : FW off , Compatibility modes and Run as Administrator ) help pls
To me happens exactly the same. Im with Windows 7 and I cant play AoC online. I cant see any games nor people see my ones when I create.
My System SpecsSystem Spec
20 Dec 2009   #55
xavierk

Windows 7
 
 

I have been able to play AOE2 with no problems.

My Stats:
Windows 7 x86_64
Dual Wide Screen w/DVI

Color Fix:
1) Right Click the Shortcut
2) Click Properties
3) Click Compatibility tab
4) Check the "Run in 256 colors"
*Do not select "Run this program in compatibility mode"
5) Click "OK"

Lan Mode Fix:
6) Access your router management interface
7) Navigate to your Port Forwarding Page
8) Disable UPnP
9) Save

10) Launch the Game and have fun!
*Note the game can take up to 2 minutes to load, but plays well.
**Colors are distorted for a few seconds but clears up
***Water colors are still slightly messed up, but for the most part is very playable.


Xavier
My System SpecsSystem Spec
20 Dec 2009   #56
noside85

W7 (64)
 
 

i believe my prob is that i need to have resolution at 4:3...the old school comps. my vizio won't do it by itself. My gf's laptop (win7 32bit) sets it to 4:3 and very playable with that comp. anything i can do? maybe get a RCA to RGB (or something) adapter?
My System SpecsSystem Spec
21 Dec 2009   #57
lollipop

Windows 7
 
 

Quote   Quote: Originally Posted by xavierk View Post
I have been able to play AOE2 with no problems.

My Stats:
Windows 7 x86_64
Dual Wide Screen w/DVI

Color Fix:
1) Right Click the Shortcut
2) Click Properties
3) Click Compatibility tab
4) Check the "Run in 256 colors"
*Do not select "Run this program in compatibility mode"
5) Click "OK"

Lan Mode Fix:
6) Access your router management interface
7) Navigate to your Port Forwarding Page
8) Disable UPnP
9) Save

10) Launch the Game and have fun!
*Note the game can take up to 2 minutes to load, but plays well.
**Colors are distorted for a few seconds but clears up
***Water colors are still slightly messed up, but for the most part is very playable.


Xavier
AWESOME man.

AWESOME

My System SpecsSystem Spec
26 Dec 2009   #58
benvivi

Windows 7 x64 pro
 
 

Quote   Quote: Originally Posted by adamzx View Post
I havnt been able to solve the issue, but a work around is:

1.Change desktop theme to windows classic and then,
2.Open the screen resolution window
3.Then load AoE

(saves closing explorer.exe)

For some reason this removes the 'red grass effect', if it doesnt first up, once in a game, simply tab out and back in. Both steps must be completed for me. Simply bringing the resolution up doesnt help.

Enjoy.
Hello ! I have the same problem of you in an ATI graphic Card (4850). But you're soluce work without to kill the explorer process. Thank you.

(I have Windows 7 x64 pro)
My System SpecsSystem Spec
28 Dec 2009   #59
igan

Win 7
 
 

i also have a problem, you see i am using laptop with 1366x768 resolution under ATI Radeon HD 3200 hardware..

The problem is that the game display with black bars on the left and right and it's not full screen. The colors can be fixed by killing the explorer.exe process although it's kinda making me hectic.

Does any one knows how to fix this?

Thanks
My System SpecsSystem Spec
28 Dec 2009   #60
miztik

windows 7
 
 
new member with a question

Everytime i open up AOE it opens up a black screen then
closes and a error bok pops up and says " Could not
initialize Graphics , make sure you video card and driver
are compatible with direct draw" i need to know how i can
fix this problem. I am running an ATI Raedon 4350.
My System SpecsSystem Spec
Reply

 Age of Empires 2: AoC expansion




Thread Tools




Similar help and support threads
Thread Forum
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
Gaming
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Gaming
Portable Expansion Drive.
Hi, I have a Seagate USB3 500GB Portable Expansion Drive to accommodate my Back-ups and also any files I wish to 'transport' to another PC. I would prefer to leave the device connected to my PC except when I need to transport files. Will leaving it connected do any harm; should it be removed when...
Backup and Restore
automatic submenu expansion
Win7 Ultimate x 32, SR1 fully updated - I've disabled the "open Submenus" option in start menu but still getting regular popup windows. There was a registry entry I disabled previously which stopped it, but after recent updates it's back and I can't find or remember the reg entry I modified....
Performance & Maintenance
Partition expansion
I decided to delete the hidden Asus restore partition from my cloned hard drive. The drive had 2 partitions, the hidden one, then the C: drive (with system and data). This was before I found out that the Windows 7 Disk Management tool will not allow you to expand a partition to the left. So...
Installation & Setup
DA:O Expansion
For all you other Dragon Age origins fans out here: Dragon Age Origins - Awakening Looks like its scheduled for is scheduled for release in March. :D
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App