Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires 2: AoC expansion

30 Dec 2009   #61

W7 (64)

all in all, the microsoft game series AoE doesn't easily work with microsoft's new OS. gay indeed. some ppl have luck, i've been S.O.L. and just play on my girl's laptop (w7 32bit). thanks microsoft

My System SpecsSystem Spec
13 Jan 2010   #62


hey i now how i made a video in youtube :):)
My System SpecsSystem Spec
13 Jan 2010   #63

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64

No offense but I have 20/20 vision and I can't even read what code you placed inside that batch file on the video...

Why don't you upload the batch file here so people can just use it
My System SpecsSystem Spec

13 Jan 2010   #64

Windows 7 Professional 32 Bit

Quote   Quote: Originally Posted by Anarchitect View Post
Hi guys,

I installed W7 and so far it's been working fine. However, I ran into a problem. When I try to play my AoE 2: the Conquerors expansion, everything works. When I start a game, some of the graphics (trees, grass and water) seem highly corrupted (mostly they're much to 'red'). When I put the resolution on 800x600, it works. When I try 1024x768, I get the weird corruption.
I tried most of the compatibility modes (XP, W2000, W98, all with different combinations of DPI/Visual Themes/256 colors etcetera). Does anybody have an idea?

Thanks in advance!
I'm not sure if someone has answered your question, but what I do is open the game, then whilst in the game press Alt and Tab, then disable explorer.exe from the task manager, then Alt and Tab again to return into the game, and you should have the correct graphics and colour. I believe the reason for this is the compatibility issues with Aero. Let me know if this works.
My System SpecsSystem Spec
14 Jan 2010   #65


it works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
My System SpecsSystem Spec
14 Jan 2010   #66

Windows 7

Quote   Quote: Originally Posted by morfeu View Post
I searched in whole Internet for a solution and I found one

Go into task manager select the processes tab and end explorer.exe then alt-tab back into age of empires
Note: this will make your task bar disapear and any open folders
To restart explorer open the task manager agian in the aplications tab hit new task and type explorer in the box
The colours change because of the Aero theme's poor handling of colours

You can also make a batch file with the following lines and place it in the same location as your age of empires 2 executable

taskkill /F /IM Explorer.exe
Start explorer.exe
Thanks a lot. Of all the solutions posted here, this is the only one that works.
My System SpecsSystem Spec
15 Jan 2010   #67


My System SpecsSystem Spec
19 Jan 2010   #68

W7 (64)

didnt work for me. the resolution is still messed up, i've tried everything to fix it but nothing worked. the in-game screen is running out the monitor, you can't see the list at the very top. i tried changing all 3 resolution settings in game, tried changing resolution out of game, nothing. nothing at all. i think it would work if i could get my screen to show 4:3. any ideas?
My System SpecsSystem Spec
20 Jan 2010   #69

Win7,Win Vista

I have Age of Empires 3. 2 doesn't work for me.
My System SpecsSystem Spec
21 Jan 2010   #70

Windows 7 64bit Ultimate

I have been able to play AOE2 with no problems.

My Stats:
Windows 7 x86_64
Dual Wide Screen w/DVI

Color Fix:
1) Right Click
the Shortcut
2) Click Properties
3) Click Compatibility tab
4) Check the "Run in 256 colors"
*Do not select "Run this program in compatibility mode"
5) Click "OK"

Lan Mode Fix:
6) Access your router management interface
7) Navigate to your Port Forwarding Page
8) Disable UPnP
9) Save

10) Launch the Game and have fun!
*Note the game can take up to 2 minutes to load, but plays well.
**Colors are distorted for a few seconds but clears up
***Water colors are still slightly messed up, but for the most part is very playable.
This works for LAN play. Give it a minute to warm up, and then it is great.

My System SpecsSystem Spec

 Age of Empires 2: AoC expansion

Thread Tools

Similar help and support threads
Thread Forum
USB 3.0 expansion UAS drive in desktop?
Hello. I was wondering if there is anyway to access the contents of a Seagate 3.0 expansion UAS drive, when it's plugged directly into a SATA port on A desktop PC?
Hardware & Devices
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Partition expansion
I decided to delete the hidden Asus restore partition from my cloned hard drive. The drive had 2 partitions, the hidden one, then the C: drive (with system and data). This was before I found out that the Windows 7 Disk Management tool will not allow you to expand a partition to the left. So...
Installation & Setup
DA:O Expansion
For all you other Dragon Age origins fans out here: Dragon Age Origins - Awakening Looks like its scheduled for is scheduled for release in March. :D

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:48.
Twitter Facebook Google+