StarCraft fix holy cow!

Page 1 of 25 12311 ... LastLast

  1. Posts : 68
    Windows 7 (7127)
       #1

    StarCraft fix holy cow!


    So there I was, stuck playing starcraft in crappy colors yet again, as it has always been during my beta testing of windows 7. For what ever reason, I decided to leave screen resolution dialog box open and what do you know- starcraft runs with its beautiful original colors.

    If anyone knows what I'm talking about:

    Symptoms:
    Starcraft runs with bright turquoise colors everywhere in the menu system. It looks rather psychedelic.

    On vista, it intermittently happened, on win7 it happens every time after the 1.16.00 patch installed.

    Fix:
    Simply open up your screen resolution window before playing, and leave it open. Doing so will result in perfect colors ever time. The same for vista, just open up personalize. I have no idea why this works, but I've tested it many many times- you just open the window- nothing else.

    I've reported it to MS and Blizzard- blizzard quickly blew me off though with a "WINDOWS 7 IS NOT SUPPORTED" email.

    Hmm... nope, don't care about spelling.

    enjoy SC lol!
    Last edited by johngalt; 19 Apr 2009 at 15:04. Reason: spell checked - *I* do care.
      My Computer


  2. Posts : 1
    Dual booting Windows XP service pack 2 and Windows 7 beta build 7000
       #2

    I can confirm this.
      My Computer


  3. Posts : 8
    Windows 7
       #3

    Hm this is great.
    Now only if we can get a World of Warcraft fix...
      My Computer


  4. Posts : 2
    Windows 7 Ultimate 32-bit (6.1, Build 7000)
       #4

    ... OMG im coming all the way from israel to ohio just to kiss you@!#$ THX SO MUCHHHH!!!! YOUR A GENIUS!!
      My Computer


  5. Posts : 9
    Windows 7 Beta Build 7000
       #5

    Tomthe3rd said:
    ... OMG im coming all the way from israel to ohio just to kiss you@!#$ THX SO MUCHHHH!!!! YOUR A GENIUS!!

    LMAO tom cracks me up
      My Computer


  6. Posts : 2
    Windows 7 Ultimate 32-bit (6.1, Build 7000)
       #6

    Hootie said:
    LMAO tom cracks me up
    XD ive been searching for quite a while after a fix of some sort for this problem XD just went crazy after ive finally found it XD
      My Computer


  7. Posts : 68
    Windows 7 (7127)
    Thread Starter
       #7

    I too searched for a fix forever, but never found it. Glad I could help some people... I'll probly post this elsewhere for others to see.

    If you care to know how i found it:
    I run multiple monitors most of the time, however starcraft would run in ultra terrible colors if i had more than one graphics card active. (these colors were much worse than the normal menu messup, they had that problem and were what seemed inverted). Anyway, I commonly opened my display settings, shut two monitors off, then played. I just happened to leave it open by accident one day, started up the game and it looked great.

    Tried it a few more times and noticed scr res was open, horray!
      My Computer


  8. Posts : 2
    Windows 7
       #8

    Proper Fix Tested and working


    This is one way to guarantee starcraft works without opening certain windows beforehand etc. Right click on the starcraft.exe in \Program Files\Starcraft. Go to the compatibility tab in properties and tick every box under settings: All of these relate to graphics so tick em all! Do not tick run in compatibility mode though cause then sc won't run can't find a font file somewhere . Anwho hope this helps!
    Last edited by johngalt; 19 Apr 2009 at 15:03. Reason: spell checked
      My Computer


  9. Posts : 68
    Windows 7 (7127)
    Thread Starter
       #9

    doesnt work


    Sadly, nope... this does not work for me. The window still needs to be open. I am still running 16.0 - I saw that they released a 16.1 recently, maybe this is why it's working for you? I'll have to try updating it later.
      My Computer


  10. Posts : 2
    Windows 7
       #10

    Maybe. I am running the windows 7 build 7000 64bit with starcraft patched to 16.1 and a 9800gtx. Strange that my fix won't work for you. I was having exactly the same problem. Does your graphics card have drivers for vista 64bit/32bit those are the ones most likely to work with 7?
      My Computer


 
Page 1 of 25 12311 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:01.
Find Us