Fallout 3 on Windows 7.

Page 3 of 65 FirstFirst 1234513 ... LastLast

  1. Posts : 12,364
    8 Pro x64

    thunderclap said:
    I did, and it doesn't seem to work.
    That method worked for me with the x32 version, but I'm just trying it and it's not working for me in x64.... catalyst is failing to detect the hardware and the installer is 'just sitting there'. Perhaps it's a similar detection issue with Nvidia.

    I'm going to give driver sweeper a go.


    Phew, talk about an uphill battle getting Catalyst 8.12 Drivers to install.

    Unfortunately it made no difference. FO3 is still hanging....

    At least it *may not* be a driver issue. Then again, I can't even play it in window mode.
    Last edited by smarteyeball; 11 Jan 2009 at 23:19.
      My Computer

  2. Posts : 7
    Windows 7

    I hope this helps someone.

    I ran into problem similar to whats mentioned in this thread, where I would launch the game and would just get stuck in a loop with the launcher. Well it turns it if you start adding, removing, changing the location of your documents, and your library settings, the launcher loses track of where "My Games/Fallout 3/" Directory is, and doesn't seem to recreate it, just gets stuck in a loop.

    So double check all those settings, change or move your "My Games/Fallout 3" directory and you should be good to go.
      My Computer

  3. Posts : 4,364
    Windows 11 21H2 Current build

    What about those that *don't* have it moved?
      My Computer

  4. Posts : 7
    Windows 7

    thats just worked for me, when I was stuck in a launcher loop.

    Another thing is check to make sure permissions are set correct. Give the My Games and Fallout 3 full read write permissions to Everyone. Beyond that I have no clue.
      My Computer

  5. Posts : 12,364
    8 Pro x64

    Chuki, your a champ :) It was a permission problem. It would hang at the point where it would've been writing to the save game. No write access=hang.

    I took ownership of the C:\Users\*YOURNAME*\Documents\My Games\Fallout3 folder and gave my username full read/write privileges. I Started a new game and it was past the hang. Save games from Vista work too :)

    It's a similar issue to the Vista / S.T.A.L.K.E.R save game problem that occured in one of the patches. The game kept crashing because of write permissions.
      My Computer

  6. Posts : 7
    Windows 7

    Glad I could be of assistance, I was just googling my own problem and found this thread, and then finally fixed my problem. It was a mix of relocating folders in the library and the move from Vista to Win7 did something to the permissions as well.
      My Computer

  7. Posts : 5
    windows 7

    Ok,I've got the same launcher crash out as chuki et al,but my Fallout 3/My games file is read-only no matter what I do;ownership change,permissions changed and the GENERAL tab jumps back to read-only next time I open it no matter what it says in the SECURITY tab.Any ideas?
      My Computer

  8. Posts : 7
    Windows 7

    Right your Documents folders, go to security make sure Administrators, and Users, have full access, then go to the My Games folder do the same, then fallout 3 folder and do the same.

    If that don't work backup the Fallout 3 Folder, delete and see if the game can recreate it. If that works just cut and paste your saves.
      My Computer

  9. Posts : 6
    Windows Vista/7

    Ok, I ran into the fallout 3 launcher loop thing. I first messed around with my documents to the point where I couldn't even find it. I made a new profile on windows, and reinstalled the game.

    I'm still having trouble with the launcher loop thing. Other games are working fine. Every time the launcher comes up, it does the hardware configuration check and resets everything to the "High Quality" level.

    So far I have

    Deleted "my games" folder (I moved my saves to a different place, but even if that doesn't work I'll just start anew).
    It just creates a new "my games" folder on start up, and continues the loop.
    Checked the security tab on each folder and ini file to make sure there is full read/write privileges.
    Nothing changed, loop still there.
    Checked the security tab for the game and launcher, gave all privileges of read/write.
    Nothing changed, loop still there.
    Reinstalled the game
    Nothing changed, loop still there.

    I currently am out of ideas of how to get this game running. Chuki, what is everything you have done from getting the problem to running the game properly; point A to B? I have a feeling that you might have done something you might have thought was trivial at the time, but actually fixed the problem. I have a feeling I know what the problem is, I just have no clue in how to fix it. Is there any way to change the location of the FalloutPrefs.ini?
      My Computer

  10. Posts : 7
    Windows Vista

    Okay, well this is what we know:

    Fallout3.exe punts to FalloutLauncher.exe if FalloutLauncher.exe has never been run before. So, the problem lies in the fact that Fallout3.exe and FalloutLauncher.exe always think that this is the first time its been run... hence the Launcher loop.

    So the question is where it is that the Launcher stores the information that it has been run before, and whether the problem is that it can't store that information or can't retrieve that information, or both. Unfortunately, Securom complains if you run Process Monitor while the Launcher is starting. And Process Monitor doesn't yield anything I can detect for Fallout3.exe that might explain it...
      My Computer

Page 3 of 65 FirstFirst 1234513 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:55.
Find Us