Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Warcraft III

28 Jan 2009   #1
Eternal Cat

32-bit b7000
Warcraft III

So I've had Win7 running for about a week now, and I can't get Warcraft III:TFT to work. I've got the French version on CD. I ran the install.exe files as admin and in XP SP2 compatibility mode while installing, and didn't get any problems. I installed the 1.22 full patch too, again running in XP SP2/admin mode (I also had to make the C:/Program Files/Warcraft III directory . I've also set run-as-admin on Frozen Throne.exe, Warcraft III.exe, and war3.exe, and am running those in XP SP2 mode too. When I run frozen throne.exe, I get told "Warcraft III was unable to initialise." followed by a message (in French) asking me to insert the CD and click retry. What really bugs me is that I shouldn't be getting a CD error, because for quite a few versions now, WC3 hasn't needed the CD to run. I'm not sure what else I can do from here. Has anyone had a similar problem?

My System SpecsSystem Spec
15 Nov 2009   #2

Windows 7

I did a complete reformat when I got Win 7 with a new HDD. When I put the WC3 disk in to install it says it doesn't support Windows NT.... I think we might be screwed unless Blizzard comes out with a patch we can install or something.
My System SpecsSystem Spec
15 Nov 2009   #3

Windows 7 Professional (x64)

I was able to install and play after running the latest patch which is 1.24b.

On a side note, I've gotten WC3 to play in widescreen from this thread.
My System SpecsSystem Spec


 Warcraft III

Thread Tools

Similar help and support threads
Thread Forum
warcraft 3
it wont load i get this issue roblem signature: Problem Event Name: APPCRASH Application Name: Frozen Throne.exe Application Version: Application Timestamp: 3eb0223d Fault Module Name: Frozen Throne.exe Fault Module Version: Fault Module...
Warcraft III RoC + Warcraft III TFT Problem
Hai! For days I've been trying to install Warcraft III RoC and Warcraft III TFT. The first few times I attempted to install RoC it just stopped halfway through and the installation window couldn't be closed. After those few times, I managed to install it. With a boost of hope, I placed the TFT...
HELP PLZ warcraft 3 and win7
OK just installed win 7 downloaded it from microsoft, i can't get war3 to work now. i start it up and it starts to load war3, black screen then back to desktop with a 800x600 resolution. i have to ctrl alt del to start task manager and end war3 via process tab. then my screen will go back to...
Warcraft 3
Hello Guys! Today i installed Windows 7 Enterprise Edition on my PC and wanted to install Warcraft 3! So i installed Warcraft 3 ROC and everything went fine. But when i tired to install Warcraft 3 TFT the system told me that i have to install Warcraft 3 ROC before. But the ROC is already...
ok strange problem, i used to be able to run 2 copy of wow at once on my hardware running vista 64, now on windows 7 its not possible, it just grind to a halt my hardware is Intel Q9650 (quad core 3 ghz) 6 Gigs PC800 DDR2 ATI 4850 Graphics.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:50.
Twitter Facebook Google+