Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bioshock finally working

19 Sep 2009   #21


Wow, thanks Leon, i just tried Win2k compatibility like you suggested & it worked. Sound & crashing problems fixed I'd almost given up trying to get bioshock to run on 7. That's the problem with bioshock, great game but it was poorly tested, you never know if it's going to work with certain hadware configurations or not...

My System SpecsSystem Spec
12 Nov 2009   #22

Windows 7 Professional x64


Thanks for your help! This was the ONLY fix that worked for me and Bioshock now runs happily on my Win7 x64 machine. It's odd how things change between the RC and the final code (as the game ran fine on the RC). But I'm back up and running again.
My System SpecsSystem Spec
08 Jan 2010   #23

Windows 7 64bit
Bioshock working in Windows 7 64bit

Hi all,
First time posting. I got Bioshock (Non Steam version) to work by doing this. I installed it while running the installer in Windows XP SP2 compatibility. Whether that makes a difference, I am unsure.
Then to run the game, do this:
Start Menu
All Programs
When you see Bioshock, right click and select Play - Direct X 9

The game worked like a charm. I had audio and the game never froze.
Good luck
My System SpecsSystem Spec

08 Jan 2010   #24

Windows 7 Ultimate x86-64

Installed easily, patched it as the auto didn't work. Set to Vista SP2 compatiblity, and only the sound in one section close to the end was off for a few minutes. No issues - except without compatibility its unplayable for me.
My System SpecsSystem Spec
30 Jan 2010   #25

windows 7 ultimate
Bioshock problem solved easy

I was have similiar problem on my new instaled win 7 ultimate (sorry for my bad english) - no sound in game. Try this (see picture), works for me just fine ....
Without any patching, any start under win xp compatibility, just do it and play the great game ....
I have a standard configuration (dual core e6300, mb g31, ati 4650, hd 500gb, sound card on board, 4gb ddr2 ram .... standard drivers for mb and gpu)

Attached Thumbnails
Bioshock finally working-09_windows_7_no_sound.png  
My System SpecsSystem Spec
07 Feb 2010   #26

Windows 7 Home Premium 64-bit

I have the exact same problem as ballerjones as well, I have the retail copy and sound doesn't work in game...only in menu or when hacking. Any help appreciated.

Referring to doco300, anyone know why in Sound nothing comes up when I enable disabled devices? Technically Realtek High Definition Audio (or rather I mean the Stereo Mix) should appear since I had to do the same thingish for CoD4 when I was running Vista. Again, any help appreciated.
My System SpecsSystem Spec
08 Feb 2010   #27

Windows 7 Professional x64
Bioshock on Windows 7 x64 and Steam

try this Support it worked for me and DX10, sound, and everything else works, and I don't have to use compatibility mode
My System SpecsSystem Spec
15 Feb 2010   #28

Windows 7 Home Premium 64-bit

Okay I got it, I just needed to install the sound driver and then I could go into the sound tab. Thanks all.
My System SpecsSystem Spec
16 Mar 2010   #29

Windows 7 Home Premium 64bit

I have tried to install Bioshock on a new Windows 7 machine.
My first attempt was as described by several others in this thread - the sound was working in the game menus and videos, but not in the game itself.
My first response was to attempt an unstall and reinstall... but guess what? It now will not install - I'm getting CRC errors (?!?) because .bik files don't match those in the setup's cab file (it also says the medium may be corrupted, but since I'm not trying to talk to dead relatives, that doesn't bother me).

Any suggestions? I'd happily try playing the game with no sound... if I could get it to work at all...
My System SpecsSystem Spec
17 Mar 2010   #30

Windows 7 Home Premium 64bit

Strange, I didnt have any issues at All w/Bioshock or Bioshock 2 in Win7 x64.
Even w/DX10. No need for comapatability, tweaks or anything.
Just instal, patch & play.

The only issue I had was with sound.
If set for 5.1 and Reverb ON, I had positional 5.1 that worked perfectly.

If I turned on EAX effects, I had sound in menu but not in game.
i even tried Alchemy as well, and still wouldnt work.
My System SpecsSystem Spec

 Bioshock finally working

Thread Tools

Similar help and support threads
Thread Forum
Did Microsoft finally get IE11 working right
I just downloaded and installed IE11 with my patch Tuesday updates and it seems to be working better than what IE10 was, it took them 7 months to get it right as it only took about 4 months to get IE10 working right
Browsers & Mail
BioShock 2
can anyone give me there views on this game please? :D
Bioshock and GEF
For some reason, my bioshock icon is blank in the GEF. I checked and it also is in the main directory for some reason. How can I go about changing this. I don't need it to appear in the main directory but really need it to show in GEF. I've tried adding "BoxArt" string to regedit and typing...
For some reason, I cant seem to hear any sound during game play of Bioshock, but the weird thing is, during cut scene movies, there is sound. Anyone experience this problem before?
Bioshock not working. DX11?
Bioshock refuses to launch. It's telling me that the d3dx9_33.dll file is missing. This is a file for DX9. Not sure if it also part of DX10. But I'm using DX11. Has anybody able to run Bioshock without the need for instsalling DX9 or DX10?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:24.
Twitter Facebook Google+