Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Bioshock finally working

17 Mar 2010   #31
stepfordhusband

Windows 7 Home Premium 64bit
 
 

I'm only running with stereo sound.... but since my problem is more fundamental than that, now, I frankly couldn't give a damn about lack of sound at the moment...

I just want to be able to install the damn game!


My System SpecsSystem Spec
.
17 Mar 2010   #32
Frostmourne

Windows 7 Ultimate x86-64
 
 

Quote   Quote: Originally Posted by stepfordhusband View Post
I'm only running with stereo sound.... but since my problem is more fundamental than that, now, I frankly couldn't give a damn about lack of sound at the moment...

I just want to be able to install the damn game!
What are your system specs? Post a screenshot of HWInfo32's summary screen.
My System SpecsSystem Spec
18 Mar 2010   #33
stepfordhusband

Windows 7 Home Premium 64bit
 
 

I don't know what HWInfo32 is, but I can give you a brief run down of my system spec...

AMD Phenom II X4 965
4Gb RAM
nVidia GTX260
Plenty of HDD space
Windows 7 Home Premium 64-bit.

Anything else?

Get this, though... the problem is getting worse.

Earlier it failed to load at the "Engine.U" file (I tried a couple of times, but it was the same each time)
So I ejected the disk and tried again; it failed to load at a blk file - the same one, a couple of times.
So I ejected again, and tried again; this time it failed to load at the "dfe" (I think) file...

Every other game I have tried to load has worked... I don't see this as a drive or a media failure...

It seems to fail to load at a different point, dependent upon when I put the disk in... MADNESS!!!
My System SpecsSystem Spec
.

18 Mar 2010   #34
Wishmaster

Windows 7 Home Premium 64bit
 
 

Seeing as its different points, It could be a error reading the disc. Either the disc itself or the reader.

Can you copy the contents of the disc to your HD, or create a ISO of it successfully?

If not, its likely read errors.
My System SpecsSystem Spec
20 Mar 2010   #35
stepfordhusband

Windows 7 Home Premium 64bit
 
 

I'm not convinced it is the media, since it installs fine on my old machine, but I did (eventually) manage to get it to install...

Each time the installation failed on a file I ejected the disc, and reinserted it, clicked retry, and lo-and-behold, it then loaded that file (but later failed on another file, of course)... the whole process took about four hours... *sigh*

Now I'm back to a situation where I have sound in the game menus, in the video clips, but not in the playable part of the game itself... frustrating...

...and nothing suggested anywhere seems to work!
My System SpecsSystem Spec
26 Mar 2010   #36
VulcanSoulPatch

Win7 Pro x64
 
 
Bioshock (Steam ver.): what worked for me... so far!

Just got my new rig about a week ago, and even though I had bought Bioshock during the Steam Winter Sale, I did not install it until last night since my last comp had no hope of running it.

My issue was a little worse than what most have experienced, as I could not even get the game to load. First, it froze on the nVidia splash video with looping sound. Took forever to get it to reboot at this point, since my whole system was bogged down (like trudging through mud). So, my first step was this:
Quote   Quote: Originally Posted by MUff1N View Post
I don't know if you figured this out yet or not, but all you have to do is run Microsoft DirectX® End-User Runtime to fix W7 up for gaming!
After I installed the Runtime ALL my games played just fine!
It installs all versions of DirectX & the games will use what they need.
Installing DX Runtime got me through that hiccup, only to freeze at the end of the next splash video (RT Games). Wove my way to the exe file and tried the Win7 compatibility troubleshooter. It suggested WinXP SP2. No dice, but it was easier to reboot (not as bogged down). So, then I tried this:
Quote   Quote: Originally Posted by LeonLandford View Post
I know it sounds weird, but after changing bioshock exe to work in compatibility mode with windows 2000, everthing just went fine, even with that crap patch 1.1 from 2k. the game is running well and isnt crashing anymore, hope that will help! ( lol)
And it worked!!! Sonuvagun... who woulda thunk that Win2K could be useful for anything? Anyway, this got me to the title screen, so I decided to go ahead and post my findings (thus far) since it has taken me about 1.5 hrs to get here. Will update if I need to do anything else.

Hope this helps out fellow Steamers!

VSP
My System SpecsSystem Spec
26 Mar 2010   #37
VulcanSoulPatch

Win7 Pro x64
 
 

Crud... got too greedy. Noticed that the title screen was a little grainy, so I went into the Options menu and saw that the default rez was 1024 x 768, so I bumped it up to my native rez (1920 x 1200) and it bombed out. Now I can't get back in.

Anybody know how to change the display settings before running the game?

Can't think anymore. Gonna hit the hay and try again in the morn.

VSP

EDIT: OK, I was able to get it to load again and it seems Bioshock reset itself back to default rez. I upped it to a lower rez widescreen mode, and it bombed out again. Really, truly giving up for the night.
My System SpecsSystem Spec
29 Mar 2010   #38
VulcanSoulPatch

Win7 Pro x64
 
 

So, I decided to download the Catalyst 10.2 driver last Friday and give it a go, and found out that they had just released 10.3 on 3/24/10. I did the appropriate uninstall/install and reset the compatability mode to none. Clicked on the Bioshock link and crossed my fingers...

Voila!!!

Worked like a charm. Changed the rez to 1920 x 1200 and it did not bomb out. Looked beautiful! In fact, I played it for about 4 hours straight.

(Still getting the large mouse pointer at random intervals, but I read here that they released an even newer 10.3 since I downloaded it. Thanks to Rik55 for the link and Airbot for linking to the link. Off to try that one.)

Now I just have to figure out if it is better to harvest or not... any advice (w/o giving away too much story)?
My System SpecsSystem Spec
29 Apr 2010   #39
demonparia

Windows 7
 
 
Oh, here's an idea...

Running it in Windows 2000 compatibility mode worked, and here's something to think about.

The name of the company is 2K.

2K? Two thousand. Windows 2000. It makes sense. Am I right?
My System SpecsSystem Spec
29 Apr 2010   #40
rvbfan

Windows 7 Home Premium 64bit
 
 

Harvest
My System SpecsSystem Spec
Reply

 Bioshock finally working




Thread Tools




Similar help and support threads
Thread Forum
Did Microsoft finally get IE11 working right
I just downloaded and installed IE11 with my patch Tuesday updates and it seems to be working better than what IE10 was, it took them 7 months to get it right as it only took about 4 months to get IE10 working right
Browsers & Mail
BioShock 2
can anyone give me there views on this game please? :D
Gaming
Bioshock and GEF
For some reason, my bioshock icon is blank in the GEF. I checked and it also is in the main directory for some reason. How can I go about changing this. I don't need it to appear in the main directory but really need it to show in GEF. I've tried adding "BoxArt" string to regedit and typing...
Gaming
Bioshock
For some reason, I cant seem to hear any sound during game play of Bioshock, but the weird thing is, during cut scene movies, there is sound. Anyone experience this problem before?
Gaming
Bioshock not working. DX11?
Bioshock refuses to launch. It's telling me that the d3dx9_33.dll file is missing. This is a file for DX9. Not sure if it also part of DX10. But I'm using DX11. Has anybody able to run Bioshock without the need for instsalling DX9 or DX10?
Gaming
BioShock Problem
every time i run bioshock i get not responding here is the error report Faulting application name: Bioshock.exe, version: 1.0.0.0, time stamp: 0x00000000 Faulting module name: Bioshock.exe, version: 1.0.0.0, time stamp: 0x00000000 Exception code: 0xc0000005 Fault offset: 0x012d6e60 Faulting...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App