Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "lag" in online games with Windows 7

08 Jan 2010   #101
Nipzon

Win7 64-bit
 
 

Over the last couple days Microsoft has been pumping my win7 pc with updates and I keep hoping that some of it will fix my problem but no go as yet. I found a couple mobo driver updates on the Asus website including Bios updates.
I have also tried everything mentioned on this site including XP 32 which leaves me to think it's the mobo only.


My System SpecsSystem Spec
.
08 Jan 2010   #102
TheHonkeyDonkey

windows 7 32bit
 
 

So are you getting the same problem as I am? No sound drivers = cpu performs as expected. sound drivers = cpu usage goes to 100%. could be conflicting drivers but i've tried so many with driver sweeper and everything.. Think I'm gonna have to boot up XP again.
My System SpecsSystem Spec
09 Jan 2010   #103
Ozirus

Windows 7 Home Premium 64-bit
 
 

My System SpecsSystem Spec
.

20 Jan 2010   #104
PapaSmurf2413

Windows 7 Ultimate 64-bit
 
 
I figured it out.

I think I completely figured it out... I uninstalled my realtek drivers..... every single problem went away.. I had vent crashes, source issues.......all that crap. Surprisingly after I did that (because I was just reinstalling my drivers when I found this out), you still have sound with windows default. Everything worked out completely perfectly for me. If you have no other options, just install your audio drier and see if anything works. Worked perfectly for me guys!
My System SpecsSystem Spec
20 Jan 2010   #105
valtonray

Windows 7 Ultimate Signature Edition
 
 

thanks for the tip. it's likely you had the wrong version of the driver if that what was causing your problems, but if the windows default works better for you stick with it.
My System SpecsSystem Spec
28 Jan 2010   #106
nightrhyme

windows 7
 
 

So I guess this is the mother-lagg-thread

I have now tried all suggested fixes to no avail.

  • Disabled all sound hardware
  • Removed the MMCSS service
  • Used the regedit fix

System specs:
Asus p5k premium
C2D 6850
4GB Ballistix pc8500
ATI HD4870 1GB
Audigy2 value
Corsair 520w
windows 7 ultimate 64bit


I guess win7 i not for me. I don't get down on my hardware as it's just fine and imho the fault lies with win7. Well if it was just my soundcard I would buy another

First time I tried win7 was at release and no one had heard of the spike lagg problem. Now at least I'm not completely alone even if most people can fix the problem with above mentioned fixes.

Well back to old trusted winXP 32bit
My System SpecsSystem Spec
29 Jan 2010   #107
Nipzon

Win7 64-bit
 
 

Well I have gone back to Win XP 32 bit and have the same problem. I believe it is a combination between new hardware and Windows. I have an Asus mobo and the sound is down to stereo only. Win7 is fine with local online servers and lagging with overseas ones. With a combo of Bios updates, Win7 updates(shit load from Microsoft- auto update lol), mobo drivers and nVidia drivers, my problems eased up. I can atleast play my games online now even though it is in stereo.
My System SpecsSystem Spec
29 Jan 2010   #108
qberty

windows 7 64bit ultimate
 
 

i use spotify mostly when i listen to music and i do that a lot when i gaming, so i thought spotify was the problem, i got a program called "net limiter 2 pro" so i could limit the upload of the program, and i think that fixed it for me.
My System SpecsSystem Spec
29 Jan 2010   #109
nightrhyme

windows 7
 
 

Quote   Quote: Originally Posted by Nipzon View Post
Well I have gone back to Win XP 32 bit and have the same problem. I believe it is a combination between new hardware and Windows. I have an Asus mobo and the sound is down to stereo only. Win7 is fine with local online servers and lagging with overseas ones. With a combo of Bios updates, Win7 updates(shit load from Microsoft- auto update lol), mobo drivers and nVidia drivers, my problems eased up. I can atleast play my games online now even though it is in stereo.

Hmm if it's a combination between new hardware and Windows then why do you have the same problem in winxp ?

My hardware works flawlessly in ubuntu, winxp 32 and 64bit.
The problem was introduced in vista 32 and 64bit, win7 32 and 64bit
My System SpecsSystem Spec
30 Jan 2010   #110
raffael

Windows 7 + Windows XP + Linux Mint 8
 
 

Quote:
My hardware works flawlessly in ubuntu, winxp 32 and 64bit.
Same for me. Linux Mint 8 and Windows XP x64 work without any issue.
Until they fix this situation with lagging I'm staying with XP x64.
My System SpecsSystem Spec
Reply

 "lag" in online games with Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Playing Speed Windows "Hearts" and other Card Games
I know this is trivial but it is bothersome. I have 2 PCs running with W7 Home Premium. They are basically identical and all updates are installed. However, on PC2 when playing Windows Hearts, Spider Solitaire and plain Solitaire the movements of cards from playing hands to the board is...
Gaming
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
"HIRED GOONS: Father pays 'assassins' to kill son online"
Hey guys I saw this article and im still laughing my head off lol, have a look. HIRED GOONS: Father pays 'assassins' to kill son in online video game | Online Video Games Reviews & News | News.com.au What do you think of that? -Iroro
Chillout Room
online games are "lagging"
Hi all I play Counter Strike Source, Team Fortress 2 and Battlefield 3 Now this never used to happen before but some reason it does now. I join servers that are under 100 ping (New Zealand or Australian servers) And I can play fine for x amount of minutes (x being random number). but...
Gaming
"dependency chain" "windows 7" internet "windows explorer"
"dependency chain" "windows 7" internet "windows explorer" At the time of this writing, this search in Google will produce one result at best. Am I searching the wrong things? I have tried a couple handfuls of variants, and I am coming up with zilch. Though I am fairly well versed in...
System Security
"Games" Folder? Windows 7 Beta- help me recall
When the Windows 7 Beta had first come out, I downloaded it right away. I installed some games and when I went to play them, I think there was a folder that automatically put my games in to it. ei: When I installed CoH, it was put in to a folder that I would access from the Start Menu. Am I...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App