Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "lag" in online games with Windows 7

19 Dec 2009   #51
Dragoon

WinXP Pro (x86) / Win7 Pro (x64)
 
 

Can you upload a DirectX report? That will give us a detailed report on your hardware setup.
To do this open your Startmenu and type dxdiag into the searchbox.
It will bring up the DirectX Diagnostic Tool.
If you have a 64bit OS click on the button "Run 64-bit DxDiag", otherwise click the "Save All Information" button.
It will generate a report of your system in a file called DxDiag.txt.
Save it where you can find it easily and upload it please here.


My System SpecsSystem Spec
.
19 Dec 2009   #52
kicken

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by Dragoon View Post
Can you upload a DirectX report? That will give us a detailed report on your hardware setup.
To do this open your Startmenu and type dxdiag into the searchbox.
It will bring up the DirectX Diagnostic Tool.
If you have a 64bit OS click on the button "Run 64-bit DxDiag", otherwise click the "Save All Information" button.
It will generate a report of your system in a file called DxDiag.txt.
Save it where you can find it easily and upload it please here.
Done it.


Attached Files
File Type: txt DxDiag.txt (37.4 KB, 125 views)
My System SpecsSystem Spec
19 Dec 2009   #53
cheNga

Windows 7 Ultimate x86
 
 

Quote   Quote: Originally Posted by kicken View Post
So, finally I was forced to register here! Well, let's start off with my problem.

Like many others I've been having constant fps-drops in Counter-Strike 1.6 and from the first beginning it was very bad and by that I mean really bad. My ping was 180+ (when it used to be 14-25 on XP) and I couldn't play CS at all. I then tried the following things.

1. Turned off MMCS completely
2. Turned off MMCS completely and disabled the throttling component
3. Kept MMCS on and disabled the throttling component

All of these three options (not at the same time) resulted in much better ping (the usual 14-25 I had before), but the fps-drops remained, especially when other players were shooting at me and when I climbed through several smokegrenades.

I was glad at first, because the ping was fixed, but I understood pretty quickly that I can't play this way. You can't play when you lag when your enemies are shooting at you. So, I googled, I asked friends and I made threads on several forums but no one could give me an answer. I still find this as the most common and logic way, but it doesn't work fully for me.

So, I've searched hours and finally found this thread:

Windows 7 High Ping Fix

It did make my browser work way much faster, but it didn't help at all in-game.

So, I have a very new & good computer and there's nothing wrong with it. I've been able to play CS on it on XP and it worked very good on XP. I've downloaded and installed all the latest drivers and "cleaned" the computer with programs like CCleaner, but it still isn't working. When I play, I fps-drop to 20-40 fps when my fps should be around 75 like it always been.

I tried to disable my sound device and to my surprise it worked very well. Not 100 %, but almost. By the things you've all wrote in this thread I understood that this fix should be the answer to the problem, but it wasn't. I've also tried this method: http://www.youtube.com/watch?v=XbWQnvytvqk But it doesn't help either.

I've searched the web for hours and I've found a lot of people with the same problem and I've found a lot of people whose problems went away by this fix and I've found a lot of tips and recommendations, but nothing has worked so far. So, if somebody here know what the problem can be, I would be thankful for weeks to come. I'd really appreciate some help, because I feel that this is the only forum that can have the answer to my problems. I hope someone read through this post and can help me.

All the best, Kicken.
Sorry for the qoute (if it bothers you) but i have the same problem. I have an ATI Radeon HD2600 PRO AGP graphic card with Catalyst 9.11 drivers. I have fixed the lag problem but my fps is low -.- I can say that drivers are solid and stable but the fps is... oh man when i mention it i get nervous :@ I will try different drivers in these couple of days because i have some school obligations (lol) if i fix it i'll tell you how. And if someone had fixed it please say how ?!?
My System SpecsSystem Spec
.

19 Dec 2009   #54
Dragoon

WinXP Pro (x86) / Win7 Pro (x64)
 
 

@Kicken You mentioned at an earlier post that turning off your sound device actually help you but not the fixes here correct?

I saw you're using the default drivers for your audio card.
Realtek has released Version 2.39 of its HD Audio drivers. Could you update your driver to rule out any driver issues first.

Edit:

I forgot you should also update your Intel chipset/graphic drivers to the newest ones.
You are still using the default pre-release win7 drivers.
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Chipsets&ProductLine=Laptop+Chipsets&ProductProduct=Mobile+ Intel%C2%AE+4+Series+Express+Chipset+Family&ProdId=2991&LineId=1088&FamilyId=40
My System SpecsSystem Spec
20 Dec 2009   #55
kicken

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by Dragoon View Post
@Kicken You mentioned at an earlier post that turning off your sound device actually help you but not the fixes here correct?

I saw you're using the default drivers for your audio card.
Realtek has released Version 2.39 of its HD Audio drivers. Could you update your driver to rule out any driver issues first.

Edit:

I forgot you should also update your Intel chipset/graphic drivers to the newest ones.
You are still using the default pre-release win7 drivers.
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Chipsets&ProductLine=Laptop+Chipsets&ProductProduct=Mobile+ Intel%C2%AE+4+Series+Express+Chipset+Family&ProdId=2991&LineId=1088&FamilyId=40
I know I mentioned that I could play lag-free when I disabled my sound drivers, but when I recall that incident, I think I just imagined that I played lag-free. I'll try that again though and report if I was right or wrong.

I thought I had the latest drivers, but as you found out, I hadn't. So, I downloaded the drivers and installed them and run the game (with Gamebooster turned on) and I've experienced a minor improvement. When I play without Gamebooster it's really bad, I can't play at all. But when I play with Gamebooster turned on, I can somewhat play and the latest drivers got me a slight improvement as well, but the fps drops are still not gone.

I lag less, that I am sure of. But the fps drops are just irritating and when the fps drops a lot (happens quite a lot) I lag as well. I'm just (very) chocked that nothing has helped this far.

It's still veeeery strange how this computer which is produced 2008/2009 can't handle a game from 1999. I admit that my laptop isn't the best in the world, but it should be capable of running games from '99. It's just ... strange. So, I don't even know if there's any more people who can help me. Maybe I should try enabling the throttling now when I've downloaded the latest drivers?
My System SpecsSystem Spec
20 Dec 2009   #56
rynio

 
 

I don't believe it fixes the problem, i did it
Quote:
network performance throttling, set it to FFFFFFFF hex (willl look like 0xFFFFFFFF to the right of the entry)
and no results. I also read that it was only problem on vista.


I read on microsoft that network throttling performance issue only happens on "high speed networks that are saturated to maximum capacity" its applies to vista don't sure how it works under win7.
My System SpecsSystem Spec
20 Dec 2009   #57
HardTarget

Windows 7 Ultimate 64 Bit
 
 

Quote   Quote: Originally Posted by pinstripe View Post
  • Stop and disable the "Multimedia Class Scheduler" service
  • Run regedit and go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Audiosrv"
  • Double click on the entry "DependOnService" and delete the line with "MMCSS" from the text box
  • Reboot and enjoy lag free games

Quote:
Leave the multimedia class scheduler service running, but disable its network throttling "feature":
  • Open regedit
  • Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile
  • There will be an entry for network performance throttling, default value is 10; set it to FFFFFFFF hex (willl look like 0xFFFFFFFF to the right of the entry)
  • Reboot
Just joined the forum and wanted to say a big thank you to Pinstripe I play COD4 and have had nothing, but lag when ever I play.............no matter what I tried nothing worked..............well that is untill I followed your guide. Now I enjoy lag free games once more.

First I tried the MMCSS and nothing. I then tweaked the network performance throttling and that seems to have fix my problem. COD4 runs ultra smooth now!

[img=http://img684.imageshack.us/img684/4867/shot0000z.jpg]
My System SpecsSystem Spec
21 Dec 2009   #58
kicken

Windows 7 Ultimate
 
 

So, pinstripe, Dragoon and all the others who helped me: I tried to enable the network throttling feature, because I've had it disabled all the time. To my big surprise it helped and it helped a lot. The fps drops were blown away and I wasn't lagging at all. It was like it should be. No fps drops at all and no lag at all - I thought.

The thing is that the ping now goes up tp 130-140 at totally random times during the game. It can happen whenever, wherever and however. This of course makes me lag and it gets really frustrating at times, because otherwise it is really good without any fps drops and lag. But now the ping is the real problem.

So, disabling the throttling service results in constant fps drops and lag, but enabling the throttling service results in intermittent high ping. I don't know which one is best, but all I want is to solve is this f*cking problem. Now I can't have it disabled or enabled, because no option helps. And this while I've been running MMCS all the time. Because if I disable/remove MMCS, I can't even start Steam and run the game.

So, does this sound strange to you? What should I do know?
My System SpecsSystem Spec
22 Dec 2009   #59
pinstripe

Windows 7 x64 Professional
 
 

So what happens when you disable your sound device entirely in device manager?
My System SpecsSystem Spec
22 Dec 2009   #60
kicken

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by pinstripe View Post
So what happens when you disable your sound device entirely in device manager?
Still lagging.
My System SpecsSystem Spec
Reply

 "lag" in online games with Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Online "Windows Live" vs. desktop "Windows Live Mail"
I use "Windows Live Mail" as my email client on Windows 7 Home Premium 64-bit. Ever since I got Windows 7 and WLM, WLM was configured to automatically sign in to "Windows Live" whenever it opened. Now it is many years later, and I would like to 'divorce' my WLM from online "Windows Live" because a)...
Browsers & Mail
DISM error 87 "DISM /online ""command not recognized""
Hey, So im trying to clean up my PC, FRESH install w/current updates followed @BRINK guide to DISM and keep getting this error
Performance & Maintenance
Playing Speed Windows "Hearts" and other Card Games
I know this is trivial but it is bothersome. I have 2 PCs running with W7 Home Premium. They are basically identical and all updates are installed. However, on PC2 when playing Windows Hearts, Spider Solitaire and plain Solitaire the movements of cards from playing hands to the board is...
Gaming
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
online games are "lagging"
Hi all I play Counter Strike Source, Team Fortress 2 and Battlefield 3 Now this never used to happen before but some reason it does now. I join servers that are under 100 ping (New Zealand or Australian servers) And I can play fine for x amount of minutes (x being random number). but...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App