Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "lag" in online games with Windows 7

22 Dec 2009   #61
denox

Windows 7 Home Premium
 
 

I had same problem with you guys before and none of the tricks above work for me.
I moved back to wired connection and all problem are gone.
I guess that is the only option for me now.


My System SpecsSystem Spec
.
22 Dec 2009   #62
pinstripe

Windows 7 x64 Professional
 
 

Quote   Quote: Originally Posted by kicken View Post
Quote   Quote: Originally Posted by pinstripe View Post
So what happens when you disable your sound device entirely in device manager?
Still lagging.
Is that network latency or framerate drop? Honestly, your CPU may simply be too weak.
My System SpecsSystem Spec
22 Dec 2009   #63
kicken

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by pinstripe View Post
Quote   Quote: Originally Posted by kicken View Post
Quote   Quote: Originally Posted by pinstripe View Post
So what happens when you disable your sound device entirely in device manager?
Still lagging.
Is that network latency or framerate drop? Honestly, your CPU may simply be too weak.
Don't know the terms, so I don't acutally know what kind of lag it is. Well, I've run CS without any problems on this same computer with XP, so I really don't think it's the CPU as long as W7 doesn't take up all the CPU
My System SpecsSystem Spec
.

23 Dec 2009   #64
pinstripe

Windows 7 x64 Professional
 
 

I mean, with Windows 7 your CPU may be too weak. Are we talking about 1.6 or Source? My old laptop with a celeron (slightly slower than yours) had a hard time running even 1.6 on an XP machine.
My System SpecsSystem Spec
24 Dec 2009   #65
gunners

Windows 7 Pro x64
 
 

Thought I might wade in here as well...

I seem to be getting random lag spikes in CSS, despite having tried the fix earlier in this thread. The game loads fine, I get good frame rates (about 180fps), have no loss and minimal choke (usually 0-2). Ping is about 50 on most servers I play on.

What is seriously annoying is that after playing for a couple of minutes, I get a wierd lag where I seem to be stuck for half a second, then warp forwards - also, after warping I get redistributed my guns and equipment (looks like I just picked them up). Seems like the game is dropping out briefly? The display from net_graph shows no particular spike in choke when this happens.

I've tried updating drivers - all are fresh as a daisy. Still no luck. Also, disabling the sound drivers makes no difference, I still get this problem. I have spent quite a few frustrating hours trying to rectify, but no luck! Any help would be mucho appreciated...
My System SpecsSystem Spec
25 Dec 2009   #66
raffael

Windows 7 + Windows XP + Linux Mint 8
 
 

This problem is really annoying.

I have 2 PCs. One with Windows XP and second with Windows 7 x64 Pro. Few days ago I had Windows XP on both and everything was fine. Now I can't even play GTA2 on LAN (one PC through WiFi, one PC through cable) normally because of the lags. I've tried everything. Disabling the MMCSS, disabling sound devices (no influence), adding TcpAckFrequency like described here WoWAcker Main , disabling autotuning (netsh int tcp set global autotuninglevel=disable) and still nothing.

Ping is between 70 and 100+ (sometimes even 150). On Windows XP it was 30 maximum. And that's even before the game, in the network game manager. I think during the game it gets even worse because I get some serious game hang-ups which are obviously network based. If anyone else know different method please inform me. If I won't find any solution I going back to Windows XP.

I'm using ATI Catalyst 9.12 & Realtek HD 2.39 drivers.

EDIT:

New thread started at Lags in games on Windows 7 x64 pro.
My System SpecsSystem Spec
26 Dec 2009   #67
pinstripe

Windows 7 x64 Professional
 
 

if you disable your sound device and the problem persists, you are experiencing another issue and this fix will not work for you. i would suggest starting a new thread specific to your problem for the best results, this is not really a general lag thread.
My System SpecsSystem Spec
26 Dec 2009   #68
Ozirus

Windows 7 Home Premium 64-bit
 
 

I get alot of LAG when I play, "Left 4 Dead" and "Left 4 Dead 2".

I get a high ping on single player ~ 55 ms and alot of slow motion.

I installed Windows 7 Home Premium 64-bit three days ago.

They both worked fine on Vista Home Premium 32-bit.

I guess I'm new at the whole 64-bit thing!
My System SpecsSystem Spec
27 Dec 2009   #69
qberty

windows 7 64bit ultimate
 
 

i registered just to help those who still have problems and dont wanna turn of MMCSS.

at The Bits 2.0 Disabling/Tweaking Vista’s Multimedia Class Scheduler that the thread makers linked to says "Double click on NetworkThrottlingIndex. To disable completely, enter FFFFFF with base hexadecimal." Thats 6 "F" not 8.


so it should say: 0x00ffffff


that worked for me!
My System SpecsSystem Spec
27 Dec 2009   #70
Ozirus

Windows 7 Home Premium 64-bit
 
 

Cool. I just tried that. What was the default value? I entered the 8 Fs yesterday, and can't remember seeing anything but the letter "a" before I changed it.
My System SpecsSystem Spec
Reply

 "lag" in online games with Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Playing Speed Windows "Hearts" and other Card Games
I know this is trivial but it is bothersome. I have 2 PCs running with W7 Home Premium. They are basically identical and all updates are installed. However, on PC2 when playing Windows Hearts, Spider Solitaire and plain Solitaire the movements of cards from playing hands to the board is...
Gaming
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
"HIRED GOONS: Father pays 'assassins' to kill son online"
Hey guys I saw this article and im still laughing my head off lol, have a look. HIRED GOONS: Father pays 'assassins' to kill son in online video game | Online Video Games Reviews & News | News.com.au What do you think of that? -Iroro
Chillout Room
online games are "lagging"
Hi all I play Counter Strike Source, Team Fortress 2 and Battlefield 3 Now this never used to happen before but some reason it does now. I join servers that are under 100 ping (New Zealand or Australian servers) And I can play fine for x amount of minutes (x being random number). but...
Gaming
"dependency chain" "windows 7" internet "windows explorer"
"dependency chain" "windows 7" internet "windows explorer" At the time of this writing, this search in Google will produce one result at best. Am I searching the wrong things? I have tried a couple handfuls of variants, and I am coming up with zilch. Though I am fairly well versed in...
System Security
"Games" Folder? Windows 7 Beta- help me recall
When the Windows 7 Beta had first come out, I downloaded it right away. I installed some games and when I went to play them, I think there was a folder that automatically put my games in to it. ei: When I installed CoH, it was put in to a folder that I would access from the Start Menu. Am I...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App