Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bioshock fails to launch.

09 Mar 2010   #11

Windows 7 x64

Won't run in W7 anymore. Did fine after W7 install (day after retail release), all MS updates since then done. I don't have the reg entry noted above so that's not it. What happens is just about nothing. No screen presence. Process bioshock.exe shows up at about 33,000k for maybe 15 seconds then disappears. Nothing else happens at all. Bioshock 2 runs fine as does every other game I have. None have to be run in compatible mode. Bioshock won't though; it kicks back with a message about turn off compatibility mode first. I'm stumped. Reinstall changes nothing.
W7 Pro x64, EVGA 780i, 8 MB, 2x 8800GT (tried SLI, changes nothing), 2 TB Disk space

My System SpecsSystem Spec
09 Mar 2010   #12

Windows 10 Pro

Try updating your DirectX Files.

Try the web installer first - Download details: DirectX End-User Runtime. if you have issues getting it to update, then download the entire 104MB file here Download details: DirectX Redist (February 2010)

Contrary to popular belief even though Windows 7 is DX11 capable, you STILL need to update the DX9 files. And Microsoft continues to update all the DX files so updates are still in order.

Good luck.
My System SpecsSystem Spec
09 Mar 2010   #13

Windows 7 x64

Didn't do any good. Guess I'll have to try a VM. Thanks anyway.
My System SpecsSystem Spec


 Bioshock fails to launch.

Thread Tools

Similar help and support threads
Thread Forum
Windows Fails to start, Start up repair does not launch.
I have been trying to pinpoint this problem for a little shy of a week now. I have a custom built desktop which was running windows 7 Ultimate when it started to have troubles shutting down and booting up. It would fail to shut down and the windows start up would either get stuck for awhile(on the...
BSOD Help and Support
BioShock 2
can anyone give me there views on this game please? :D
Bioshock and GEF
For some reason, my bioshock icon is blank in the GEF. I checked and it also is in the main directory for some reason. How can I go about changing this. I don't need it to appear in the main directory but really need it to show in GEF. I've tried adding "BoxArt" string to regedit and typing...
For some reason, I cant seem to hear any sound during game play of Bioshock, but the weird thing is, during cut scene movies, there is sound. Anyone experience this problem before?
Launch Manager (Quick Launch Buttons)
I now have these quick launch buttons working but I was wondering how can I change the defaut programns they open. e.g. The email button opens Outlook but I want it to open Windows Live Mail. REP will be given.
Hardware & Devices
BioShock Problem
every time i run bioshock i get not responding here is the error report Faulting application name: Bioshock.exe, version:, time stamp: 0x00000000 Faulting module name: Bioshock.exe, version:, time stamp: 0x00000000 Exception code: 0xc0000005 Fault offset: 0x012d6e60 Faulting...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App