Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Star Wars Empire at War Forces of Corruption

16 Feb 2010   #11

win 7 64 bit

Thx omegazero55
u are the best
u made my day

My System SpecsSystem Spec
08 Mar 2010   #12

Windows 7 32bit Enterprise
Multiplayer Lan

I got the game working great, however I'm trying to play multiplayer on a LAN, I can get an XP and Vista users to show up in the lobby but not the Windows 7 machine. Would you know what could cause this. Empire at War works fine, so not sure why the FOC won't work.
My System SpecsSystem Spec
03 May 2010   #13

windows 7

Ya i also downloaded that patch that omegazero55 posted. the game for me would now show the Lucas arts logo and the other game logo, but then soon after while it says loading on the bottom right side of the screen the game crashes to desktop. no error messages. i have the same problem with the regular star wars empire at war game. That patch only made the game crash after the opening game logos. and ideas?
My System SpecsSystem Spec

03 May 2010   #14

windows 7

it still doesnt work for me. neither of the games do.
My System SpecsSystem Spec
19 Aug 2010   #15

Windows 7 32bit

I've downloaded that unofficial patching thing and now i can get FOC to run, but no matter what i cannot get the game to build anything. in the campaign nothing appears int he build queue. tried a skermish and the ships show but r grayed out and not clickable. running 32bit win 7. without that patch game wont even start up, screen just goes black. havent tried the first one yet.
My System SpecsSystem Spec
05 Sep 2010   #16

Windows 7 Home Premium 64bit

hey. sorry to revive an old topic..but i have the exact same problem that ScourgeDL had. I downloaded the patch and everything but when i try to overwrite the old file, it says i don't have permission. is there a way to work around this?
I recently upgraded my comp and i'm dying to play foc on it but it refuses to load. please help!
My System SpecsSystem Spec
09 Sep 2010   #17

Windows 7 Home Premium 64 bit

Hey guys, if you're still having issues get FOC to launch, go to Lucasart's web site here:[/url Scroll to the bottom and get their official RAM fix patch. Worked like a charm for me!
My System SpecsSystem Spec
16 Sep 2010   #18

Windows 7 Pro 64 Bit

Thank you Thrawn, great link. Worked perfectly for me.

Just be sure to install the 1.1 patch first.
My System SpecsSystem Spec
16 Oct 2010   #19

Windows 7 Professional 32-bit operating system

yah I know this is an old thread but if anyone can help me, I can't seem to get FoC to work at all. here is the error message I get when I attemp to launch the application:
"An exception has occured. See _logfile.txt and _except.txt for details. Press CANCEL to exit or RETRY to debug"

- RETRY just closes the program.

this is my system:
Windows 7 Professional
Processor: Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz 2.67GHz
Installed memory (RAM): 4.00 GB (3.25 GB usable)
System type: 32-bit Operating System

this appears to be a registry problem but if there is a way to fix it, please let me know.
My System SpecsSystem Spec
01 Nov 2010   #20

windows 7 home 64bit

thank you so much! i been trying to find fix for 3 days ><
My System SpecsSystem Spec

 Star Wars Empire at War Forces of Corruption

Thread Tools

Similar help and support threads
Thread Forum
Star Wars Forces of Corruption Problem With Multiplayer
I have a new laptop with windows 7 / 64 bit and 6 GB of RAM. I installed Star War Empire at War and it works fine. I installed Forces of Corruption and the RAM patch. Single player works fine but the game always locks up when I try multiplayer on the internet. The game works fine on my old...
Star Wars Shadows of the Empire
I know this is a stretch but I may as well ask. Does anyone know how to get Star Wars: Shadows of the Empire working properly on Windows 7 64-bit or 32-bit with a modern video card? Whenever I try to launch it no matter what settings, I try the Hoth Level and I can only see the ground, nothing else.
Star wars empire at war;forces of corruption issue
Me and my friend have modded our games. and i have vista and the mod works fine. but he has Windows 7 and when he starts the mod it says it cant find the file path C:\Program Files\LucasArts\Star Wars Empire at War Forces of Corruption\swfoc.exe it says please check the file pth and try...
Star Wars Empire at War Crashes
I have Star Wars Empire at War on Star Wars Best of PC. Once I start it up, then go to multiplayer and sign in--it freezes. Then I have to start the Task Manager and end process. The actual single player works fine, but I can't get multiplayer to work? Is there a patch of somekind? Please help,...
Star wars forces of corruption won't work!
I've tried every single solution posted and none of them have worked like the patch from I can't seem to figure it out.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:15.
Twitter Facebook