Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Star Wars Empire at War Forces of Corruption

01 Feb 2011   #21
Bean Delphiki

Windows 7 Professional 64 bit
 
 

Ok, I have Windows 7 professional 64-bit. I have tried all of the above methods and in each one I have been stopped by some error message or other. Please help!! I love FoC and I really want this to work on my new computer.


My System SpecsSystem Spec
.
01 Feb 2011   #22
Bean Delphiki

Windows 7 Professional 64 bit
 
 

Addendum: I posted earlier that with all the above fixes, i could not get it to work. I went on a different site, and then tried the VISTA patch instead of the Windows 7 patch and now it works...

link to vista patch: LucasArts.com | Star Wars: Empire at War Forces of Corruption

not sure why this worked. I have a windows 7 64 bit professional, so.... whatever. im just happy it works. enjoy!
My System SpecsSystem Spec
20 May 2011   #23
PragmaR

Windows 7
 
 
Getting FoC multiplayer to work on Windows 7

I really appreciate you providing the solution guys, but I've one question about it: If you download the patch, does that mean you can no longer play with people that don't have the patch? For instance, if I was using Vista or Windows 7 (with the patch) and a friend was using an older OS, could they still connect and play with me? I have gotten the patch to work for single player on my Windows 7 operating system thanks to you guys. Just trying to get this thing to work. We're attempting to connect via LAN btw. Thanks a million.
My System SpecsSystem Spec
.

11 Jun 2011   #24
Il Schvetto Gra

windows 7
 
 

just wanted to notify you guys of my utter appreciation for putting up those links, i have been dying to play the game again so u guys really made ma day
My System SpecsSystem Spec
21 Jun 2011   #25
colgraves

windows 7 home premium 64bit
 
 
problem with patch

I tried using the patch but when i go to download the patch it asks to put in command and conquer generals zero hour disc in. then it just dose nothing. dose anyone know whats going on?
My System SpecsSystem Spec
27 Jun 2011   #26
justlemmepost

Windows 7 64 bit
 
 

I had this original problem, so i downloaded the unofficial Vista patch and now im getting a different error. Instead of the black screen, it has the EAW logo(dont know why) then it minimizes and a white box pops up saying that it has stopped running. I'm running Windows 7 64bit, anyone know why this isnt working?
My System SpecsSystem Spec
03 Jul 2012   #27
tlkoss

Windows 7 Home Premium x64
 
 

Guys I've had the same problems as everyone else after installing the official RAM FIX patch. After installing the patch, right click the launcher then click troubleshoot compatiblily. when you get to that windows select windows vista service pack 2. I had this version and it works. I launched FOC and got into the game.
My System SpecsSystem Spec
03 Jul 2012   #28
tlkoss

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by justlemmepost View Post
I had this original problem, so i downloaded the unofficial Vista patch and now im getting a different error. Instead of the black screen, it has the EAW logo(dont know why) then it minimizes and a white box pops up saying that it has stopped running. I'm running Windows 7 64bit, anyone know why this isnt working?
Try this I got the same message after installing patch too. Guys I've had the same problems as everyone else after installing the official RAM FIX patch. After installing the patch, right click the launcher then click troubleshoot compatiblily. when you get to that windows select windows vista service pack 2. I had this version and it works. I launched FOC and got into the game.
My System SpecsSystem Spec
05 Nov 2012   #29
Johnythe

Windows 7
 
 
Ermmm... Help

Okay, so I bought Star Wars: Empire at War Forces of Corruption, it worked fine on XP (Bugged with some mods) But now I have a Windows 7, and when I try to install it says ''Feuture Transfer Error''

Feuture: IS_STRING_NOT_DEFINED
Component: UnCabbedAppComponent
File: D:\swfoc.exe
Error: Data Error (Cyclic Redundancy Check)

Help please!
My System SpecsSystem Spec
05 Nov 2012   #30
Richardc269

Windows 7 Ultimate 32-Bit
 
 

Sounds corrupted.
My System SpecsSystem Spec
Reply

 Star Wars Empire at War Forces of Corruption




Thread Tools




Similar help and support threads
Thread Forum
Star Wars Forces of Corruption Problem With Multiplayer
I have a new laptop with windows 7 / 64 bit and 6 GB of RAM. I installed Star War Empire at War and it works fine. I installed Forces of Corruption and the RAM patch. Single player works fine but the game always locks up when I try multiplayer on the internet. The game works fine on my old...
Gaming
Star Wars Empire At War Crash
So, I have a problem that I have now been scouring the internet for, trying to solve. Both my copies of Star Wars Empire at War, and the expansion Forces of Corruption continuously crash at the loading screen for the main menu. Now, before I am told to download the patch, I have tried running the...
Gaming
Star Wars Shadows of the Empire
I know this is a stretch but I may as well ask. Does anyone know how to get Star Wars: Shadows of the Empire working properly on Windows 7 64-bit or 32-bit with a modern video card? Whenever I try to launch it no matter what settings, I try the Hoth Level and I can only see the ground, nothing else.
Gaming
Star wars empire at war;forces of corruption issue
Me and my friend have modded our games. and i have vista and the mod works fine. but he has Windows 7 and when he starts the mod it says it cant find the file path C:\Program Files\LucasArts\Star Wars Empire at War Forces of Corruption\swfoc.exe it says please check the file pth and try...
Gaming
Star Wars Empire at War Crashes
I have Star Wars Empire at War on Star Wars Best of PC. Once I start it up, then go to multiplayer and sign in--it freezes. Then I have to start the Task Manager and end process. The actual single player works fine, but I can't get multiplayer to work? Is there a patch of somekind? Please help,...
Gaming
Star wars forces of corruption won't work!
I've tried every single solution posted and none of them have worked like the patch from mike.nl. I can't seem to figure it out.
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App