All games cutscenes and intros are black no video


  1. Posts : 6
    Windows 7
       #1

    All games cutscenes and intros are black no video


    I just bought a used dell 3330 lattitude windows 7.... The guy I bought it from did a fresh install of Windows 7... But he forgot some things.. For example the network drivers. I am not a tech person so I'm not sure what else could be missing... Anyways anytime I go to play ANY game no matter what it is... The intro movie and cut scenes are black... I have no idea How to fix this. Ant help as is appreciated. Thank you
      My Computer


  2. Posts : 1,962
    Windows 7 x64 (Ultimate)
       #2

    go to dell and download all new drivers for chipset, network, video & audio from their website
      My Computer


  3. Posts : 8
    Windows 7 Professional 64bit
       #3

    I'd go with what AstaLavista Said, but i'll add something more.

    1) Press Start and right click the "My Computer"
    2) Click on "Manage"
    3) Click on Device Manager
    4) You'll see a list and If there are question marks on the list take note of them they are the ones who needs drivers to be installed
    5) go to Dell and select the model code of your unit.
    6) download drivers(but be sure to check if you are running 32bit or 64bit systems, to know this, check the installation CD or right click My computer, select properties and check system line, there under system type you'll see if it is 32 bit or 64)
    7) Install drivers accordingly. Always check device manager if there would be missing drivers which would be noted with a question marc
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:27.
Find Us