Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires II: The Conqueror's will not run

22 Nov 2009   #1

Windows 7 Professional
Age of Empires II: The Conqueror's will not run

This is making me want to pull my hair out. Why does the Windows 7 compatibility center list this program as compatible with Windows 7 when it CLEARLY does not work with Win7 without serious effort? Then, Microsoft doesn't even post workarounds for how to make it work with Windows 7! I know this game is really really old but it is a Microsoft game so they should put some effort into keeping it alive, particularly since it is better than AOE III. I digress. To the point of this post.

I have successfully installed AOEII: Age of Kings and the expansion (conqueror's) and updated to patch 1.0C or whatever it is called. When I go to run conqueror's the splash screen comes up saying that it is loading, I hear the CD spin, and then 3-4 seconds later the CD spins down and the splash screen just hangs there for eternity. The game never runs. I've tried running in Windows XP SP2 compatibility mode and as an administrator. Neither resolves. Please help. I want to run this game badly.

Thank you.

My System SpecsSystem Spec
22 Nov 2009   #2

Windows 7 Ultimate x86

I actually had the same problem with another one my games. You can try using a no-CD crack, as that fixed my problem.
My System SpecsSystem Spec
22 Nov 2009   #3

Windows 7 Professional x64

Microsoft no longer supports AoE2 (which makes me cry) and so dont expect any patches to make it work better...however, I have no issues at all with the game apart from the colours going odd which i solve by disabling the explorer.exe process before I play.

Sounds odd, but have you tried to install the game under no compatibility settings at all, and no patch and then tried it first? That worked for me fine. If this doesnt work for you just come back and post and ill look more into it.
My System SpecsSystem Spec

23 Nov 2009   #4

Windows 7 Professional

I should report back that after the splash screen just sitting there FOREVER doing nothing a EULA agreement screen eventually popped up and the game did eventually run. So thanks everyone for your help but I do think it is working. Will see if the success if reproducible tonight.
My System SpecsSystem Spec
24 Nov 2009   #5

Windows 7 Home Premium x64

AOE2 might be having problems with your monitor's resolution.

You might try running AOE2 in windowed mode using a modified dll if you have further issues.

Check out posts 27, 28 and 29 here: Age of Empires 2: AoC expansion
My System SpecsSystem Spec
08 May 2012   #6


Try using compatabilty mode in Windows7

1. Right-click the shortcut you use to launch AOE2. Go to "compatabilty" tab and select "Run this program in compatablity mode for": and select "Windows 98 / Me". It also worked in "Windows XP SP3" but the colours were not quite correct in-game. So I would suggest the Win98 selection.

part b) When creating a LAN game. I get the XP machine to create the game (LAN option), other XP machines connect via the LAN option too. BUT windows7 does not find the game under the LAN option, instead using the Direct TCP connection, and enter the IP address of the hosting machine.
The game is then shown using Find Games, I connect and goes smoothly then after.

2. A second solution is to install "VirtualBox", which is free and supports DirectDraw. Virtual PC does not support this. For a first time use, I needed to add my wireless network adapter in the the list of adapters. This did all work, but was a bit sluggish when trying to play.
My System SpecsSystem Spec
09 May 2012   #7

Windows 8 64-bit (6.2, Build 9200) (9200.win8_rtm.120725-1247)

I installed using the Age of Empires that I got at Wal*Mart, it had Gold, II and it's expansion. I was able to install and play it with no problems on my computer, which is Windows 7 Home Premium 64 bit edition.
My System SpecsSystem Spec

 Age of Empires II: The Conqueror's will not run

Thread Tools

Similar help and support threads
Thread Forum
Age of Empires II: The Conqueror
Hi I am wanting to play Age of Empires II: The Conqueror over lan with 4 computers. 2 vista and 2 win7. I have been playing Age of Empires II: The Conqueror online with Voobly but I want to play over LAN. Hope someone can help :cool:
Age of Empires 3 not working
Hello, I recantly upgraded my computer from windows XP (service pack 3) to windows 7 (32 bit). On windows XP I had age of empires 3 installed which was running perfectly (My computer is more than good enough to use windows 7 by the way). Age of Empires 3 installed correctly but when I try...
Age of empires
Can some please tell me if age of empires, will play using windows 7? Thanks, Sarah.
Age of Empires II
Hi, I have a problem with Windows 7. I can play Age of Empires II, because the whole picture is green! The video is up to date,knows someone who is wrong? Thx
Age of Empires III! [ALL]
Hello, sorry. I have searched around the forum and I've found out that Age of Empires III does work on Windows 7 BUT I'm too newbie to understand. Can someone please tell me how to make it work? Actually, I'm just having some small issues rather than those extreme ones like whenever I play the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:43.
Twitter Facebook Google+