Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't get Origin game client to launch

12 Apr 2018   #1

Win 7 Home Premium x64
Can't get Origin game client to launch

I'm trying to figure something out. I try to launch Origin to play games and nothing, and I do mean nothing, happens. I even monitored the launch using Process Lasso Pro and there is no indication anywhere that anything even happens. I have tried the following:
1) Clean install using a freshly downloaded installer.
2) Clean install to another physical drive.
3) Manually deleted the OriginThinClient.exe in the Origin folder.
4) Put the shortcut to run as admin.
5) Went into the Origin folder and told both Origin.exe and OriginWebHelper.exe (testing each individually as I went) to run as admin.
6) Put the shortcut, Origin.exe, and OriginWebHelper.exe in compatibility mode for Win XP, again with individual testing for each one.
7) Went in and first disabled antivirus, anti-malware, and firewall, testing each one.
8) Added exceptions to all three listed in Step 7, testing each one.
9) Uninstalled all C++ redists using Revo Uninstaller Pro and reinstalled them (they come with the Origin installer).
10) Tried launching the client from the shortcut, start menu, and also by going into the Origin folder and directly clicking on Origin.exe and get nowhere.

Other than disabling the in-game overlay (which I can't get to cuz nothing is happening when I try to launch Origin) I can't find any other suggestions on what to do. What truly annoys me is that I have played games through Origin many times in the past on this same machine and haven't had any problems... well, occasionally I would have this same problem but reinstalling Origin always worked for me in the past. I'm lost, any other suggestions? It seems that something, somewhere simply will not allow the client to even launch, much less terminate it from running but I don't know what.

Edit: I just checked the Event Viewer and it says the following:

Event 1001

Fault bucket , type 0
Event Name: PCA2
Response: Not available
Cab ID: 0

Problem signature:
P1: Origin.exe
P2: 10..5.16.49299
P3: Origin
P4: Origin
P5: Electronic Arts
P6: 200
P7: -1

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 144f6033-3e12-11e8-ae97-dc85de3ce977
Report Status: 0

I found very similar entries for OriginWebHelper.exe as well. What the hell does "Not available" mean, anyway!? I know the program is on my machine, I've been messing with it for the last 3 hours.

My System SpecsSystem Spec

 Can't get Origin game client to launch

Thread Tools

Similar help and support threads
Thread Forum
BSOD since installing Battlefield 4/Origin (not always in-game!)
Greetings fellow inhabitants of the sevenforums! Since installing BF4 and Origin I have been getting frequent BSOD. Initially I didn't get BSOD, only crashes of the game. After a few patches however the BSOD appeared, often it happens the first time I try to start the game and after that I have...
BSOD Help and Support
blury text inside in-game Origin+steam app and also in everything
blury text inside in-game Origin+steam app and also in everything I am getting blurry vision in in-game Origin app and Steam app on WIn 7 64-bit why blurry ?? please help _sorry for noob language but i have no option i also update my AMD HD 7950 drivers to WHQL and beta too but still...
General Discussion
Free Game (BAttlefield 1942) -- Origin on November 15th!
If you logon to origin and look the opup, it has battefield 1942 for free!!! just hit add to library and get full version!
Trying to play a game - Flash.ocx is missing - Game wont launch
The title pretty much sums everything up. I downloaded a game called R.O.D.E Online, its a free mmorpg I installed the game, everything went well. When I tried to launch the game nothing happens, after clicking on the launcher a few times I get an error message that says this: Program...
BSOD after purchasing game on Origin
Windows 7 Enterprise -32bit -age of system: About 3 and a half month old -age of OS: About 3 and a half months old (never reinstalled) So I've just purchased NFS Hot Pursuit(the new one) from the Origin client. Right after the purchase I get these weird lines appear on screen(small maybe a...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:39.
Twitter Facebook