Epic Games "api-ms-win-downlevel-kernel32-l1-1-0.dll" is missing error

Page 2 of 2 FirstFirst 12

  1. Posts : 19
    Windows 7 Pro 64bit;Windows 10,Ubuntu
    Thread Starter
       #11

    Thx I'll try when I get home
      My Computer


  2. Posts : 19
    Windows 7 Pro 64bit;Windows 10,Ubuntu
    Thread Starter
       #12

    I can't believe it works . Grazie Thank you .

    At first I thought you misread my post as you were quoting a slightly different file

    The one in my error message was "api-ms-win-downlevel-kernel32-l1-1-0.dll" while yours was "api-ms-win-downlevel-kernel32-l2-1-0.dll"

    Copied "my file" from your /Windows/System32/CompatTel
    to C:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win64
    then changed "Api" to lowercase "a" and rebooted ...no difference at all

    Copied "yours" from the same folder to the Epic one changing it to all lowercase.
    Restarted and voilą no more error.
      My Computer


  3. Posts : 1
    Windows 7 Ultimate 64 bit
       #13

    My first post here, new member.

    Anyway i have the same problem, but here is what i think is the problem. See screenshot below. NOTE: As soon as i type "3" the file is not available, not seen by the search engine. If you copy/move the file, the full path to the file is seen by the OS.
    Attached Thumbnails Attached Thumbnails Epic Games "api-ms-win-downlevel-kernel32-l1-1-0.dll" is missing error-capture.png  
    Last edited by delshay; 17 Jan 2021 at 07:44.
      My Computer


  4. Posts : 1
    Windows 7 Pro X64
       #14

    Fix that worked for me


    I have gotten the same error in the past few days, and reinstalling the client hasn't helped.

    Win7 Pro x64 Here.

    I do not have a CompatTel subdir under System32, however this may be because I'm selective about updates and removed many telemetry related ones, if those are what creates this..

    For me, api-ms-win-downlevel-kernel32-l2-1-0.dll was entirely missing from my system. I downloaded this using the site I use often and trust for dlls, api-ms-win-downlevel-kernel32-l2-1-0.dll free download | DLL‑files.com and tried placing this in the Win64 subdir of the Epic progfiles folder and I still got the error. Only when copying this to System32 like with most dlls erroring as missing did it resolve this for me.

    I don't know if this being different for me has to do with those telemetry updates I prevented or removed or something else, but Epic Games Store specifically just started producing this error at launch just in the last few days like many of you, and so far this has remained resolved after placing the dll here.

    I hope this helps someone that wasn't able to resolve this thus far and also had missing the CompatTel subdir too.
      My Computer


  5. Posts : 1
    win7
       #15

    This works for me, Thanks.




    Enable GingerCannot connect to Ginger Check your internet connection
    or reload the browserDisable in this text fieldRephraseRephrase current sentenceEdit in Ginger×
      My Computer


  6. Posts : 29
    Windows 7 Ultimate x64 SP1
       #16

    I have just got this same error in a different program that I installed yesterday and this thread came up in a search. I did also get the same error much earlier with the Epic client but they did fix that with an update.
    I used a similar idea to what is detailed here ie "copying" the dll to the installed program directory and that eliminated the problem. I am using Win 7 as well BTW because that seems to be the common connection between all the reports that I have read.

    I quoted "copying" because I did not actually copy the dll, I made a hardlink in the program install folder which did what was necessary. I have "Link Shell Extension" by Hermann Schinagl installed for a long time and never really used it until now. It worked quite well. That appears in file properties where it shows any links and their location and can be used to create links on the right click menu. See the instructions on his site for details on how to use it.
    Link Shell Extension
      My Computer


 
Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 20:51.
Find Us