Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ghostbusters Performance

30 Dec 2009   #1
jim84

Windows 7 Home Premium 64-bit
 
 
Ghostbusters Performance

Anyone here played Ghostbusters on Win 7?

I have serious performance issues with it, even if I turn the settings way down. I don't have the best gaming PC, but I can handle Batman, Crysis, Source etc on high settings fine.

From what I've been reading, a lot of people seem to have problems with Ghostbusters. It looks like it would probably be a good game, but it just doesn't work well.

When I first started it up, it played smooth, and looked good.... And then it bogged down and remained like a slug until I tried to close it where it then had some error.

Computability settings? Maybe I'll give them a try.

Edit:
So looking around where people suggest things to fix it, because so many people have problems with this game (I emailed Atari and told them I want them to replace my PC version that is unplayable with a Xbox copy, like that will happen), one suggestion I found seemed odd. It was to make the game run in low priority mode. This doesn't make sense how it could help to me, but others reported it did, so I gave it a shot. It gave me the longest time with the game being playable (actually playing really well on high settings), before completely bogging down. Probably 15 minutes it was good for. Then I went to about 1 frame every 20 or 30 seconds. It was at this point that I gave up again. Hopefully there is a way to make it work, or Atari gives me my exchange, but I don't see either happening.


My System SpecsSystem Spec
.
31 Dec 2009   #2
Coolness

Win 7 pro 64-bit, Ubuntu 9.10 64-bit
 
 

Quote   Quote: Originally Posted by jim84 View Post
Anyone here played Ghostbusters on Win 7?

I have serious performance issues with it, even if I turn the settings way down. I don't have the best gaming PC, but I can handle Batman, Crysis, Source etc on high settings fine.

From what I've been reading, a lot of people seem to have problems with Ghostbusters. It looks like it would probably be a good game, but it just doesn't work well.

When I first started it up, it played smooth, and looked good.... And then it bogged down and remained like a slug until I tried to close it where it then had some error.

Computability settings? Maybe I'll give them a try.

Edit:
So looking around where people suggest things to fix it, because so many people have problems with this game (I emailed Atari and told them I want them to replace my PC version that is unplayable with a Xbox copy, like that will happen), one suggestion I found seemed odd. It was to make the game run in low priority mode. This doesn't make sense how it could help to me, but others reported it did, so I gave it a shot. It gave me the longest time with the game being playable (actually playing really well on high settings), before completely bogging down. Probably 15 minutes it was good for. Then I went to about 1 frame every 20 or 30 seconds. It was at this point that I gave up again. Hopefully there is a way to make it work, or Atari gives me my exchange, but I don't see either happening.
Have you tried the "run as admin" and compatibility modes? Also, did this just suddenly happen or did you do something that made it happen?
And, youre right, the cake is a lie! :O
My System SpecsSystem Spec
31 Dec 2009   #3
AngelProcesser

 

"It looks like it would probably be a good game, but it just doesn't work well."

I do believe that to be an accurate statement - but...it should be directed at the game developers.
My System SpecsSystem Spec
.

31 Dec 2009   #4
jim84

Windows 7 Home Premium 64-bit
 
 

@Coolness, I just got the game on the Steam Holiday Sale, so it hasn't worked well ever for me, but reading up it does seem to happen for a lot of people. I haven't yet tried run as admin or compatibility modes, just that weird low priority suggestion. I think the game has memory leaks or something, I'm not sure. It seems there is so many people who have problems with it. I will try those though. For a short time it played great, about 15 minutes, it was fun, but on slideshow mode it's not fun

@Sawnson Photos, I emailed them And by the look of the Atari forums, nobody cares. Terminal Reality also has no support mentioned anywhere on their website, they do have job ad's though so I suppose it would be possible to contact them that way.

Anyways I'm not here to complain about the game, I was just wondering if anyone else here had any tricks that made it work for them.

My System SpecsSystem Spec
Reply

 Ghostbusters Performance




Thread Tools




Similar help and support threads
Thread Forum
Intel 520 SSD, low performance, high performance, then low again...?
I just now installed an Intel 520 240GB SSD. Measuring the performance, got strange results. First it did not at all perform close to my expectations and Intels promises:...
Hardware & Devices
TDU 2 performance is below par
So as the days go by Crossfire is beginning to annoy me more and more; I have the latest CAP Profiles installed and with 2 instances of GPU-Z open, the second card isn't be loaded much if at all. I'm seeing frames in the 40's and it's not making any sense to me at all. I should make mention that...
Gaming
SSD Performance
Hi all, I am a bit of a noob and I am looking for some help with understanding whether or not I have my system configured for optimal performance of my SSD drive. The performance I am currently getting seems quite low. Below are what I understand to be the relevant components involved: ...
Performance & Maintenance
Performance Has Changed To Performance Moniter
I am going through sql server 2005 implemetation and maintenance book. On chapter 15 it is going through useing performance moniter. which was about long before windows 7. Now ive got up to specifying my counters but i cannot find options to: 1. Set the inteval to one second. 2....
Performance & Maintenance
low performance
hello i want to declare that i very unsitisfied with the performance of my laptop with win 7 x64: 1.most of the time i see that my CPU usage is high 2.on new games on highest settings the game runs slow and i have tried the new wolfenstein and on highest settings its slow while my friend with the...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App