Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Star wars empire at war;forces of corruption issue

03 Jan 2010   #1

Star wars empire at war;forces of corruption issue

Me and my friend have modded our games. and i have vista and the mod works fine.
but he has Windows 7 and when he starts the mod it says it cant find the file path

C:\Program Files\LucasArts\Star Wars Empire at War Forces of Corruption\swfoc.exe
it says please check the file pth and try again.

I am pretty good with computers and i tried to help him but nothing we did seemed to work.

could it be because Empire at war is installed in the Program Files(x86) folder. so the filepath the mod is normally meant to used isnt tthe right one. I understand that 7 has two different program file folders, one for 64bit and one for 32bit.
so would i have to change the filepath in the mod to
"C:\Program Files(x86)\LucasArts\Star Wars Empire at War Forces of Corruption\swfoc.exe

My System SpecsSystem Spec
03 Jan 2010   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Go to the MS compatibility center and make sure the game is compatibile with 7.
My System SpecsSystem Spec
03 Jan 2010   #3


it is. the regular game works. but the mod wont
My System SpecsSystem Spec

21 Jul 2010   #4

windows 7

i know its really late and dont know if u still have the problem but i recently had the same trouble and i solved it by just moving the whole game into the normal 'program files' in stead of the 'program files (x86)' now it works fine...hope it helps
My System SpecsSystem Spec
31 Jul 2010   #5

Windows 7 and Windows Vista
Not sure what is the problem

I am having a problem with Star Wars Forces of Corruption on my laptops. One is running Windows Vista, and the other is running Windows 7. On both laptops the game loaded ok, I click start and it will go to the menu of options, and runs fine other than one problem. Once the game starts I don't get the menu of options, I mean the HUD for building and upgrading, and is just the games play screen without the bottom map or build options. I thought it was an issue with Windows 7, but the same problem is on my laptop running Windows Vista. Anyone have this problem too, or know a solution?
My System SpecsSystem Spec
03 Aug 2010   #6

Windows 7 Ultimate 32-Bit

Might be a bad install. Did you try reinstalling the game? Is this a disk version of the game, or did you download it online?
My System SpecsSystem Spec

 Star wars empire at war;forces of corruption issue

Thread Tools

Similar help and support threads
Thread Forum
Star Wars Empire at War Forces of Corruption
I cannot for the life of me get this to work, regular Star Wars - EAW works fine but when I try to play the FOC expansion it won't work and I get this exeption that I uploaded to be read. Windows 7 Home Premium 64-Bit 12GB of RAM GeForce GTX 295 Why won't it work?!
Star Wars Forces of Corruption Problem With Multiplayer
I have a new laptop with windows 7 / 64 bit and 6 GB of RAM. I installed Star War Empire at War and it works fine. I installed Forces of Corruption and the RAM patch. Single player works fine but the game always locks up when I try multiplayer on the internet. The game works fine on my old...
Star Wars Empire At War Crash
So, I have a problem that I have now been scouring the internet for, trying to solve. Both my copies of Star Wars Empire at War, and the expansion Forces of Corruption continuously crash at the loading screen for the main menu. Now, before I am told to download the patch, I have tried running the...
Star Wars Shadows of the Empire
I know this is a stretch but I may as well ask. Does anyone know how to get Star Wars: Shadows of the Empire working properly on Windows 7 64-bit or 32-bit with a modern video card? Whenever I try to launch it no matter what settings, I try the Hoth Level and I can only see the ground, nothing else.
Star wars forces of corruption won't work!
I've tried every single solution posted and none of them have worked like the patch from I can't seem to figure it out.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App