Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WINDOWS 7 wont work with zero hour!!!!!!!!!!!!!!!!

30 Jan 2010   #1

Windows 7
WINDOWS 7 wont work with zero hour!!!!!!!!!!!!!!!!



Release Crash at Sat Jan 30 20:30:31 2010
; Reason Uncaught exception in Main::WndProc... probably should not happen

Last error:
Exception is access violation
WinMain at 401700
Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Access address:00000000 was read from.
Stack Dump:
<Unknown>(-1) : <Unknown> 0x004010BB
<Unknown>(-1) : <Unknown> 0x76A46238
<Unknown>(-1) : <Unknown> 0x76A468EA
<Unknown>(-1) : <Unknown> 0x76A47177
<Unknown>(-1) : <Unknown> 0x76A472F1
<Unknown>(-1) : <Unknown> 0x774200E6
<Unknown>(-1) : <Unknown> 0x76A4A484
<Unknown>(-1) : <Unknown> 0x70130B64
<Unknown>(-1) : <Unknown> 0x701322C3
<Unknown>(-1) : <Unknown> 0x76A4A52B
<Unknown>(-1) : <Unknown> 0x004014ED
<Unknown>(-1) : <Unknown> 0x76A46238
<Unknown>(-1) : <Unknown> 0x76A47298
<Unknown>(-1) : <Unknown> 0x76A47D31
<Unknown>(-1) : <Unknown> 0x76A47DFA
<Unknown>(-1) : <Unknown> 0x76A6272B
<Unknown>(-1) : <Unknown> 0x76A6288A
<Unknown>(-1) : <Unknown> 0x76A9F8D0
<Unknown>(-1) : <Unknown> 0x76A9FBAC
<Unknown>(-1) : <Unknown> 0x76A9FCAF
<Unknown>(-1) : <Unknown> 0x76A9FD2E
<Unknown>(-1) : <Unknown> 0x76A9FE81
<Unknown>(-1) : <Unknown> 0x76A9FEC6
<Unknown>(-1) : <Unknown> 0x00402098
<Unknown>(-1) : <Unknown> 0x0041385B
<Unknown>(-1) : <Unknown> 0x008E08AC
<Unknown>(-1) : <Unknown> 0x767E3677
<Unknown>(-1) : <Unknown> 0x77449D72
<Unknown>(-1) : <Unknown> 0x77449D45
Register dump...
Eip:004010BB Esp:00189D14 Ebp:00189D84
Eax:00000000 Ebx:00000000 Ecx:00000000
Edx:0095DA0C Esi:00000010 Edi:00000000
CS:0023 SS:002b DS:002b ES:002b FS:0053 GS:002b
EIP bytes dump...
Bytes at CS:EIP (004010BB) : 8B 01 68 84 00 00 00 FF 50 28 33 C0 8B 4D F4 64 89 0D 00 00 00 00 5F 5E 5B 8B E5 5D C2 10 00 8B

Current stack:

Can someone please help me? I bought a brand-New 1200 Dollar computer and This SHIT IS KILLING ME!!!!!!!!!! SOME1 please help me it would be much appreciated....


My System SpecsSystem Spec
31 Jan 2010   #2

windows 7 ultimate

My System SpecsSystem Spec
31 Jan 2010   #3

Windows 7 Ultimate x64

You might get more help by filling in your system specs.
My System SpecsSystem Spec

31 Jan 2010   #4

Windows 7 x64 Ultimate

Unfortunately that error is actually a program bug.

So to get it to work is going to be a little bit hard as you have to find away of not triggering the bug in the game.

You could try updating audio/video drivers, or even downgrading them to older versions. But unfortuantely the slight differences in timeing/behavior in W7 have flushed out a bug in the original program.

Maybe the game has a patch for W7? Or is the game too old?
My System SpecsSystem Spec
01 Feb 2010   #5

Windows 7

it is command and conquer gnerlas zero hour

thx for your advice fseal I will try updating drivers and even downgrading them. If that doesnt wrk I will try something else...
My System SpecsSystem Spec
21 Jun 2010   #6

windows 7 32 bits
access violation


In your case it's an access violation error you get. Did you already try to run the game as administrator or xp compatible mode?

regards, steph
My System SpecsSystem Spec
19 Aug 2010   #7

Windows 7
This is how to fix the problem

This I found on another page and thought I would share it here as it worked for me.

Good News - Have just successfully managed to get it working, and it IS Windows 7 that causes the problem, specifically it's to do with access permissions to folders - Windows 7 blocks access to folders that Generals uses to run.
The way I fixed it was:
In 'My Documents' (usually at C:\users\YOURNAME\documents) there should be a folder named 'Command and Conquer Generals Data' or 'Command and Conquer Generals Zero Hour Data', which was put there when you installed the game. You need to create a text file using notepad and save it into this folder. However, you must click 'save as' and change the type drop-down box from text file (.txt) to 'all files'. Then save the file as 'options.ini'
Before you save, paste this text into the file to get you started:

AntiAliasing = 1
BuildingOcclusion = yes
DrawScrollAnchor =
DynamicLOD = no
ExtraAnimations = yes
GameSpyIPAddress =
Gamma = 50
IPAddress =
IdealStaticGameLOD = High
LanguageFilter = true
MaxParticleCount = 5000
MoveScrollAnchor =
MusicVolume = 55
Resolution = 1024 768
Retaliation = yes
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 50
SendDelay = no
ShowSoftWaterEdge = yes
ShowTrees = yes
StaticGameLOD = Custom
TextureReduction = 0
UseAlternateMouse = no
UseCloudMap = yes
UseDoubleClickAttackMove = no
UseLightMap = yes
UseShadowDecals = yes
UseShadowVolumes = yes
VoiceVolume = 100

This is simply how the game remembers what options you picked (music volume, brightness and the like) and you can change them once the game is running using the options menu.
Now the key bits - firstly, make sure that you have full read/write permissions for the Command and Conquer Generals Data folder - do this by right clicking on the folder, then properties then the security tab and change the permissions for all users. It might also be worth making sure no files are "Read-Only" in that folder.
Then change the game's compatibility mode by right clicking on the game in the start menu, clicking on properties and then the Compatibility tab. I used the "Change settings for all users" button at the bottom and changed to Windows XP (SP3), as well as checking the "Run as administrator box".
My System SpecsSystem Spec
19 Aug 2010   #8

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)

Zero hour or Generals is not compatible with windows 7 at all, but according to WCC it works on 32 and 64 bit.
My System SpecsSystem Spec
20 Aug 2010   #9

Windows 7

its defently compatible all you have to do is what i just posted... i have windows 7 x64 bit and after i did that about 4 hours ago it worked fine no problems!
My System SpecsSystem Spec
20 Aug 2010   #10

Windows 7 Ultimate x64

Tried fiddling with UAC?

Works for me when games refuse to install or run.

Unfortunately that error is actually a program bug.

So to get it to work is going to be a little bit hard as you have to find away of not triggering the bug in the game.
Doesn't help when the game is copy protected, too. Then it makes that debug info clear as mud ie: useless.
My System SpecsSystem Spec

 WINDOWS 7 wont work with zero hour!!!!!!!!!!!!!!!!

Thread Tools

Similar help and support threads
Thread Forum
Command & Conquer Zero Hour Wont start! 64bit 7600 W7
Hi! I just reformatted and installed my computer and it's all fresh, I've downloaded and installed all drivers for my parts. I have Windows 7 Professional Build 7600 64bit Here's the problem, I've tried all compatible modes and still it just starts up I can see the logo and then in the...
Taskbar and icons wont show up. Ctrl+Alt+Del wont work
So I just re-installed my Windows 7 and re-formatted my disk after getting the virus Win32:Sality. However, after I installed my graphics drivers and restarted my computer, the taskbar and icons wouldn't show. I can see my cursor and can move it. I can right click and get options as well. If I...
General Discussion
system repair wont work windows wont load
not sure if im in the right place but computer wont do anything but load up with options to do system repair or whatever its called but it says it cant fix the problem i dont have disc for it or any pw's im on a reg user account it wont load in safe mode but by doing different things i have access...
Hardware & Devices
Regedit wont run, and grant admin full control context menu wont work
For some reason, my logon background image isnt showing up anymore, and when I try to change back to the way I had done it, regedit wont run, I've searched the forums for an answer, with no luck. And when I go to click grant admin full control, it brings up an open with menu, so I need a command...
General Discussion
Lan wont work Compters wont give permision no matter what
Me and my nephew wanted to lan play a couple of games. The first time every thing went smoothly. Both computers communicated fine how ever after that they now refuse to communicate. When I try to test the access it now stats on both that we don't have admin permission. I tride every thing I...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App