Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: elder scrolls 4 and titan quest not installing

22 Feb 2010   #1

windows 7
elder scrolls 4 and titan quest not installing

both of these games start the install and get to the step where you see the completion indicator and they both freeze not installing the game. Task manager shows them running but nothing happens. Running them on win 7 32 bit and I have tried using comapt mode as well.

My System SpecsSystem Spec
22 Feb 2010   #2

Windows 7 Professional x64

How long have you waited for them to finish?
  • It's not uncommon for installers to hang and then suddenly leap to finished or near finished on weaker systems. If you're assuming they're frozen quickly then it could be that they just hung and aren't displaying their progress results to you.

Are you running anything in the background?
  • I have Titan's Quest (and Immortal Throne) as well as TES4: Oblivion installed on my PC so I know they install just fine. Could there be anything else running that might interfere with the installation?

Have you tried going right to the CD/DVDs and running the setup/autorun files with the "Run as Administrator" option?
  • It could be that you lack sufficient permissions for them to install. I don't recall doing this with my games but it's worth a shot.

Did you cancel an installation and leave partial files out there?
  • This may or may not matter but if you cancelled the installations I'd suggest checking to see what did get installed and copied to your HDD. I'd also suggest removing that before trying the next install.
My System SpecsSystem Spec
22 Feb 2010   #3

windows 7

got a dual core and 2gb ram so not the fastest but hardly a slow poke. Do you have it running on a win 7 machine and if so did you install it UNDER 7 or was it there from before (I know you can't go to 7 from xp directly but you may have gone the xp to vista to 7 route and installed somewhere earlier). I also see neither HD or CD activity and can leave it this way for 5-01 minutes and nada so I doubt it is doing anything.

What could interefer with the install? Ideas would help since I see nothing odd and only have the usual programs running.

I ran the setup file by right clicking and running as admin (although I am the only user and I have admin rights).

There are no files since the folder was never created.
My System SpecsSystem Spec

23 Feb 2010   #4

windows 7

here is something to ponder. Had a brilliant idea that worked. I installed the game on my son's xp box. Set up a share. Copied the folder. Ran it and things seem fine! I guess everything is going to work but I will leave things on his comp just in case something down the line ends up missing but I would imagine that if there were things in the system folder or elsewhere 9or stuff in the registry) it would already have died so I am hopeful.
My System SpecsSystem Spec

 elder scrolls 4 and titan quest not installing

Thread Tools

Similar help and support threads
Thread Forum
Error C80001FE, after installing Elder Scrolls Online.
Hi! So I installed ESO about 2 days ago, which was followed by boot up problems and BSOD's, which i managed to fix by running the windows boot up fix over and over again. But now, I cant run windows update because of error C80001FE. I have tryed running the sfc/scannow, but it gets to 1%...
BSOD Help and Support
Elder Scrolls... ONLINE!
I am not with you, i am on my local EB Games website right now, and it shows Elder Scrolls Online!!! God, that is one game that I am deffinately getting... how about everyone else on these forums?
Titan Quest
Is anyone else here a fanatical Titan Quest/Immortal Throne player. By the way, I installed it yesterday on my new Windows 7 computer and it runs fine.
Elder Scrolls V: Skyrim trailer.
New Elder Scrolls V: Skyrim footage is better than we deserve | Joystiq I'm speechless.
I can't get Elder Scrolls: Oblivion working
Reinstalled, done everything. Hasn't worked on my rig. It crashes every time I start it, before even getting to the menu screen. I have also tried it without any mods installed. Anyone else having this issue?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:49.
Twitter Facebook Google+