Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: left 4 dead 2 won't run

25 Mar 2010   #11
Lordbob75

Windows 7 Ultimate x64, Mint 9
 
 

Sounds like that particular engine does not run well....

~Lordbob


My System SpecsSystem Spec
.
26 Mar 2010   #12
haxcid

Windows 7; Server 08; Window Home Server; Vista; XP
 
 

have you tried elevating the games cpu priority?

under the games launch options, found in your steam games list, right click the game, properties.

put this -high

This will run the game at high cpu priority.
You might want to make sure you are running the game under an administrator account as well.

H.
My System SpecsSystem Spec
26 Mar 2010   #13
QuackPot

Windows 7 Professional x64
 
 

Make sure you have the latest direct X and C++ runtimes.
My System SpecsSystem Spec
.

09 Apr 2010   #14
Chaosty

Acer
 
 

hellllllllllllppppppp
what can i do with this?
im also windows 7 user


My System SpecsSystem Spec
11 Apr 2010   #15
Lordbob75

Windows 7 Ultimate x64, Mint 9
 
 

Quote   Quote: Originally Posted by Chaosty View Post
hellllllllllllppppppp
what can i do with this?
im also windows 7 user


We will need some more information Chaosty....

~Lordbob
My System SpecsSystem Spec
12 Apr 2010   #16
haxcid

Windows 7; Server 08; Window Home Server; Vista; XP
 
 

Quote   Quote: Originally Posted by Chaosty View Post
hellllllllllllppppppp

what can i do with this?
im also windows 7 user

Well the first thing I see is that aero is not running. I notice that your title bar on that window is a solid blue and not transparent. Which would lead me to believe that you may be having a graphic driver issue.

Have you updated the graphics driver on your system recently?
My System SpecsSystem Spec
13 Apr 2010   #17
Chaosty

Acer
 
 

Quote   Quote: Originally Posted by haxcid View Post
Quote   Quote: Originally Posted by Chaosty View Post
hellllllllllllppppppp

what can i do with this?
im also windows 7 user
Well the first thing I see is that aero is not running. I notice that your title bar on that window is a solid blue and not transparent. Which would lead me to believe that you may be having a graphic driver issue.

Have you updated the graphics driver on your system recently?
i think no..?
how can i do that?


@lordbob..
will post soon, im not with my loptop now..
My System SpecsSystem Spec
14 Apr 2010   #18
haxcid

Windows 7; Server 08; Window Home Server; Vista; XP
 
 

Quote   Quote: Originally Posted by Chaosty View Post
Quote   Quote: Originally Posted by haxcid View Post
Quote   Quote: Originally Posted by Chaosty View Post
hellllllllllllppppppp


what can i do with this?
im also windows 7 user
Well the first thing I see is that aero is not running. I notice that your title bar on that window is a solid blue and not transparent. Which would lead me to believe that you may be having a graphic driver issue.

Have you updated the graphics driver on your system recently?
i think no..?
how can i do that?


@lordbob..
will post soon, im not with my loptop now..
Sometimes you can get it through windows update, manufacturers website, or from the graphics processors site.

What graphics do you have? Your system specs on list the OS as Acer.

I am assuming you are using a laptop. Is the laptop even capable of running left 4 dead 2?
My System SpecsSystem Spec
09 May 2010   #19
Sumguy105

Windows 7
 
 

Hi, i have almost the same problem i just bought a new comp with windows 7 and when i run steam not only does it take i lifetime to load but when i run newly installed L4D2 it gets through the opening Valve logo and then freezes after the video or i hit escape any ideas>

Thanks
My System SpecsSystem Spec
09 May 2010   #20
rvbfan

Windows 7 Home Premium 64bit
 
 

No over clocks? I know that with my system Source and overclocking don't mix well.
My System SpecsSystem Spec
Reply

 left 4 dead 2 won't run




Thread Tools




Similar help and support threads
Thread Forum
left 4 dead 2
does any 1 play this on steam? i think much people cant play it (say if im wrong) but i heard you need a verry good videocard (i got NVIDEA GTX550)
Gaming
Left 4 Dead and CS2 lag
Hi, I have been experiencing lags on my Laptop for Left 4 Dead and CS2. Specs: ACER Aspire 4715 Pentium Dual Core 1GB RAM m965 chipset Windows7 Ultimate I did not have problems with CS2 when I had WinXP but with Windows7, I have some lagging issues. I cannot compare that of left 4 dead...
Gaming
Left 4 Dead on Win 7
Hi SevenForums. In vista I had L4D 1 running perfectly fine. In windows 7 it lags very much, also in singleplayer. I have windows 7 home premium 32 bit. Please help me
Gaming
Left 4 Dead 1 and Windows 7...
Hi, I want to download and buy Left 4 Dead 1 from Steam. I was just wondering if it should work fine on my 7600 Build Windows 7. Here is the link to my setup as well. Newegg.com - HP Pavilion DV6-2144NR NoteBook AMD Turion II M520(2.3GHz) 15.6" 4GB Memory 320GB HDD 7200rpm DVD Super Multi ATI...
Gaming
left 4 dead help pls
worked great with vista , just upgraded to win7. installed all latest win7 drivers from asus homepage, all seems great.. run l4d and after vids in beginning it crashes right away and i have no clue what to do now.. tryed to re-install l4d once still the same..:shock:
Gaming
Left 4 dead crashed only me?
hello guys, i am new to this forum. the problem i've just got and got confused is that, after installing Windows, i played L4D with my firends for a campaign. However, after the campaign while i was trying to play another, the program freezed. after it freezed, no matter how many times i...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App