Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: xFire requires admin access

17 Apr 2010   #1

Windows 7 Professional x64
xFire requires admin access

I just installed Windows 7 Pro x64, and I am trying to install xFire. It tells me "This installer requires admin access, try again"

Windows seems to have alot of privlages issues.

Any ideas?

My System SpecsSystem Spec
17 Apr 2010   #2
not so gray matter

W7 Ult. x64 | OS X

Enable your administrator account and try to install it from there:

Start > "cmd" > Right Click cmd.exe > Run as Admin...
Enter line: net user administrator /active:yes
Log Off
Log In Using Administrator Account
Install Xfire
Log Out
Log In Using Normal Account
Check to make sure you can use Xfire properly
If so, disable Administrator Account by running the same line in cmd.exe w/ a no instead of yes...
net user administrator /active:no

Otherwise you could just disable UAC while you install Xfire...

Control Panel > User Accounts > Change User Account Control Settings > Slide to bottom
My System SpecsSystem Spec
17 Apr 2010   #3

Windows 7 Professional x64

I disabled UAC, didn't work.

Worked the other way though.... what a shit of a thing to have to do!!!


You need to restart your PC after you disable UAC. Now it works fine.
My System SpecsSystem Spec


 xFire requires admin access

Thread Tools

Similar help and support threads
Thread Forum
Admin account corrupted and cant access files using Admin p/w
Hi guys when my pc gets to the first screen where you choose your account my admin account has changed from my name to 'Other user' and when I click on it it asks for a username and password. Also trying to access files from the admin account when it prompts me with a password I enter it and the...
General Discussion
Windows cant "find" any .EXE files or any file that requires admin
This has been happening for 7 months now, and i've had enough. spent over 70$ on games, which cant run because windows can't find firewall settings. Or it just cant find the file in the first place. Windows can run certain .exe files that were before this started happening, but any installer or...
Standard user requires admin PW when using elevated command
I have a file to clear the print spooler when it has an error. I based this file on Brinks tutorial. Thanks Brink. I placed this file in C:\windows\system32 folder so all users would have access. The file must be run in a elevated cmd window. I then created a shortcut to the file and put the...
General Discussion
How can I schedule a startup task that requires admin privileges?
This is something that has bugged me since installing Windows 7 Ultimate with separate admin and user accounts. As often recommended for security, I normally log on as a standard user. If I truly want to make a system change, update a program, etc., I am happy to get a prompt for an admin...
General Discussion
How do I unlock admin with no admin access
So, here's what I did. Fresh install of Windows 7 x64 Pro. Default initial user is "Benjamin" created a second user, "Adam" created a third user, "root" Next security setup. I removed administrator privileges from Benjamin. Adam was created with no administrator privileges. root was given...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:51.
Twitter Facebook Google+