Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires 3 not working

21 Apr 2010   #1

Windows 7 Home Premium (32)
Age of Empires 3 not working


I recantly upgraded my computer from windows XP (service pack 3) to windows 7 (32 bit). On windows XP I had age of empires 3 installed which was running perfectly (My computer is more than good enough to use windows 7 by the way). Age of Empires 3 installed correctly but when I try and open the age of empires 3 it came up with the message "This program has known compatibility issues" and asks me to either "check for solutions" online (which when clicked says "there are no solutions") or "run program". When you click "run program" a message comes up saying "The color scheme has been changes to Windows 7 Basic, as it is not compatible with windows aero" which it fine, but then nothing happens... When you go to task manager the "age3.exe" process is running but nothing happens. Also I will add that the same problem happens with The War Chiefs and The Asian Dynasties expansions.

I have spent hours searching the internet for a solution to this problem, but to no success. Many windows 7 users are having the same problem I have read, I have not been sold a dud, and there is no solution that seems to work. I have already tried running age of empires 3 in compatability mode for Vista and windows XP service pack 3 and run program as administrator (which I already am) and it does nothing. I have also downloaded the latest patch from age community and installed it, which makes no difference. I have also uninstalled and reinstalled the game 3 times which did not fix it.

If anyone can not come up with a solution, could you please at least help me get customer support from Microsoft?

To get customer support from microsoft you need a Product Identification Number, which is unfortunately accessed in-game, which I can not access. On Windows XP you can access the Product Identification number through:

Click Start / Help and Support / Tools / My Computer Information
click "View a list of Microsoft software installed on this computer" to
see programs registered by product identification number.

But on Windows 7 there is no "Tools" section in Help and Support.

I payed over $100 for Age of Empires 3 and its expansions, I really want to get it working again.


My System SpecsSystem Spec
21 Apr 2010   #2

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)

Have you tried Compatibility mode:

Attached Images
Age of Empires 3 not working-compatmode.jpg 
My System SpecsSystem Spec
21 Apr 2010   #3

Windows 7 Professional 64

Hi xAoe,

Yea looking for you I have seen quite a few posts about this particular problem.
Have you tried the file checker? It's in this mod post from Empires:AOE3 Forums - File Check Utility

At this time I only have one other suggestion, the .exe that you click to launch the game, right click it /properties/compatibility and check off Disable desktop composition, then apply.

What this does is when you launch the game exe file, windows will force aero off as long as you are in game.

If I come across something, I'll post back here, can't promise anything.
We aren't connected to Microsoft, but hopefully someone might see this with a possible answer.

PS: Ah I just found this, it might be worth a try.
Workaround to Play StarCraft, Age of Empires and Diablo in Windows 7 or Vista (Fix Color Display Issues) My Digital Life

There is also this thread:
Age of Empires II

Also what is your graphic device, onboard or card?
My System SpecsSystem Spec

21 Apr 2010   #4

Windows 7 Home Premium (32)

Yes I have already tried compatability mode just like the image shows and it makes no difference, so does running the program as administrator and enabling the other settings in compatability makes no difference.

I also tried ending the process explorer.exe then running the game, the same problem still happened, which i think eliminates the possibility of windows areo interfering, additionally I tried changing the colours of my monitor from 32 to 16 (which looks crap) and also makes no difference.

I am out of ideas...

Anyone know how to access the Product Idenification Number without going into the game on Windows 7? Maybe Microsoft support may have something.... Maybe

Edit: my graphics card came with the computer (Nvidia Geforce 8600 GT), I have not messed around with it, and the drivers are no more than a few months out of date. It runs Cod MW2 on highest graphics no problem...
Edit: just updated my graphics drives to most recant, made no difference
My System SpecsSystem Spec
06 Sep 2010   #5

Windows 7 x64 RC1 b.7100

I just told Microsoft there gay, and that age3 is not compatible with win 7, lol. I will fix this issue; it is not the system or drivers, it a possible exe script error that win7 does not read right at all, so MS needs to figure out why there' game does not work on win7 all the time. Funny thing was that I ran the game 3 times and then stopped, it might be that if you check do not show again on the notice popup it stops working, HHHMMM???

Weee, new prob for me to fix!
My System SpecsSystem Spec
06 Sep 2010   #6

Windows 7 x64 RC1 b.7100

Update to patch 1.14, it worked for me and now I play all the time, good luck.
My System SpecsSystem Spec
10 Mar 2012   #7

Windows 7 64-bit home premium

Hi, I just bought a copy of Age of Empires used, but when I put the CD into the disk drive nothing happens. I do not receive any message box, and when I check the status of it in the Start menu-computer section, the game is not listed anywhere. I have Windows seven, can any one help me with this, or is it that the disk may be damaged so it won't come up at all?
My System SpecsSystem Spec
14 Apr 2012   #8

windows 7

i have the exact same problem! any solutions being found ?
My System SpecsSystem Spec
30 Apr 2012   #9

windows 7
age of empire 3

i have the same problem and i also tried all the solution and even update the patch but the conclusion is same
My System SpecsSystem Spec

 Age of Empires 3 not working

Thread Tools

Similar help and support threads
Thread Forum
binkw32.dll not working for age of empires
hi after installing and loading the game , a message saying binkw32.dll is unresponsive blah blah blah.Ive tried microsoft website but i get to step 7 when extracting this and transfering it is not available , any help ?
age of empires not working
Hi , After i installed all three disks i went on to play the game and all of a sudden the the game was unable to load up.In the bottom right corner of the screen a blue box comes up saying my graphics have automatically changed to window 7 basic but then still didnt work :S , any help please to...
Age of empires
Can some please tell me if age of empires, will play using windows 7? Thanks, Sarah.
Age of Empires II
Hi, I have a problem with Windows 7. I can play Age of Empires II, because the whole picture is green! The video is up to date,knows someone who is wrong? Thx
Age of Empires III! [ALL]
Hello, sorry. I have searched around the forum and I've found out that Age of Empires III does work on Windows 7 BUT I'm too newbie to understand. Can someone please tell me how to make it work? Actually, I'm just having some small issues rather than those extreme ones like whenever I play the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:04.
Twitter Facebook Google+