Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow game performance

04 Jun 2010   #51
ro888

Windows 7
 
 

Quote   Quote: Originally Posted by whiplash View Post
I don't know if anyone read one of my resent posts or not but i had a really important question to ask.

Here's the question, if i format my drive will i be able to reinstall win 7 with the "upgrade version" of Home Premium? I just need to know if i have to go out and buy the full version or not.
Finally, I found someone on the same boat like me. I have the following configuration:


Quote:
OS: Windows 7 Ultimate 32bit (Clean install)
CPU: AMD 64 3700+
Motherboard: Lanparty NF4-SLI D
RAM: 3GB DDR400
HDD: 250GB Western digital 7200rpm SATAII, 16MB buffer (No NCQ support)
Sound: Creative X-Fi Champion series
Graphic: XFX ATI HD 4870 1GB GDDR5
Power: Antec Trupower 480W

Drivers
Graphic: Catalyst 10.5 with CCC
Chipset: NF4-7 Performance Packs
Gaming was horrible slow in Windows7 and I would say it's only 30% performance of XP SP3. Now, I am start thinking if this issue only occur with Nvidia Nforce chipset. I did try to comparing the performance of different chipset different including the Windows 7 default driver by using Passmark Performance Test tool. What I found was:

Quote:
1. There is no signification difference between difference chipset drivers.
2. If you run benchmark just after the start up of OS, it would give you very high score.
3. If you run it after a while (Say 30mins), the performance will degrade so much especially in the CPU and 3D's mark.
I guess there are definitely something with Nforce memory bus.


My System SpecsSystem Spec
.
04 Jun 2010   #52
Fumz

7 Ultimate x64
 
 

My wife has almost those exact same specs. DFI nf4, 3700+, 2GB ddr 400, 8600gt, Samsung 226bw (1680x1050). 32-bit 7 Ultimate.

There are no issues, or slowdowns gaming on that rig; however, I don't install modern games on it... she just doesn't have the cpu strength.

Battlefield 1942, CS: Source, those games run ok... anything more demanding would, I suspect, choke.

What games are you trying to run?
My System SpecsSystem Spec
04 Jun 2010   #53
ro888

Windows 7
 
 

Quote   Quote: Originally Posted by Fumz View Post
My wife has almost those exact same specs. DFI nf4, 3700+, 2GB ddr 400, 8600gt, Samsung 226bw (1680x1050). 32-bit 7 Ultimate.

There are no issues, or slowdowns gaming on that rig; however, I don't install modern games on it... she just doesn't have the cpu strength.

Battlefield 1942, CS: Source, those games run ok... anything more demanding would, I suspect, choke.

What games are you trying to run?
I tried Left 4 Dead2, Borderlands and those were able run at 8x AA without any problem in XP. In fact, it is not only gaming, general browsing are all slow down. For Passmark Performance test, I can only get 260 mark where it is supposed to be more than 500!

Can you tell me what driver you installed?
My System SpecsSystem Spec
.

04 Jun 2010   #54
Fumz

7 Ultimate x64
 
 

hmm... Unfortunately I can't find the nf4 downloads on DFI's site (you know they're shutting down their LanParty division, right? ).

I know I updated the bios to the latest and just installed the chipset and ethernet drivers. I didn't install any performance packs and no ide drivers.

edit...

hold on a sec, finding them now.

406 bios. Marvell Lan driver.

I recall installing a chipset driver, I just can't seem to find it anymore... it was for Vista. http://www.dfi.com.tw/portal/CM/cmpr...rmal&mode=view
My System SpecsSystem Spec
04 Jun 2010   #55
ro888

Windows 7
 
 

1 .I did try to uninstall all the Nivida and just let Windows7 to use its own driver. It doesn't help.

2. My bios was update to the newest one.

This is a stange issue and I am thinking if I should back to XP, lol.
My System SpecsSystem Spec
05 Jun 2010   #56
archie123

Win 10 Home Premium 64 Bit
 
 

ro888 ...................

ok ive been doing a bit of digging it seems the default win 7 chipset driver is the best for NF4 chipsets under win 7 (this is only for gaming ive not looked into anything else)

so your better off uninstalling your chipset drivers and letting win 7 do its thing on reboot then leaving it
........................

the problem seems after looking around that win 7 doesnt properly support NF4 though i dont think this is the full issue , i think running a multithreaded game on a single cor cpu in win 7 is always going to be an issue no matter what you try and do

whiplash.................

i would never recommend anyone upgrade their hardware till all other avenues have been explored but i think this one has been "done to death" i think (and i hardly ever say this) its a hardware issue , specifically and old hardware issue , i think the cpu is dragging the rig down under certain circumstances , ie games that are specifically written to run on multi core cpu's , win 7 seems to have issues
My System SpecsSystem Spec
05 Jun 2010   #57
ro888

Windows 7
 
 

Thanks for your help, guys. I think it's the time to upgrade my system and let NF4 sit back with XP.
My System SpecsSystem Spec
05 Jun 2010   #58
Fumz

7 Ultimate x64
 
 

Look at this positively: it'll make an excellent htpc, and that's something XP can't do.
My System SpecsSystem Spec
06 Jun 2010   #59
whiplash

Windows 7 Home Premium x64, Ubuntu Linux
 
 

ok, so later on today i'm going to order a new quad core cpu. here's a link to it.

Intel Core 2 Quad Q8300 Processor BX80580Q8300 - 2.50GHz, 4MB Cache, 1333MHz FSB, Quad Core, Retail, Socket 775, Processor with Fan at TigerDirect.com

There's also an identical OEM model for the same price that has 6mb of cache. should i go for 2 more mb of cache, or stay with retail packaging?

as for cooling, i have that handeled. here's a link to the cpu cooler i'm getting.

Thermaltake SpinQ CPU Cooler - Socket 775, 939, 754, AM2/AM2+/1366/1156 Support at
TigerDirect.com

Or should i go with this cooler for $10 less.

http://www.tigerdirect.com/applicati...3&Sku=ULT40493

i would like to get the thermal-electric cooler but i'm a little short on cash now.

anyone have anything to say before i say goodbye to $200 and become a broke teenager once again?
My System SpecsSystem Spec
06 Jun 2010   #60
Fumz

7 Ultimate x64
 
 

Games make use of two things: cores and cache. As for whether or not to get the cpu with the higher cache... well, even though it's OEM (original equipment manufacturer), in this case, the OEM happens to be Intel. Just be aware that it's not going to come with the same warranty as the retail (lower cache) version.

Just to calm your nerves, if they're not already, I've never had a single problem with an OEM cpu. If a chip is going to fail, it's going to do it shortly after I pull it out of the box, still under the 15/30/whatever day warranty... not six months to a year down the road.

As for your cooler, $60.00 for a Thermaltake? That's spending Thermalright or Zalman type cash; does it deliver similar performance?
My System SpecsSystem Spec
Reply

 Slow game performance




Thread Tools




Similar help and support threads
Thread Forum
Very slow game loading, game runs normal
I switched to Win7 just 2 months ago. Though my hardwares are quite old, but it still running well. So I installed some games in my PC, and played without problem. However, today I have this weird thing. When I start a game, it loads very slow, and I thought it freezes. However, after some...
Gaming
System performance "slow" warning in any game, but running just fine
I'm very tired of seeing this message booting me to desktop just to ask me if I want to change the color scheme because it perceives my computer is running slow. Load up Batman AC? 10 minutes in focus changes from said full-screen app to this completely unnecessary 'warning'. Battlefield 3? ...
Performance & Maintenance
Game lagging and slow performance of pc.Suggestion about a gaming rig?
hello everyone, nowadays my pc are running slow and my game are lagging. When i run some of my game, my cpu usage become 100 percent and cause my game to lag. But this is not because of the graphic settings i have on the game. I have already try to defrag and do some checking like scanning with...
Gaming
game performance becomes slow/jerky
i have an hp dv5 1006ax laptop with windows 7. my problem is, the game performance becomes slow/jerky (not smooth) when power is unplugged. i tried changing my power plans. but no use. when it is plugged in it works smooth. i have ATI Radeon HD 3400 on it please help
Gaming
Slow Performance, Slow Boot-up - Cause Undetermined!
Hello everyone, I have done a lot of research on Google as well as on this forum to find a solution to my problem. Unfortunately, people who have posted on the forums have SIMILAR but not the exact problem as I have. I would like to take this opportunity and explain exactly whats been going...
Performance & Maintenance
W7 Slow Boot Time and Overall Slow performance
Hi new to these forums and I'm hoping someone can help me out here. I formated my HDD and did a clean install (W7 7100 build) but I'm noticing slow boot times and slow performance compared to Vista x64. W7 boots at least 10secs slower and programs tend to lag (aren't as snappy compared to...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App