Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow game performance

06 Jun 2010   #61
whiplash

Windows 7 Home Premium x64, Ubuntu Linux
 
 

Quote   Quote: Originally Posted by Fumz View Post
Games make use of two things: cores and cache. As for whether or not to get the cpu with the higher cache... well, even though it's OEM (original equipment manufacturer), in this case, the OEM happens to be Intel. Just be aware that it's not going to come with the same warranty as the retail (lower cache) version.

Just to calm your nerves, if they're not already, I've never had a single problem with an OEM cpu. If a chip is going to fail, it's going to do it shortly after I pull it out of the box, still under the 15/30/whatever day warranty... not six months to a year down the road.

As for your cooler, $60.00 for a Thermaltake? That's spending Thermalright or Zalman type cash; does it deliver similar performance?
So you're suggesting the OEM CPU?

I've never heard of Thermalright or Zalman. all i know is i'm getting a quad core CPU and i need something better than a stock heat sink and fan that comes with most Intel CPUs


My System SpecsSystem Spec
.
06 Jun 2010   #62
Fumz

7 Ultimate x64
 
 

$60.00 is a lot to spend on a cooler... so if you're going to spend it, you want something that proven to be really good. You'd be hard pressed to find anyone or any review that says that for LGA 775 sockets, you can't do much better than the Thermalright Ultra 120 Extreme. Well, you can do a bit better, but it will cost you almost twice as much, and twice as much will only get you 1C or 2C lower. Thermalright Ultra-120 Extreme Rev C CPU Heatsink: CrazyPC Computers Here's a 120 Extreme that's actually cheaper than that Thermaltake.

Thermalright Ultra 120 eXtreme Rev.C Review - Overclockers Club

Slight Tune Up: Thermalright Ultra-120 eXtreme Rev.C, Cogage Arrow and Zalman CNPS10X Flex - X-bit labs

Introduction - Thermalright Ultra Extreme 120 Revision B & C Review | [H]ard|OCP

As for the cpu, you have what you need to make the choice. 1 comes with a longer warranty, the other comes with a higher cache. I'm not so much suggesting as I am telling you my experience... the choice is yours to make; afterall, you're the one that's got to use it.
My System SpecsSystem Spec
06 Jun 2010   #63
whiplash

Windows 7 Home Premium x64, Ubuntu Linux
 
 

Quote   Quote: Originally Posted by Fumz View Post
$60.00 is a lot to spend on a cooler... so if you're going to spend it, you want something that proven to be really good. You'd be hard pressed to find anyone or any review that says that for LGA 775 sockets, you can't do much better than the Thermalright Ultra 120 Extreme. Well, you can do a bit better, but it will cost you almost twice as much, and twice as much will only get you 1C or 2C lower. Thermalright Ultra-120 Extreme Rev C CPU Heatsink: CrazyPC Computers Here's a 120 Extreme that's actually cheaper than that Thermaltake.

Thermalright Ultra 120 eXtreme Rev.C Review - Overclockers Club

Slight Tune Up: Thermalright Ultra-120 eXtreme Rev.C, Cogage Arrow and Zalman CNPS10X Flex - X-bit labs

Introduction - Thermalright Ultra Extreme 120 Revision B & C Review | [H]ard|OCP

As for the cpu, you have what you need to make the choice. 1 comes with a longer warranty, the other comes with a higher cache. I'm not so much suggesting as I am telling you my experience... the choice is yours to make; afterall, you're the one that's got to use it.
thanks for the links, but i decided against one of those because of size. i'm sure they're great coolers but i'm just mot sure if one will fit in my case. that's why i'm probably going with the Ultra Chilltek Silver CPU cooler.

i was looking at the OEM cpu again and if you scroll down to the near bottom of the page, the warranty says 12 months. seems like a no brainier, same price as retail, better, 1 year warranty.

I just have one thing to say, i hope this fixes my problem and i'm not out $200 for nothing! Although i'm pretty sure my "ancient" P4 is my problem, knock on wood.
My System SpecsSystem Spec
.

07 Jun 2010   #64
Fumz

7 Ultimate x64
 
 

If it's any consolation, I just went from an E8400 @ 3.6GHz to a quad because Bad Company 2 just didn't play smoothly even when I clocked to 4GHz. The improvement was dramatic. I'm sure you'll be quite pleased.
My System SpecsSystem Spec
08 Jun 2010   #65
whiplash

Windows 7 Home Premium x64, Ubuntu Linux
 
 

I just got my quad core about an hour ago. I just now put it in and put the new CPU cooler on, but I can't boot up! When it asks you to chose the OS it comes up with a screen that is titled "Windows Error Recovery". If I choose to start windows normaly then it goes to the windows loading screen but freezes right when the little red and yellow balls of light spin around. If I choos safe mode then it won't go further than the drive loading screen.

Got any ideas?
My System SpecsSystem Spec
08 Jun 2010   #66
Fumz

7 Ultimate x64
 
 

Turn the machine off, and disconnect any secondary hard drives you may have. You only want your primary partition connected.

I'm not sure how you're getting to 3GB's of RAM, but pull all but one stick and then boot into the bios. Load the fail safe defaults, aka system setup defaults, save your changes, then reboot.

See if you can boot into Windows. If you can, find and get a bios update for your board.

Did you also get a new board, or is this still the 650i?
My System SpecsSystem Spec
08 Jun 2010   #67
whiplash

Windows 7 Home Premium x64, Ubuntu Linux
 
 

I'm booting with the OS DVD in the drive and it's doing the same thing, freezes at the starting windows screen.
My System SpecsSystem Spec
08 Jun 2010   #68
whiplash

Windows 7 Home Premium x64, Ubuntu Linux
 
 

Quote   Quote: Originally Posted by Fumz View Post
Turn the machine off, and disconnect any secondary hard drives you may have. You only want your primary partition connected.

I'm not sure how you're getting to 3GB's of RAM, but pull all but one stick and then boot into the bios. Load the fail safe defaults, aka system setup defaults, save your changes, then reboot.

See if you can boot into Windows. If you can, find and get a bios update for your board.

Did you also get a new board, or is this still the 650i?
Tried the defaults and that didn't work. I am still useing the same board.

Sorry for Any spelling or grammar mistakes, Im useing my iPod touch and it's hard to type on.
My System SpecsSystem Spec
08 Jun 2010   #69
Fumz

7 Ultimate x64
 
 

I had a very similar problem just a few weeks ago. Windows 7 is actually very good about detecting a new chipset and installing the right drivers (not that that's your problem), but we'd like to avoid having you reinstall the OS.

If it's your idea to repair the mbr, that's cool, but you're going to have to select cd/dvd to run first, or before the hdd. For me, that didn't actually work... which was also inexplicable? I was all ready to wipe the OS and do a clean re-install, but it just would not boot to dvd first no matter what. That was fortunate, because all I needed was a bios update.

I really have no idea why all of a sudden you can't boot? There's really no reason why it's not. Same chipset, just another cpu. My suggestion remains to try and get into the OS with 1 stick of RAM. Try each of the remaining sticks individually. If that doesn't work, select a different dimm slot and repeat the process.

If worse comes to worse and you get fed up, you could always put the old chip back in, update the bios, then replace it with the new.

A hassle for sure, sorry you have to go through it.
My System SpecsSystem Spec
08 Jun 2010   #70
whiplash

Windows 7 Home Premium x64, Ubuntu Linux
 
 

Quote   Quote: Originally Posted by Fumz View Post
I had a very similar problem just a few weeks ago. Windows 7 is actually very good about detecting a new chipset and installing the right drivers (not that that's your problem), but we'd like to avoid having you reinstall the OS.

If it's your idea to repair the mbr, that's cool, but you're going to have to select cd/dvd to run first, or before the hdd. For me, that didn't actually work... which was also inexplicable? I was all ready to wipe the OS and do a clean re-install, but it just would not boot to dvd first no matter what. That was fortunate, because all I needed was a bios update.

I really have no idea why all of a sudden you can't boot? There's really no reason why it's not. Same chipset, just another cpu. My suggestion remains to try and get into the OS with 1 stick of RAM. Try each of the remaining sticks individually. If that doesn't work, select a different dimm slot and repeat the process.

If worse comes to worse and you get fed up, you could always put the old chip back in, update the bios, then replace it with the new.

A hassle for sure, sorry you have to go through it.
I just put the old P4 back in and everything's working fine, good to know i can fall back to it if need be.

How would i update the BIOS? would it be just like updating a video driver or something like that? i'm asking because i've never done it before and don't know if there it something special that needs to be done. Also, can i update the BIOS with the P4 and then swap it out for the quad?

I'll try booting with 1gb of RAM in a minute. that big CPU cooler is a PAIN! it's getting really annoying to have to take the whole motherboard out every time i switch CPUs.
My System SpecsSystem Spec
Reply

 Slow game performance




Thread Tools




Similar help and support threads
Thread Forum
Very slow game loading, game runs normal
I switched to Win7 just 2 months ago. Though my hardwares are quite old, but it still running well. So I installed some games in my PC, and played without problem. However, today I have this weird thing. When I start a game, it loads very slow, and I thought it freezes. However, after some...
Gaming
System performance "slow" warning in any game, but running just fine
I'm very tired of seeing this message booting me to desktop just to ask me if I want to change the color scheme because it perceives my computer is running slow. Load up Batman AC? 10 minutes in focus changes from said full-screen app to this completely unnecessary 'warning'. Battlefield 3? ...
Performance & Maintenance
Game lagging and slow performance of pc.Suggestion about a gaming rig?
hello everyone, nowadays my pc are running slow and my game are lagging. When i run some of my game, my cpu usage become 100 percent and cause my game to lag. But this is not because of the graphic settings i have on the game. I have already try to defrag and do some checking like scanning with...
Gaming
game performance becomes slow/jerky
i have an hp dv5 1006ax laptop with windows 7. my problem is, the game performance becomes slow/jerky (not smooth) when power is unplugged. i tried changing my power plans. but no use. when it is plugged in it works smooth. i have ATI Radeon HD 3400 on it please help
Gaming
Slow Performance, Slow Boot-up - Cause Undetermined!
Hello everyone, I have done a lot of research on Google as well as on this forum to find a solution to my problem. Unfortunately, people who have posted on the forums have SIMILAR but not the exact problem as I have. I would like to take this opportunity and explain exactly whats been going...
Performance & Maintenance
W7 Slow Boot Time and Overall Slow performance
Hi new to these forums and I'm hoping someone can help me out here. I formated my HDD and did a clean install (W7 7100 build) but I'm noticing slow boot times and slow performance compared to Vista x64. W7 boots at least 10secs slower and programs tend to lag (aren't as snappy compared to...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:13.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App