Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Star Wars Forces of Corruption Problem With Multiplayer

10 Jul 2011   #11

Windows 7 Ultimate 64 bit
How do I install the RAM patch.

I downloaded the patch but it cant find the game files. (and please tell me how to put the Vista patch in.) I am still learning.

My System SpecsSystem Spec

 Star Wars Forces of Corruption Problem With Multiplayer

Thread Tools

Similar help and support threads
Thread Forum
Star Wars Empire at War Forces of Corruption
I cannot for the life of me get this to work, regular Star Wars - EAW works fine but when I try to play the FOC expansion it won't work and I get this exeption that I uploaded to be read. Windows 7 Home Premium 64-Bit 12GB of RAM GeForce GTX 295 Why won't it work?!
Star Wars battlefront 2 Crashing problem
im not sure if anyone else is having this trouble with Star Wars Battlefront 2, but every time i go to start a game, it crashes to the desktop. I am running Windows 7 7600. This game has worked on my computer before when i ran Windows Vista. I have also installed the 1.1 patch and it still doesn't...
Star Wars Battlefront 2 Problem
I just reinstalled Battlefront 2, the menu in game is at a low frame rate for some reason. And the maps do not load. Before I installed Windows 7 (was using Vista), I had a similar loading problem, it would take roughly a minute for a map to load, but now they don't load at all. Operating...
Star wars empire at war;forces of corruption issue
Me and my friend have modded our games. and i have vista and the mod works fine. but he has Windows 7 and when he starts the mod it says it cant find the file path C:\Program Files\LucasArts\Star Wars Empire at War Forces of Corruption\swfoc.exe it says please check the file pth and try...
Star wars forces of corruption won't work!
I've tried every single solution posted and none of them have worked like the patch from I can't seem to figure it out.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:28.
Twitter Facebook Google+