Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New to forums unable to get D2 to work

07 May 2009   #1

Win7 RC Build 7100
New to forums unable to get D2 to work

Hi there,

I am new to the forums, not so much new to Win7. I have upgraded from Vista Ultimate 64 to Windows 7 RC 64 just recently, and proceeded to get the VPC working without any problems.

Here is the problem. I have the original discs for the Diablo 2 game and a burned copy of the expansion. I originally got it installed to Vista Ultimate and was unable to run even after patching from the blizzard site instructions and downloads, running in compatibility mode and running as Admin. So I said screw it. Waited until 7 came out to try again in the VPC. Got Diablo 2 installed and was going through the video test and did not see the emulated graphics card so it couldnt proceed. Was ok and tried running the exp installer, the VPC sees it, double click on it, hour glass for a few seconds and nothing happens. Go to 7 and it opens up no problem. Tried just running D2 from the start menu and it does the same thing; hour glass for a few seconds and then nothing, doesn't ask for play disc regardless if it is in the comp or not. Is there anything else I can do because I really do not want to have a tri-boot again. I am really excited for the VPC as I have VMWare on Lenny and enjoy it greatly.

My rig is:
P5N-D, E8500, GTX 260, 8GB Gskill Ram (I know, useless in VPC since its a 32 bit), Asus Xonar DX, Corsair 750.

My System SpecsSystem Spec
08 May 2009   #2

Win7 RC Build 7100

Fixed compatibility issues

I've gotten Diablo 2 + Exp working on Windows 7 Ultimate RC1 x64. At first it wouldn't work using the desktop icon placed by the game installer. Edited the DEP and ran the game.exe in the program directory as admin and in compatibility mode SP2 after upgrading the game to 1.12a download from support center. There is a little issue with the sound when alt+tab'ing and reentering the game, but other than that there is no issues with gameplay on
My System SpecsSystem Spec

 New to forums unable to get D2 to work

Thread Tools

Similar help and support threads
Thread Forum
AeroPeak Disabled Check all forums still cant get it to work
Hello, Recently i cleaned my computer with Zemna AntiMalware as I had a redirect browser malware on my machine. It has cleaned it all and cannot see it anymore all redirects gone. Since running my computer with Zemna AntiMalware, my Aero Peak desktop has gone. I no longer can also change the...
Windows Firewall Service unable to activate, SFC scan unable to work
Well I got a big problem. A couple days ago I noticed network connectivity issues. Random connection drops, overall bad connection, etc. I recently had some really bad malware and I removed it, so I suspected leftover malware from the start. I went to check Windows Update to see if I missed a...
System Security
Seven Forums, Eight Forums, Registration question
Do I have to register a new account on Eight Forums or will my Seven Forums account work there too?
Chillout Room
Seven Forums at work?
While I am sitting at work, reading the forums I have noticed many people say "I will do that when I get home from work".. or something to that effect, which makes me wonder... Do you browse the forums at work and if so how much? Personally work is really slow so I have nothing else to do......
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:59.
Twitter Facebook Google+