Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Red Faction 1 on windows 7

08 May 2009   #1
MasBlaMan

 
 
Red Faction 1 on windows 7

So here I am trying to play at Red Faction 1.
Install went ok, then patching still ok. Patch v1.30.
Launcher pops up and asks for setup. I do that.
Then I click PLAY and... screen goes dark for a sec, then back to desktop and a srot of error msg saying:

"Missing Features:
At least 8 MB of available video memory is required to run Red Faction!"

Sooooo whats the hubub?

And yes I did try run as admin and troubleshoot compatibility and compatibility mode xp and vista w and w/o sps. Played around with the Red Faction setup to. Same msg.

My setup:
MB: asus p6t6 ws revolution latest bios
CPU: i7 920 with 3g ram
VGA: asus gtx 295 driver: v185.85
OS: w7rc 32bits patched

Thanks for reading.

Solution:


I had to download Pure Faction from: purefaction.org (click Download on the left under Site Menu for link and instructions)

With this I just had to disable multy GPU in the nVidia control panel. It seems that Red Factions engine cant support multiple GPUs. Or ist a nVidia driver problem.

And voila... the game works.

Finished the game, no bug encounter.

Thanks to TrotSkie from purefaction.org


My System SpecsSystem Spec
.
17 Jun 2009   #2
Deathdread

Windows 7 x64 RC1 b.7100
 
 

Hey, im working with this issue, my pc is a little older but same issue, it has to do with the issue of to much ram, the game can only read up to 2gb of ram on a single pc!

So either pull some sticks, run a virtual OS with modded ram total used!

I'm going to keep looking for a way around this or some kind of way to tell the game that the memory is always 2gb total and run!

Ill post more info later.
My System SpecsSystem Spec
21 Jun 2009   #3
MasBlaMan

 
 

You ware correct.

By using msconfig > Boot tab > Advanced options... and setting Maximum memory to 2048 I was successful in launching the game.

However the game is not playable. There seems to be a problem with the polygons that are creating the environment. I can see trough walls, I see strange surfaces with artefacts on them. I do not think the video card is the problem since I run newer games with out any problems.

I will keep searching...
My System SpecsSystem Spec
.

22 Jun 2009   #4
Deathdread

Windows 7 x64 RC1 b.7100
 
 

Well, well, thanks for that other bit of help. Anyway, I have no graphics problems, all good. It is becuase nvidia kinda has this wierd bug that can be fixed, i think it was a mipmaping or aa bug, try shutting those off and see what happens. LOL, i have ATI, but both are good cards, so good luck and enjoy, i love it except there is no auto saves, if you dont save alot you have to play all the way at the very begining, aaarrrrgggg!

Hope rf2 is good, im gonna down it to play after 1, hehe, yay.

Well good luck and glad I could help.
My System SpecsSystem Spec
23 Jun 2009   #5
MasBlaMan

 
 

Yay!!!!

I finally did it. I had to download Pure Faction from: purefaction.org (click Download on the left under Site Menu for link and instructions)

With this I just had to disable multy GPU in the nVidia control panel. It seems that Red Factions engine cant support multiple GPUs. Or ist a nVidia driver problem.

And voila... the game works.

Oh btw with PF you dont need to tweek the msconfig. It just works and has some interesting options. All this thanks to TrotSkie.

Enjoy!
My System SpecsSystem Spec
22 Jan 2010   #6
kuliddar

Windows 7 Home Premium x86
 
 

Confirmed about the "purefaction.org" patch. Had graphical issues with Win7. This fixed it and the game plays fine now!
My System SpecsSystem Spec
27 Feb 2010   #7
subyroo

Dual Boot of WinXP Pro SP3 & Windows 7 Ultimate 64 bit
 
 

I've run the PF installer and setup my resolution etc but it keeps telling DirectX 8 failed to load properly when I try to play the game.

Anybody have an idea on what is going wrong?

P.S. I had run a No CD crack prior to finding and installing PF, I will uninstall the game and start afresh to see if that makes a difference ......... standby.
My System SpecsSystem Spec
Reply

 Red Faction 1 on windows 7




Thread Tools




Similar help and support threads
Thread Forum
Steam Deal - Red Faction Collection
Just picked up Red Faction Collection from Steam for $11.99 (U.S.) - 80 percent off. Collection includes Red Faction 1, 2, Guerilla, Armageddon, Armageddon DLC: Path to War. These can also be purchased separately as well. I believe this is a weekend only deal so... Save 80% on Red...
Gaming
BSOD playing Red Faction/other Games, related to win32k.sys
Hi Sevenforum Members, i hope you can help me with my PC problems. My System: Windows 7 64 Ultimate OEM Version (Installed myself) - What is the age of system (hardware)? Just recently bought a new mainboard,cpu,memory - What is the age of OS installation (have you re-installed the OS?) ...
BSOD Help and Support
Red Faction Guerrilla!
All system specs are okay and i know many others are having the same problems but i was wandering if anyone has a solution on these forums. I can start the game fine but it laggs slightly and the main characters coat flaps wildly and randomly all over the screen and sometimes even disappears....
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App