Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empire 2 not working Win 7

03 Jul 2010   #1

64 bit
Age of Empire 2 not working Win 7

Age of Empires 2 The Age of Kings & Age of Empires 2 The conquerors expansion not working.

The game installs fine but when I go to play it I get a loading screen. The game never loads. The loading screen disappears and nothing. If I go to task menu it does not even show the game. I downloaded the latest DirectX (DirectX 9.0 Web setup) I also have turned off all boot start ups. Still nothing works! Now I go to Welcome ValuSoft, a division of THQ, Inc. Online Store as it says and follow the 1000 easy steps they give to fix this (enraged sarcasm). Yet it still don' work. Yet to top it off and find not a single email or contact on the site. hehehe yes I love it when they do this! Now I am here hoping someone can help me with this.

Dell Inspiron 19
Pentium(R) Dual-core CPU E5400 @ 7.70GHz 2.69

My System SpecsSystem Spec
03 Jul 2010   #2

Microsoft Window 7 Professional 32 bit

Have you install the .Netframework 2 for the games?

My System SpecsSystem Spec
03 Jul 2010   #3

64 bit

I have .Netframework 4. Do I need to go back to #2?
Age of Empire 1 works fine on my computer.

Also I took a screen shot so you can see the screen I see before it disappears. And just for a little bit more info this is a store bought game not burned and its bran new.
My System SpecsSystem Spec

03 Jul 2010   #4

windows 7 home premuim x64

try changing the compatibility settings for the age of empires.exe.
1:right click on the shortcut

2:click "open file location"

3:right click on the .exe

4:click on the compatability tab

5:check the "run this program in compatability mode for:" box

6:make sure windows xp (doesnt matter wat service pack, i usualy do pack 2 just to be safe) is selected in the drop down box.

7:click apply and try running the .exe

hope it works
My System SpecsSystem Spec

 Age of Empire 2 not working Win 7

Thread Tools

Similar help and support threads
Thread Forum
Empire Total War, can you run it?
Hello everyone! excelent forum. I have a problem with Empire Total War: I have this computer: AMD X2 6000+ 2gb ram nvidia 8600gts Windows 7 build 7057 I can't run Empire Total War full version.I've tried with compatibility modes and "run as administrator", I reinstalled directx and I...
not able to run age of empire 3 in window 7 ultimate 32 bit
hey friends i m not able to run age of empire 3 game on my computer which runs on window 7 ultimate 32 bit having intel chipset g33/g31 and graphics of intel gma 3100. when i run this game a dialoge box with notification that this game is not compatible with this...
All help welcome - empire total war
Game was working find up till yesterday. Over night downloaded a set of Windows 7 updates (security etc) and no game hangs at intro screen. I have updated my drivers but still having the same problem. All help gratefully received. I have looked at the other Empire threads on the forum and...
Age of Empire 3 No Audio
Hi folks I need help. I installed AoE3 in my computer but when I restart, Windows Audio service won't run and all programs that checks system specs can't run. My Computer (the desktop shortcut) keeps on saying: "There is not enough free memory to run this program. Exit one or more programs, and...
Sound & Audio
Empire Total War still reboots PC
Hey guys, I posted this thread before, Sadly, it is still happening. After getting an extra 4GB of Kingston Ram and updating all my drivers, the game still crashes. It is getting really fustrating...really. Never...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:32.
Twitter Facebook Google+