Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Game won't even install issue (x64 compatibility error)

16 Jul 2010   #1

Mac OS X / Windows 7
Game won't even install issue (x64 compatibility error)

I looked here in Seven Forums for this known error and have found some threads about it. However, none of them had a solution of any kind, and that's why I'm creating this new thread. I am having the exact same issue, and I hope to find a solution because it's really annoying by now.

I have had this error in more than two games, so that's why I think this is not a specific game error no longer. What's more strange is that for test purposes, I tried installing again a game I had previous installed succesfully (Assassins Creed II), and this second time, I had this error message.

It happens when the installation is supposed to begin. When the installation executes a Setup.exe, Installer.exe or some file like this one, the main installation file of the game, it stops immediately with the following error message:

The version of this file is not compatible with version of Windows you're running. Check your computer's system information to see whether you need an x86 (32 bit) or x64 (64 bit) version of the program, and then contact the software publisher.

I had installed before Assassins Creed II and FIFA2010, and both went fine. Then I tried installing, other day, Arkham Asylum and Left4Dead 2. On both of them, I had this error. Then I tried installing, again, FIFA2010 and Assassins Creed II so I could prove that the previous games were damaged or something, but I had again this error and now with games I had just the day before installed.

Then to go further, I downloaded on the web image files for those games (ISO), just to make sure there was something wrong with the computer, not the disc itself. I emulated the ISO files, and the .exe files inside it such as Installer or Setup.exe, when I double-click them, they come up with the same error message stated before.

I really don't know what happened in just one day that messed up my system. What I can assure is that is NOT a disc/image corruption of some kind.

I tried a lot of things, none of them worked. So I literally BEG for a solution. The bottom line is: Windows 7 Ultimate 64-bit (x64) is not accepting to install game's .exe files from disc or ISO file.

My System SpecsSystem Spec
16 Jul 2010   #2

Mc Donald OS Version Beta

where did you get the iso files?

Note: You may consider running the exe files as Admin Mode.
My System SpecsSystem Spec
16 Jul 2010   #3

Mac OS X / Windows 7

I properly downloaded them from torrent trackers (to be more specific, from torrentleech).

They all have been reported as functional, and are from what appears to be trustworthy groups.

I forgot to mention that I have already tried running as admin (do you mean that mode in right click, right?) and also in Compatibility mode (tried Vista SP2, SP3 and XP).

Nothing seems to work.

I also tried different softwares with the ISO images (Daemon Tools, Alcohol120% and another one).

The most strange thing is the installation discs that worked before and now are also with the same issue. Something changed, I just don't know what.

Oh yeah, I forgot to mention that when I start emulating the ISO images, the Autorun is strange. Before it showed a Setup.exe to click on with the game's icon, now it only shows a folder to click on it and then it opens the folder with the files on it. Really strange. Doesnt seem like a Autorun of a game at all.
My System SpecsSystem Spec

17 Jul 2010   #4

Mac OS X / Windows 7

Well, I finally found a solution. Actually, in my case at least, it was a Mac OS X / Windows 7 issue.

I don't know about the discs, but Windows 7 was reading the .iso files as OS X file, or something like that. This happened in Boot Camp (Windows 7), when I copied the .iso files from Mac OS X to Windows directly from Windows.

Then to solve this, I logged in OS X and copied from there the .iso files to Windows 7 partition. Worked perfectly.

This is my solution, I hope it helps someone, someday.

My System SpecsSystem Spec

 Game won't even install issue (x64 compatibility error)

Thread Tools

Similar help and support threads
Thread Forum
Fresh install Windows 7 and game compatibility
Hi, I would like to ask - I have two partitions on HDD C: for system and programs and D: for games and my files, if I ever want to install fresh Windows 7 x64 Home Premium (right now have exact same system) and format this C: partioin before install, do all insalled games on D: would still work on...
How can I play this game, error message relating to compatibility?
So I recently bought and downloaded a game, Hearts of Iron 3 (2009). Now every time I click to play it I receive a pop up with this message. "The version of this file is not compatible with the version of windows you're running. Check your computers system information to see whether you need...
Windows 7 game compatibility issue
Alright, I got an issue. I want to play Age of Empires II: Age of Kings. I'm running Windows 7 64bit. Only thing is, when I put it in to install it, it says "Windows cannot access this disc......This disc might be corrupt, make sure that the disc uses a format that Windows recognizes. Only...
Old game, 64-bit compatibility issue
Hey there. I'm trying to install this old game that ran on Windows 95/98. The problem is that it's incompatible with my 64-bit Windows 7, so despite running the installer using Compatibility Mode, it still doesn't work. Is there any way to get it to work?
Windows7 install compatibility issue
I have two computers that are running Win XP Home and one that is running Win Xp Media Center Edition. Will I have any problems upgrading the Win Xp Media Center Edition? Currently I'm trying to upgrade the system with Win Xp Home. It has a Gigabyte AMD AM2 Socket (GA-M57 SLI-S4) motherboard, AMD...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:47.
Twitter Facebook Google+